aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-11-11 16:14:29 +0800
committermarino <marino@FreeBSD.org>2015-11-11 16:14:29 +0800
commitfd85c9993973ac19e2489d89e595446ab0abe32c (patch)
treeef144a0adf477d2b396dd00427f32078f7ec347f /finance
parent626f5d962416dab3dfdb59ad267e1ab4045b75ae (diff)
downloadfreebsd-ports-gnome-fd85c9993973ac19e2489d89e595446ab0abe32c.tar.gz
freebsd-ports-gnome-fd85c9993973ac19e2489d89e595446ab0abe32c.tar.zst
freebsd-ports-gnome-fd85c9993973ac19e2489d89e595446ab0abe32c.zip
finance/ledger: Convert to USES=libedit
Approved by: infrastructure modernization
Diffstat (limited to 'finance')
-rw-r--r--finance/ledger/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/finance/ledger/Makefile b/finance/ledger/Makefile
index f9a8a4ecb604..b06720ee1cc0 100644
--- a/finance/ledger/Makefile
+++ b/finance/ledger/Makefile
@@ -15,13 +15,12 @@ LICENSE_FILE= ${WRKSRC}/doc/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:${PORTSDIR}/devel/utf8cpp
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libmpfr.so:${PORTSDIR}/math/mpfr \
- libedit.so.0:${PORTSDIR}/devel/libedit \
libboost_system.so:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
USE_LDCONFIG= yes
-USES= cmake compiler:c++11-lib
+USES= cmake compiler:c++11-lib libedit
CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
-DCMAKE_INCLUDE_PATH=${LOCALBASE}/include