aboutsummaryrefslogtreecommitdiffstats
path: root/french
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-17 14:06:55 +0800
committermaho <maho@FreeBSD.org>2007-01-17 14:06:55 +0800
commit09839eaa6edd715b940e3bec8086fd072cd0ec5b (patch)
tree95e13883714668f4f33e3e9ab732ef1944783c4a /french
parent5bdb96256c8b6e35d6ca0d54fed1259bf3fecb0d (diff)
downloadfreebsd-ports-gnome-09839eaa6edd715b940e3bec8086fd072cd0ec5b.tar.gz
freebsd-ports-gnome-09839eaa6edd715b940e3bec8086fd072cd0ec5b.tar.zst
freebsd-ports-gnome-09839eaa6edd715b940e3bec8086fd072cd0ec5b.zip
* Migrate to gfortran.
* Bump port revision. * Always use F90.
Diffstat (limited to 'french')
-rw-r--r--french/med/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/french/med/Makefile b/french/med/Makefile
index 28c1754766eb..e57223888a4b 100644
--- a/french/med/Makefile
+++ b/french/med/Makefile
@@ -7,6 +7,7 @@
PORTNAME= med
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= french science
MASTER_SITES= http://www.code-aster.org/FICHIERS/
@@ -20,29 +21,27 @@ RUN_DEPENDS= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
TK_VER?= 8.4
SHORT_TK_VER= ${TK_VER:S/.//}
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+FFLAGS+= -O2
+
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= HDF5HOME=${LOCALBASE} CPPFLAGS="${PTHREAD_CFLAGS}" \
- LDFLAGS="${PTHREAD_LIBS}" WISH=${LOCALBASE}/bin/wish${TK_VER}
+CONFIGURE_ENV+= HDF5HOME=${LOCALBASE} CPPFLAGS="${PTHREAD_CFLAGS}" \
+ LDFLAGS="${PTHREAD_LIBS}" WISH=${LOCALBASE}/bin/wish${TK_VER} \
+ --with-f90=${FC}
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259 libtool:15
USE_LDCONFIG= yes
-.if !defined(WITHOUT_F90)
-F90= gfortran41
-BUILD_DEPENDS+= ${F90}:${PORTSDIR}/lang/gfortran
-CONFIGURE_ARGS+= --with-f90=${F90}
-.endif
-
DOC2FIX= . gif html jpg png tests
TST2FIX= c f
.include <bsd.port.pre.mk>
-.if !${OSVERSION} < 500039
-F77?= f77
-.endif
-FFLAGS?= -O2
-
pre-configure:
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|SUBDIRS = src tests tools doc|SUBDIRS = src tests tools|' \