aboutsummaryrefslogtreecommitdiffstats
path: root/french
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 22:26:52 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 22:26:52 +0800
commitb7181f1421862fea4ad24727d396f2c6c24cd637 (patch)
tree79beb491a32954098cb4f856cfffd64ab11fe705 /french
parent24111c07872c7a69e978fc0094d626c395ae8e60 (diff)
downloadfreebsd-ports-gnome-b7181f1421862fea4ad24727d396f2c6c24cd637.tar.gz
freebsd-ports-gnome-b7181f1421862fea4ad24727d396f2c6c24cd637.tar.zst
freebsd-ports-gnome-b7181f1421862fea4ad24727d396f2c6c24cd637.zip
Remove patches that added an autotools based build system and instead use
do-build and do-install targets
Diffstat (limited to 'french')
-rw-r--r--french/dico/Makefile37
-rw-r--r--french/dico/files/patch-Makefile.am7
-rw-r--r--french/dico/files/patch-configure.in7
-rw-r--r--french/dico/files/patch-lexique-Makefile.am7
-rw-r--r--french/dico/files/patch-lexique-version.dic9
-rw-r--r--french/dico/files/patch-manuel-Makefile.am10
-rw-r--r--french/dico/files/patch-sources-Makefile.am4
-rw-r--r--french/dico/files/patch-sources-dico.c9
8 files changed, 17 insertions, 73 deletions
diff --git a/french/dico/Makefile b/french/dico/Makefile
index 363d088b4e05..6cfea0e9d6b9 100644
--- a/french/dico/Makefile
+++ b/french/dico/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dico
PORTVERSION= 1.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= french
MASTER_SITES= ftp://ftp.supelec.fr/lsi/pub/security/
DISTNAME= le_dico
@@ -13,30 +13,27 @@ COMMENT= Interactive dictionary in french
BROKEN_WWW= http://www.montefiore.ulg.ac.be/cgi-bin-ulg/DICO.html
-# Global variables
-#
-
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_AUTOTOOLS= automake14 autoconf
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
-USES= gmake
-AUTOMAKE_ARGS= --add-missing --foreign --include-deps
-MAKE_ARGS= prefix=${PREFIX}
-REINPLACE_SUB= PREFIX=${PREFIX}
-
-# Post-patch
-#
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${WRKSRC}/sources/dico.c
+do-build:
+ (cd ${WRKSRC}/sources && ${CC} ${CFLAGS} ${LDFLAGS} -o dico dico.c)
-# Pre-configure
-#
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/sources/dico ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/lexique/*.dic ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.TXT ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manuel/copying.doc ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/manuel/dico.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-pre-configure:
- @cd ${WRKSRC} && ${ACLOCAL}
+post-patch:
+ @${REINPLACE_CMD} 's,/usr/local,${PREFIX},' \
+ ${WRKSRC}/README.TXT ${WRKSRC}/manuel/dico.1 \
+ ${WRKSRC}/sources/dico.c
.include <bsd.port.mk>
diff --git a/french/dico/files/patch-Makefile.am b/french/dico/files/patch-Makefile.am
deleted file mode 100644
index f2e7f0e46422..000000000000
--- a/french/dico/files/patch-Makefile.am
+++ /dev/null
@@ -1,7 +0,0 @@
---- /dev/null Thu Jan 1 01:00:00 1970
-+++ Makefile.am Wed Oct 11 03:49:06 2000
-@@ -0,0 +1,4 @@
-+docdir = $(datadir)/doc/dico
-+doc_DATA = README.TXT
-+
-+SUBDIRS = sources lexique manuel
diff --git a/french/dico/files/patch-configure.in b/french/dico/files/patch-configure.in
deleted file mode 100644
index 832ee4d5ce4d..000000000000
--- a/french/dico/files/patch-configure.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- /dev/null Thu Jan 1 01:00:00 1970
-+++ configure.in Wed Oct 11 04:19:05 2000
-@@ -0,0 +1,4 @@
-+AC_INIT(sources/dico.c)
-+AM_INIT_AUTOMAKE(dico, 1.1)
-+AC_PROG_CC
-+AC_OUTPUT([Makefile sources/Makefile lexique/Makefile manuel/Makefile])
diff --git a/french/dico/files/patch-lexique-Makefile.am b/french/dico/files/patch-lexique-Makefile.am
deleted file mode 100644
index 3d164d3e962b..000000000000
--- a/french/dico/files/patch-lexique-Makefile.am
+++ /dev/null
@@ -1,7 +0,0 @@
---- /dev/null Thu Jan 1 01:00:00 1970
-+++ lexique/Makefile.am Wed Oct 11 04:40:58 2000
-@@ -0,0 +1,4 @@
-+pkgdata_DATA = a.dic b.dic c.dic d.dic e.dic f.dic g.dic h.dic \
-+ i.dic j.dic k.dic l.dic m.dic n.dic o.dic p.dic \
-+ q.dic r.dic s.dic t.dic u.dic v.dic w.dic x.dic \
-+ y.dic z.dic version.dic
diff --git a/french/dico/files/patch-lexique-version.dic b/french/dico/files/patch-lexique-version.dic
deleted file mode 100644
index 97926141b99f..000000000000
--- a/french/dico/files/patch-lexique-version.dic
+++ /dev/null
@@ -1,9 +0,0 @@
---- old/lexique/version.dic Thu Jan 1 01:00:00 1970
-+++ new/lexique/version.dic Wed Oct 11 04:40:35 2000
-@@ -0,0 +1,6 @@
-+Derniere mise a jour: 21 Octobre 1992
-+Realisee par : Rene Cougnenc
-+Jeu de caracteres : ISO 8859-1 ( 8 bits Latin-1)
-+
-+ 94836 mots
-++ 39072 communes de France
diff --git a/french/dico/files/patch-manuel-Makefile.am b/french/dico/files/patch-manuel-Makefile.am
deleted file mode 100644
index 8bfc4f7e96b1..000000000000
--- a/french/dico/files/patch-manuel-Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- /dev/null Thu Jan 1 01:00:00 1970
-+++ manuel/Makefile.am Wed Oct 11 03:46:58 2000
-@@ -0,0 +1,7 @@
-+docdir = $(datadir)/doc/dico
-+doc_DATA = copying.doc
-+
-+man_MANS = dico.1
-+
-+EXTRA_DISTS = install.doc.msdos manuel.txt msdos.doc readme.txt.msdos \
-+ unix.doc
diff --git a/french/dico/files/patch-sources-Makefile.am b/french/dico/files/patch-sources-Makefile.am
deleted file mode 100644
index 486ee5a9febc..000000000000
--- a/french/dico/files/patch-sources-Makefile.am
+++ /dev/null
@@ -1,4 +0,0 @@
---- /dev/null Thu Jan 1 01:00:00 1970
-+++ sources/Makefile.am Wed Oct 11 03:35:13 2000
-@@ -0,0 +1 @@
-+bin_PROGRAMS = dico
diff --git a/french/dico/files/patch-sources-dico.c b/french/dico/files/patch-sources-dico.c
index 82849cd446b9..4ccbed7f9621 100644
--- a/french/dico/files/patch-sources-dico.c
+++ b/french/dico/files/patch-sources-dico.c
@@ -29,15 +29,6 @@
#ifdef MSDOS /* Systeme d'operation de disque */
#define MYOS "MSDOS" /* Microsoft :-) */
#endif
-@@ -49,7 +57,7 @@
- #define ISO_TERM 3
- #define COMMENT_CHAR 35 /* '#' ligne de commentaire */
-
--#define DICT_PATH "/usr/local/lib/dico" /* path par defaut unix/dos */
-+#define DICT_PATH "%%PREFIX%%/share/dico" /* path par defaut unix/dos */
- #define DOS_PATH "lexique" /* path par defaut Dos uniquement */
- #define DICT_EXT ".dic" /* extension des fichiers dicos */
- #define VERSION_FILE "version.dic" /* fichier texte version dico */
@@ -58,11 +66,13 @@
#define OK 0
#define MYVBUF 10240 /* pour setvbuf() eventuel */