aboutsummaryrefslogtreecommitdiffstats
path: root/french
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
commite7533864e7a7574c2d1b20a6b10f81c0561e4621 (patch)
tree709c0318625f1fe2eca8e12b791e969926c96e91 /french
parent3bc9ecccbd8279e4254d8eade21cc1a1837decfb (diff)
downloadfreebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.gz
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.zst
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.zip
- Move language prefix to PKGNAMEPREFIX
- Use DATADIR - Use PLIST_DIRSTRY for DATADIR - Explicitly list installing filenames - Bump PORTREVISION for PORTNAME and PLIST change - Sort PLIST - Cosmetic change
Diffstat (limited to 'french')
-rw-r--r--french/hunspell/Makefile27
-rw-r--r--french/hyphen/Makefile21
-rw-r--r--french/mythes/Makefile31
3 files changed, 38 insertions, 41 deletions
diff --git a/french/hunspell/Makefile b/french/hunspell/Makefile
index bd2685374462..2ce5c0377e3f 100644
--- a/french/hunspell/Makefile
+++ b/french/hunspell/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hunspell
PORTVERSION= 4.2
+PORTREVISION= 1
CATEGORIES= french textproc
MASTER_SITES= http://www.dicollecte.org/download/fr/
DISTNAME= hunspell-fr-moderne-v${PORTVERSION}
@@ -17,23 +18,23 @@ COMMENT= Hunspell modern french dictionary
USE_ZIP= yes
NO_BUILD= yes
+PLIST_FILES= %%DATADIR%%/fr_FR.aff \
+ %%DATADIR%%/fr_FR.dic
+PLIST_DIRSTRY= %%DATADIR%%
+
FRALIASES= fr_BE fr_CA fr_CH fr_LU
-PLIST_FILES= share/hunspell/fr_FR.aff \
- share/hunspell/fr_FR.dic
.for ALIAS in ${FRALIASES}
-PLIST_FILES+= share/hunspell/${ALIAS}.aff \
- share/hunspell/${ALIAS}.dic
+PLIST_FILES+= %%DATADIR%%/${ALIAS}.aff \
+ %%DATADIR%%/${ALIAS}.dic
.endfor
-PLIST_DIRS= share/hunspell
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKDIR}/fr-moderne.aff ${PREFIX}/share/hunspell/fr_FR.aff
- @${INSTALL_DATA} ${WRKDIR}/fr-moderne.dic ${PREFIX}/share/hunspell/fr_FR.dic
- @cd ${PREFIX}/share/hunspell; \
- for alias in ${FRALIASES}; do \
- ${LN} -s fr_FR.aff $${alias}.aff ; \
- ${LN} -s fr_FR.dic $${alias}.dic ; \
- done
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKDIR}/fr-moderne.aff ${DATADIR}/fr_FR.aff
+ ${INSTALL_DATA} ${WRKDIR}/fr-moderne.dic ${DATADIR}/fr_FR.dic
+.for ALIAS in ${FRALIASES}
+ ${LN} -s fr_FR.aff ${DATADIR}/${ALIAS}.aff
+ ${LN} -s fr_FR.dic ${DATADIR}/${ALIAS}.dic
+.endfor
.include <bsd.port.mk>
diff --git a/french/hyphen/Makefile b/french/hyphen/Makefile
index 8a31ee9a3b49..b1c5200b86c0 100644
--- a/french/hyphen/Makefile
+++ b/french/hyphen/Makefile
@@ -7,8 +7,7 @@
PORTNAME= hyphen
PORTVERSION= 2.0
-#PORTREVISION= 0
-#PORTEPOCH= 0
+PORTREVISION= 1
CATEGORIES= french textproc
MASTER_SITES= http://www.dicollecte.org/download/fr/
DISTNAME= hyph_fr_${PORTVERSION:S/./-/}
@@ -19,21 +18,19 @@ COMMENT= French hyphenation rules
USE_ZIP= yes
NO_BUILD= yes
-PLIST_FILES= share/hyphen/hyph_fr_FR.dic
+PLIST_FILES= %%DATADIR%%/hyph_fr_FR.dic
+PLIST_DIRSTRY= %%DATADIR%%
FRALIASES= fr_BE fr_CA fr_CH fr_LU
-
.for ALIAS in ${FRALIASES}
-PLIST_FILES+= share/hyphen/hyph_${ALIAS}.dic
+PLIST_FILES+= %%DATADIR%%/hyph_${ALIAS}.dic
.endfor
-PLIST_DIRS= share/hyphen
do-install:
- @${MKDIR} ${PREFIX}/share/hyphen
- @${INSTALL_DATA} ${WRKDIR}/hyph_fr_FR.dic ${PREFIX}/share/hyphen
- @cd ${PREFIX}/share/hyphen; \
- for alias in ${FRALIASES}; do \
- ${LN} -s hyph_fr_FR.dic hyph_$${alias}.dic ; \
- done
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKDIR}/hyph_fr_FR.dic ${DATADIR}/
+.for ALIAS in ${FRALIASES}
+ ${LN} -s hyph_fr_FR.dic ${DATADIR}/hyph_${ALIAS}.dic
+.endfor
.include <bsd.port.mk>
diff --git a/french/mythes/Makefile b/french/mythes/Makefile
index 297211e54e54..3101c5ed697e 100644
--- a/french/mythes/Makefile
+++ b/french/mythes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mythes
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= french textproc
MASTER_SITES= http://www.dicollecte.org/download/fr/
DISTNAME= thesaurus-v${PORTVERSION}
@@ -18,27 +19,25 @@ LICENSE= LGPL21
USE_ZIP= yes
NO_BUILD= yes
+NO_WRKSUBDIR= yes
-FRALIASES= fr_BE fr_CA fr_CH fr_LU
-
-PLIST_FILES= share/mythes/th_fr_FR_v2.dat \
- share/mythes/th_fr_FR_v2.idx
+PLIST_FILES= %%DATADIR%%/th_fr_FR_v2.dat \
+ %%DATADIR%%/th_fr_FR_v2.idx
+PLIST_DIRSTRY= %%DATADIR%%
+FRALIASES= fr_BE fr_CA fr_CH fr_LU
.for ALIAS in ${FRALIASES}
-PLIST_FILES+= share/mythes/th_${ALIAS}_v2.dat \
- share/mythes/th_${ALIAS}_v2.idx
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
.endfor
-PLIST_DIRS= share/mythes
-
do-install:
- @${MKDIR} ${PREFIX}/share/mythes
- @${INSTALL_DATA} ${WRKDIR}/thes_fr.dat ${PREFIX}/share/mythes/th_fr_FR_v2.dat
- @${INSTALL_DATA} ${WRKDIR}/thes_fr.idx ${PREFIX}/share/mythes/th_fr_FR_v2.idx
- @cd ${PREFIX}/share/mythes; \
- for alias in ${FRALIASES}; do \
- ${LN} -s th_fr_FR_v2.idx th_$${alias}_v2.idx ; \
- ${LN} -s th_fr_FR_v2.dat th_$${alias}_v2.dat ; \
- done
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.dat ${DATADIR}/th_fr_FR_v2.dat
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.idx ${DATADIR}/th_fr_FR_v2.idx
+.for ALIAS in ${FRALIASES}
+ ${LN} -s th_fr_FR_v2.dat ${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_fr_FR_v2.idx ${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
.include <bsd.port.mk>