aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-03-28 18:05:23 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-03-28 18:05:23 +0800
commit48c22392d8860f1007feb331354f536b806c1817 (patch)
tree4b714a68cb6abf3dbe59b0306afb8d7c9588807c /ftp/curl/Makefile
parent42c19ad48723e9980023710c182a21d4e7a9df92 (diff)
downloadfreebsd-ports-gnome-48c22392d8860f1007feb331354f536b806c1817.tar.gz
freebsd-ports-gnome-48c22392d8860f1007feb331354f536b806c1817.tar.zst
freebsd-ports-gnome-48c22392d8860f1007feb331354f536b806c1817.zip
- Remove CYASSL option until upstream supports WolfSSL (new name of CyaSSL)
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index b0109d82486a..05105a8ad596 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -16,7 +16,7 @@ OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES HTTP2 IDN IPV6
OPTIONS_RADIO= GSSAPI RESOLV SSL
OPTIONS_RADIO_GSSAPI= GSSAPI_BASE HEIMDAL_PORT KRB5_PORT
OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER
-OPTIONS_RADIO_SSL= CYASSL GNUTLS NSS OPENSSL POLARSSL
+OPTIONS_RADIO_SSL= GNUTLS NSS OPENSSL POLARSSL
OPTIONS_DEFAULT=CA_BUNDLE COOKIES GSSAPI_BASE IPV6 OPENSSL PROXY RESOLV THREADED_RESOLVER SSL TLS_SRP
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
COOKIES_DESC= Cookies support
@@ -72,9 +72,6 @@ COOKIES_CONFIGURE_OFF= --disable-cookies
COOKIES_CONFIGURE_ON= --enable-cookies
CURL_DEBUG_CONFIGURE_OFF= --disable-curldebug
CURL_DEBUG_CONFIGURE_ON=--enable-curldebug
-CYASSL_CONFIGURE_OFF= --without-cyassl
-CYASSL_CONFIGURE_ON= --with-cyassl=${LOCALBASE}
-CYASSL_LIB_DEPENDS= libcyassl.so:${PORTSDIR}/security/yassl
DEBUG_CONFIGURE_OFF= --disable-debug
DEBUG_CONFIGURE_ON= --enable-debug
GNUTLS_CONFIGURE_OFF= --without-gnutls
@@ -148,7 +145,7 @@ IGNORE= only supports TLS-SRP with either OpenSSL or GnuTLS
IGNORE= only supports LDAPS with LDAP
.endif
-.if ${PORT_OPTIONS:MLDAPS} && !${PORT_OPTIONS:MCYASSL} && !${PORT_OPTIONS:MGNUTLS} && !${PORT_OPTIONS:MNSS} && !${PORT_OPTIONS:MOPENSSL} && !${PORT_OPTIONS:MPOLARSSL}
+.if ${PORT_OPTIONS:MLDAPS} && !${PORT_OPTIONS:MGNUTLS} && !${PORT_OPTIONS:MNSS} && !${PORT_OPTIONS:MOPENSSL} && !${PORT_OPTIONS:MPOLARSSL}
IGNORE= only supports LDAPS with SSL
.endif