aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl/files
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2010-12-20 04:04:23 +0800
committerroam <roam@FreeBSD.org>2010-12-20 04:04:23 +0800
commit96fec6c9afc49f7bbef32c1092bcfd89b11f00bf (patch)
tree779e524fcd6c41120b58e0835ee124fe81c6e844 /ftp/curl/files
parentb4c59b19fcb5ae2e8ba8a83024b88d2dd0f81b8a (diff)
downloadfreebsd-ports-gnome-96fec6c9afc49f7bbef32c1092bcfd89b11f00bf.tar.gz
freebsd-ports-gnome-96fec6c9afc49f7bbef32c1092bcfd89b11f00bf.tar.zst
freebsd-ports-gnome-96fec6c9afc49f7bbef32c1092bcfd89b11f00bf.zip
Update cURL to 7.21.3 and fix its librtmp detection. In the process:
- disable the -Werror build option by popular demand - do not override the user's debug and optimization settings PR: 150854 (the debug and optimization CFLAGS) Reported by: Anonymous <swell.k@gmail.com>
Diffstat (limited to 'ftp/curl/files')
-rw-r--r--ftp/curl/files/patch-Makefile.in6
-rw-r--r--ftp/curl/files/patch-configure111
-rw-r--r--ftp/curl/files/patch-lib::url.c4
-rw-r--r--ftp/curl/files/patch-src::main.c6
4 files changed, 110 insertions, 17 deletions
diff --git a/ftp/curl/files/patch-Makefile.in b/ftp/curl/files/patch-Makefile.in
index 792d2b7fa1b4..33176dcc9180 100644
--- a/ftp/curl/files/patch-Makefile.in
+++ b/ftp/curl/files/patch-Makefile.in
@@ -1,11 +1,11 @@
Description: Build and install the documentation as usual, no special handling.
Forwarded: https://sourceforge.net/tracker/?func=detail&aid=2897155&group_id=976&atid=100976
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-09-12
+Last-Update: 2010-12-18
--- a/Makefile.in
+++ b/Makefile.in
-@@ -310,9 +310,9 @@
+@@ -311,9 +311,9 @@
libcurl.pc.in vc6curl.dsw MacOSX-Framework Android.mk $(CMAKE_DIST)
bin_SCRIPTS = curl-config
@@ -18,7 +18,7 @@ Last-Update: 2010-09-12
pkgconfig_DATA = libcurl.pc
all: all-recursive
-@@ -873,12 +873,10 @@
+@@ -874,12 +874,10 @@
# We extend the standard install with a custom hook:
install-data-hook:
cd include && $(MAKE) install
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 2212a3d5f530..27d26e2e1c8c 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -1,16 +1,109 @@
-Description: Fix a bashism - "test" uses "=", not "==".
-Forwarded: http://sourceforge.net/tracker/?func=detail&aid=3064939&group_id=976&atid=100976
+Description: Tweak the build for a FreeBSD environment.
+ Respect user-supplied CFLAGS
+ Use the FreeBSD location of pkg-config's library directory.
+ Check for librtmp in sensible locations in all cases.
+Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-09-12
+Last-Update: 2010-12-19
--- a/configure
+++ b/configure
-@@ -2992,7 +2992,7 @@
+@@ -14201,10 +14201,10 @@
+ flags_dbg_all="$flags_dbg_all -gdwarf-2"
+ flags_dbg_all="$flags_dbg_all -gvms"
+ flags_dbg_yes="-g"
+- flags_dbg_off="-g0"
++ flags_dbg_off=""
+ flags_opt_all="-O -O0 -O1 -O2 -O3 -Os"
+ flags_opt_yes="-O2"
+- flags_opt_off="-O0"
++ flags_opt_off=""
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ $as_echo "no" >&6; }
+@@ -15041,6 +15041,9 @@
+ tmp_CFLAGS="$CFLAGS"
+ tmp_CPPFLAGS="$CPPFLAGS"
++# Do not remove the user-supplied debug flags in CFLAGS
++# PR: 150854
++if false; then
+ ac_var_stripped=""
+ for word1 in $tmp_CFLAGS; do
+ ac_var_strip_word="no"
+@@ -15071,6 +15074,7 @@
+ done
+ tmp_CPPFLAGS="$ac_var_stripped"
+ squeeze tmp_CPPFLAGS
++fi
- CURL_CFLAG_EXTRAS=""
--if test X"$want_werror" == Xyes; then
-+if test X"$want_werror" = Xyes; then
- CURL_CFLAG_EXTRAS="-Werror"
- fi
+ #
+ if test "$want_debug" = "yes"; then
+@@ -15283,6 +15287,9 @@
+ #
+ if test "$honor_optimize_option" = "yes"; then
+
++# Do not remove the user-supplied optimization flags in CFLAGS
++# PR: 150854
++if false; then
+ ac_var_stripped=""
+ for word1 in $tmp_CFLAGS; do
+ ac_var_strip_word="no"
+@@ -15313,6 +15320,7 @@
+ done
+ tmp_CPPFLAGS="$ac_var_stripped"
+ squeeze tmp_CPPFLAGS
++fi
+
+ if test "$want_optimize" = "yes"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
+@@ -19224,7 +19232,8 @@
+ PKGTEST="no"
+ PREFIX_OPENSSL=$OPT_SSL
+
+- OPENSSL_PCDIR="$OPT_SSL/lib/pkgconfig"
++ # Use the FreeBSD location of the pkg-config libdir
++ OPENSSL_PCDIR="$LOCALBASE/libdata/pkgconfig"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&5
+ $as_echo "$as_me: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&6;}
+ if test -e "$OPENSSL_PCDIR/openssl.pc"; then
+@@ -21264,29 +21273,30 @@
+ ;;
+ off)
+ LIB_RTMP="-lrtmp"
++ LD_RTMP=""
++ CPP_RTMP=""
++ DIR_RTMP=""
+ ;;
+ *)
+ PREFIX_RTMP=$OPT_LIBRTMP
++ LIB_RTMP="-lrtmp"
++ LD_RTMP=-L${PREFIX_RTMP}/lib$libsuff
++ CPP_RTMP=-I${PREFIX_RTMP}/include
++ DIR_RTMP=${PREFIX_RTMP}/lib$libsuff
+ ;;
+ esac
+
+- if test -n "$PREFIX_RTMP"; then
+- LD_RTMP=-L${PREFIX_RTMP}/lib$libsuff
+- CPP_RTMP=-I${PREFIX_RTMP}/include
+- DIR_RTMP=${PREFIX_RTMP}/lib$libsuff
+- fi
+-
+ LDFLAGS="$LDFLAGS $LD_RTMP"
+ CPPFLAGS="$CPPFLAGS $CPP_RTMP"
+ LIBS="$LIBS $LIB_RTMP"
+
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for RTMP_Init in -lrtmp" >&5
+-$as_echo_n "checking for RTMP_Init in -lrtmp... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for RTMP_Init in $LIB_RTMP" >&5
++$as_echo_n "checking for RTMP_Init in $LIB_RTMP... " >&6; }
+ if test "${ac_cv_lib_rtmp_RTMP_Init+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lrtmp $LIBS"
++LIBS="$LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
diff --git a/ftp/curl/files/patch-lib::url.c b/ftp/curl/files/patch-lib::url.c
index 7b04ddeb1e98..7239f50ccdc8 100644
--- a/ftp/curl/files/patch-lib::url.c
+++ b/ftp/curl/files/patch-lib::url.c
@@ -1,11 +1,11 @@
Description: Different handling of signals and threads.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-09-12
+Last-Update: 2010-12-18
--- a/lib/url.c
+++ b/lib/url.c
-@@ -842,6 +842,10 @@
+@@ -857,6 +857,10 @@
data->progress.flags |= PGRS_HIDE;
data->state.current_speed = -1; /* init to negative == impossible */
diff --git a/ftp/curl/files/patch-src::main.c b/ftp/curl/files/patch-src::main.c
index b3b6a9bd4f86..02f52d2be1ea 100644
--- a/ftp/curl/files/patch-src::main.c
+++ b/ftp/curl/files/patch-src::main.c
@@ -1,11 +1,11 @@
Description: Use fstat() instead of stat() to avoid a race condition.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-09-12
+Last-Update: 2010-12-18
--- a/src/main.c
+++ b/src/main.c
-@@ -4842,33 +4842,34 @@
+@@ -4887,33 +4887,34 @@
break;
}
@@ -33,7 +33,7 @@ Last-Update: 2010-09-12
- outs.stream=(FILE *) fopen(outfile, config->resume_from?"ab":"wb");
+ /* (always open for appending, it has no effect on new files) */
+ outs.stream=(FILE *) fopen(outfile, "ab");
- if (!outs.stream) {
+ if(!outs.stream) {
helpf(config->errors, "Can't open '%s'!\n", outfile);
free(url);
res = CURLE_WRITE_ERROR;