aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-02-23 23:20:40 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-02-23 23:20:40 +0800
commit4f3ba01253562e8a6aa4f58ed780af794c31c79a (patch)
tree3a362f2c42a19f6abb3f97b0824106569ce05856 /ftp/curl
parente5331edbe08edc33ca753946ae83da088ee5e31e (diff)
downloadfreebsd-ports-gnome-4f3ba01253562e8a6aa4f58ed780af794c31c79a.tar.gz
freebsd-ports-gnome-4f3ba01253562e8a6aa4f58ed780af794c31c79a.tar.zst
freebsd-ports-gnome-4f3ba01253562e8a6aa4f58ed780af794c31c79a.zip
- Remove no-op NTLM option
PR: ports/186902 Submitted by: Jeremy Chadwick <jdc@koitsu.org>
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 9c2c86248640..a49290a6a51c 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -13,7 +13,7 @@ COMMENT?= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
LICENSE= MIT
-OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES GSSAPI IDN IPV6 LDAP LDAPS LIBSSH2 NTLM PROXY RTMP SPNEGO TLS_SRP
+OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES GSSAPI IDN IPV6 LDAP LDAPS LIBSSH2 PROXY RTMP SPNEGO TLS_SRP
OPTIONS_RADIO= RESOLV SSL
OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER
OPTIONS_RADIO_SSL= CYASSL GNUTLS NSS OPENSSL POLARSSL
@@ -92,8 +92,6 @@ LIBSSH2_LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
NSS_CONFIGURE_OFF= --without-nss
NSS_CONFIGURE_ON= --with-nss=${LOCALBASE}
NSS_LIB_DEPENDS= libnss3.so:${PORTSDIR}/security/nss
-NTLM_CONFIGURE_OFF= --disable-ntlm
-NTLM_CONFIGURE_ON= --enable-ntlm
OPENSSL_CONFIGURE_OFF= --without-ssl
OPENSSL_CONFIGURE_ON= --with-ssl=${OPENSSLBASE}
OPENSSL_CPPFLAGS= -I${OPENSSLINC}
@@ -138,10 +136,6 @@ IGNORE= only supports LDAPS with SSL
IGNORE= only supports LIBSSH2 with OpenSSL
.endif
-.if ${PORT_OPTIONS:MNTLM} && !${PORT_OPTIONS:MCYASSL} && !${PORT_OPTIONS:MGNUTLS} && !${PORT_OPTIONS:MNSS} && !${PORT_OPTIONS:MOPENSSL} && !${PORT_OPTIONS:MPOLARSSL}
-IGNORE= only supports NTLM with SSL
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs|; /^DIST_SUBDIRS = / s| docs||; /cd docs &&/d' ${WRKSRC}/Makefile.in