aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-11-08 01:07:41 +0800
committerroam <roam@FreeBSD.org>2006-11-08 01:07:41 +0800
commit8f06d0c724e425c7fe9705112f8909c5ac831e13 (patch)
tree73334e4306b6afdfaa42cf62864d39f802da9c52 /ftp/curl
parent62ada29e5a4e1ffc86e8356e84316c396ea92a50 (diff)
downloadfreebsd-ports-gnome-8f06d0c724e425c7fe9705112f8909c5ac831e13.tar.gz
freebsd-ports-gnome-8f06d0c724e425c7fe9705112f8909c5ac831e13.tar.zst
freebsd-ports-gnome-8f06d0c724e425c7fe9705112f8909c5ac831e13.zip
If c-ares support is requested, properly depend on the shared c-ares
library now that dns/c-ares installs it. This should, among other things, fix the build of libcurl on amd64. Reported by: girgen
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index fba7ab0b5b00..755b5f772c9c 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= curl
PORTVERSION= 7.15.5
+PORTREVISION= 1
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
@@ -80,7 +81,7 @@ CONFIGURE_ARGS+= --without-ssl
.endif
.if defined(WITH_CARES)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libcares.a:${PORTSDIR}/dns/c-ares
+LIB_DEPENDS+= cares.1:${PORTSDIR}/dns/c-ares
CONFIGURE_ARGS+= --enable-ares=${LOCALBASE}
.else
CONFIGURE_ARGS+= --disable-ares