aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/filezilla
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2009-02-06 09:06:47 +0800
committeralepulver <alepulver@FreeBSD.org>2009-02-06 09:06:47 +0800
commit0dcba7f3b85c81a311e6721eef22bc077c25fc40 (patch)
tree09ef1fb36c302179289402402778e6baf109971e /ftp/filezilla
parent50008857b5cc2faa5da56bb22dfddc2c73c443b6 (diff)
downloadfreebsd-ports-gnome-0dcba7f3b85c81a311e6721eef22bc077c25fc40.tar.gz
freebsd-ports-gnome-0dcba7f3b85c81a311e6721eef22bc077c25fc40.tar.zst
freebsd-ports-gnome-0dcba7f3b85c81a311e6721eef22bc077c25fc40.zip
- Update FileZilla to version 3.2.0.
- Fix plist to not try and rmdir locale directories. - Respect WITHOUT_NLS. - Take explicit contol of dbus dependency (default was "auto"). - Add OPTIONS for DBUS and NLS (both default On). - Silence portlint. PR: ports/131106 Submitted by: "Joseph S. Atkinson" <jsa@wickedmachine.net>
Diffstat (limited to 'ftp/filezilla')
-rw-r--r--ftp/filezilla/Makefile24
-rw-r--r--ftp/filezilla/distinfo6
-rw-r--r--ftp/filezilla/pkg-plist342
3 files changed, 272 insertions, 100 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index 2a5b38677b55..23258a1bed96 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= filezilla
-PORTVERSION= 3.0.11
+PORTVERSION= 3.2.0
CATEGORIES= ftp
MASTER_SITES= SF
DISTNAME= FileZilla_${PORTVERSION}_src
@@ -17,8 +17,8 @@ COMMENT= Fast and reliable cross-platform FTP, FTPS and SFTP client
LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls \
idn.16:${PORTSDIR}/dns/libidn
+INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_WX= 2.8
WX_CONF_ARGS= relative
@@ -26,9 +26,27 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAN1= filezilla.1 fzsftp.1
+MAN1= filezilla.1 fzputtygen.1 fzsftp.1
MAN5= fzdefaults.xml.5
+OPTIONS= DBUS "Enable D-BUS intergration" On \
+ NLS "Native Language Support" On
+
+.if !defined(WITHOUT_DBUS)
+LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+CONFIGURE_ARGS+= --with-dbus
+.else
+CONFIGURE_ARGS+= --without-dbus
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-locales
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -Ee 's|(dummy) wxrc|\1 ${WXRC_CMD:T}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/ftp/filezilla/distinfo b/ftp/filezilla/distinfo
index 9cb18df43de0..6458e38f2b3b 100644
--- a/ftp/filezilla/distinfo
+++ b/ftp/filezilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (FileZilla_3.0.11_src.tar.bz2) = 776e6eec6ee19b33b35fb55269da1e85
-SHA256 (FileZilla_3.0.11_src.tar.bz2) = f2fcb37da4c54a28059724b933b14cf03fd783e74c912c0725776c5f0de1924c
-SIZE (FileZilla_3.0.11_src.tar.bz2) = 2172359
+MD5 (FileZilla_3.2.0_src.tar.bz2) = b57fa73db4028b81efc275b911cfc3c2
+SHA256 (FileZilla_3.2.0_src.tar.bz2) = 26ac3dc2cf1792373de76b11ced1eacd83786999fc3516af6c6d7e3339c44fdc
+SIZE (FileZilla_3.2.0_src.tar.bz2) = 2789823
diff --git a/ftp/filezilla/pkg-plist b/ftp/filezilla/pkg-plist
index da2f2b295f4e..b684d51fce59 100644
--- a/ftp/filezilla/pkg-plist
+++ b/ftp/filezilla/pkg-plist
@@ -1,55 +1,57 @@
bin/filezilla
bin/fzsftp
bin/fzputtygen
-share/locale/ar/LC_MESSAGES/filezilla.mo
-share/locale/ca/LC_MESSAGES/filezilla.mo
-share/locale/de/LC_MESSAGES/filezilla.mo
-share/locale/el/LC_MESSAGES/filezilla.mo
-share/locale/es/LC_MESSAGES/filezilla.mo
-share/locale/fr/LC_MESSAGES/filezilla.mo
-share/locale/it/LC_MESSAGES/filezilla.mo
-share/locale/ka/LC_MESSAGES/filezilla.mo
-share/locale/ne/LC_MESSAGES/filezilla.mo
-share/locale/nl/LC_MESSAGES/filezilla.mo
-share/locale/pt_BR/LC_MESSAGES/filezilla.mo
-share/locale/pt_PT/LC_MESSAGES/filezilla.mo
-share/locale/ru/LC_MESSAGES/filezilla.mo
-share/locale/sv/LC_MESSAGES/filezilla.mo
-share/locale/tr/LC_MESSAGES/filezilla.mo
-share/locale/zh_CN/LC_MESSAGES/filezilla.mo
-share/locale/zh_TW/LC_MESSAGES/filezilla.mo
-share/locale/bg_BG/LC_MESSAGES/filezilla.mo
-share/locale/ca_ES@valencia/LC_MESSAGES/filezilla.mo
-share/locale/cs_CZ/LC_MESSAGES/filezilla.mo
-share/locale/da_DK/LC_MESSAGES/filezilla.mo
-share/locale/et_EE/LC_MESSAGES/filezilla.mo
-share/locale/eu_ES/LC_MESSAGES/filezilla.mo
-share/locale/fi_FI/LC_MESSAGES/filezilla.mo
-share/locale/fr_CA/LC_MESSAGES/filezilla.mo
-share/locale/gl_ES/LC_MESSAGES/filezilla.mo
-share/locale/he_IL/LC_MESSAGES/filezilla.mo
-share/locale/hu_HU/LC_MESSAGES/filezilla.mo
-share/locale/id_ID/LC_MESSAGES/filezilla.mo
-share/locale/ja_JP/LC_MESSAGES/filezilla.mo
-share/locale/km_KH/LC_MESSAGES/filezilla.mo
-share/locale/ko_KR/LC_MESSAGES/filezilla.mo
-share/locale/ku/LC_MESSAGES/filezilla.mo
-share/locale/lt_LT/LC_MESSAGES/filezilla.mo
-share/locale/lv_LV/LC_MESSAGES/filezilla.mo
-share/locale/mk_MK/LC_MESSAGES/filezilla.mo
-share/locale/nb_NO/LC_MESSAGES/filezilla.mo
-share/locale/pl_PL/LC_MESSAGES/filezilla.mo
-share/locale/ro_RO/LC_MESSAGES/filezilla.mo
-share/locale/sk_SK/LC_MESSAGES/filezilla.mo
-share/locale/sl_SI/LC_MESSAGES/filezilla.mo
-share/locale/th_TH/LC_MESSAGES/filezilla.mo
-share/locale/uk_UA/LC_MESSAGES/filezilla.mo
-share/locale/vi_VN/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/de/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/el/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/es/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/it/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ne/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/bg_BG/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ca_ES@valencia/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/da_DK/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/et_EE/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/eu_ES/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/fr_CA/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/gl_ES/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/he_IL/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/hu_HU/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/id_ID/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ja_JP/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/km_KH/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ko_KR/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ku/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/lt_LT/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/lv_LV/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/mk_MK/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/nb_NO/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/nn_NO/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ro_RO/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/sk_SK/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/sl_SI/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/th_TH/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/uk_UA/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/vi_VN/LC_MESSAGES/filezilla.mo
share/pixmaps/filezilla.png
%%DATADIR%%/docs/fzdefaults.xml.example
%%DATADIR%%/resources/16x16/ascii.png
%%DATADIR%%/resources/16x16/auto.png
%%DATADIR%%/resources/16x16/binary.png
+%%DATADIR%%/resources/16x16/bookmark.png
%%DATADIR%%/resources/16x16/cancel.png
%%DATADIR%%/resources/16x16/compare.png
%%DATADIR%%/resources/16x16/disconnect.png
@@ -197,6 +199,190 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/blukis/48x48/upload.png
%%DATADIR%%/resources/blukis/48x48/uploadadd.png
%%DATADIR%%/resources/blukis/theme.xml
+%%DATADIR%%/resources/lone/16x16/ascii.png
+%%DATADIR%%/resources/lone/16x16/auto.png
+%%DATADIR%%/resources/lone/16x16/binary.png
+%%DATADIR%%/resources/lone/16x16/bookmarks.png
+%%DATADIR%%/resources/lone/16x16/cancel.png
+%%DATADIR%%/resources/lone/16x16/compare.png
+%%DATADIR%%/resources/lone/16x16/disconnect.png
+%%DATADIR%%/resources/lone/16x16/download.png
+%%DATADIR%%/resources/lone/16x16/downloadadd.png
+%%DATADIR%%/resources/lone/16x16/file.png
+%%DATADIR%%/resources/lone/16x16/filter.png
+%%DATADIR%%/resources/lone/16x16/folder.png
+%%DATADIR%%/resources/lone/16x16/folderback.png
+%%DATADIR%%/resources/lone/16x16/folderclosed.png
+%%DATADIR%%/resources/lone/16x16/folderup.png
+%%DATADIR%%/resources/lone/16x16/help.png
+%%DATADIR%%/resources/lone/16x16/localtreeview.png
+%%DATADIR%%/resources/lone/16x16/lock.png
+%%DATADIR%%/resources/lone/16x16/logview.png
+%%DATADIR%%/resources/lone/16x16/processqueue.png
+%%DATADIR%%/resources/lone/16x16/queueview.png
+%%DATADIR%%/resources/lone/16x16/reconnect.png
+%%DATADIR%%/resources/lone/16x16/refresh.png
+%%DATADIR%%/resources/lone/16x16/remotetreeview.png
+%%DATADIR%%/resources/lone/16x16/server.png
+%%DATADIR%%/resources/lone/16x16/showhidden.png
+%%DATADIR%%/resources/lone/16x16/sitemanager.png
+%%DATADIR%%/resources/lone/16x16/speedlimits.png
+%%DATADIR%%/resources/lone/16x16/synchronize.png
+%%DATADIR%%/resources/lone/16x16/upload.png
+%%DATADIR%%/resources/lone/16x16/uploadadd.png
+%%DATADIR%%/resources/lone/32x32/ascii.png
+%%DATADIR%%/resources/lone/32x32/auto.png
+%%DATADIR%%/resources/lone/32x32/binary.png
+%%DATADIR%%/resources/lone/32x32/bookmarks.png
+%%DATADIR%%/resources/lone/32x32/cancel.png
+%%DATADIR%%/resources/lone/32x32/compare.png
+%%DATADIR%%/resources/lone/32x32/disconnect.png
+%%DATADIR%%/resources/lone/32x32/download.png
+%%DATADIR%%/resources/lone/32x32/downloadadd.png
+%%DATADIR%%/resources/lone/32x32/file.png
+%%DATADIR%%/resources/lone/32x32/filter.png
+%%DATADIR%%/resources/lone/32x32/folder.png
+%%DATADIR%%/resources/lone/32x32/folderback.png
+%%DATADIR%%/resources/lone/32x32/folderclosed.png
+%%DATADIR%%/resources/lone/32x32/folderup.png
+%%DATADIR%%/resources/lone/32x32/help.png
+%%DATADIR%%/resources/lone/32x32/localtreeview.png
+%%DATADIR%%/resources/lone/32x32/lock.png
+%%DATADIR%%/resources/lone/32x32/logview.png
+%%DATADIR%%/resources/lone/32x32/processqueue.png
+%%DATADIR%%/resources/lone/32x32/queueview.png
+%%DATADIR%%/resources/lone/32x32/reconnect.png
+%%DATADIR%%/resources/lone/32x32/refresh.png
+%%DATADIR%%/resources/lone/32x32/remotetreeview.png
+%%DATADIR%%/resources/lone/32x32/showhidden.png
+%%DATADIR%%/resources/lone/32x32/sitemanager.png
+%%DATADIR%%/resources/lone/32x32/speedlimits.png
+%%DATADIR%%/resources/lone/32x32/synchronize.png
+%%DATADIR%%/resources/lone/32x32/upload.png
+%%DATADIR%%/resources/lone/32x32/uploadadd.png
+%%DATADIR%%/resources/lone/48x48/ascii.png
+%%DATADIR%%/resources/lone/48x48/auto.png
+%%DATADIR%%/resources/lone/48x48/binary.png
+%%DATADIR%%/resources/lone/48x48/bookmarks.png
+%%DATADIR%%/resources/lone/48x48/cancel.png
+%%DATADIR%%/resources/lone/48x48/compare.png
+%%DATADIR%%/resources/lone/48x48/disconnect.png
+%%DATADIR%%/resources/lone/48x48/download.png
+%%DATADIR%%/resources/lone/48x48/downloadadd.png
+%%DATADIR%%/resources/lone/48x48/file.png
+%%DATADIR%%/resources/lone/48x48/filter.png
+%%DATADIR%%/resources/lone/48x48/folder.png
+%%DATADIR%%/resources/lone/48x48/folderback.png
+%%DATADIR%%/resources/lone/48x48/folderclosed.png
+%%DATADIR%%/resources/lone/48x48/folderup.png
+%%DATADIR%%/resources/lone/48x48/help.png
+%%DATADIR%%/resources/lone/48x48/localtreeview.png
+%%DATADIR%%/resources/lone/48x48/lock.png
+%%DATADIR%%/resources/lone/48x48/logview.png
+%%DATADIR%%/resources/lone/48x48/processqueue.png
+%%DATADIR%%/resources/lone/48x48/queueview.png
+%%DATADIR%%/resources/lone/48x48/reconnect.png
+%%DATADIR%%/resources/lone/48x48/refresh.png
+%%DATADIR%%/resources/lone/48x48/remotetreeview.png
+%%DATADIR%%/resources/lone/48x48/showhidden.png
+%%DATADIR%%/resources/lone/48x48/sitemanager.png
+%%DATADIR%%/resources/lone/48x48/speedlimits.png
+%%DATADIR%%/resources/lone/48x48/synchronize.png
+%%DATADIR%%/resources/lone/48x48/upload.png
+%%DATADIR%%/resources/lone/48x48/uploadadd.png
+%%DATADIR%%/resources/lone/theme.xml
+%%DATADIR%%/resources/opencrystal/16x16/ascii.png
+%%DATADIR%%/resources/opencrystal/16x16/auto.png
+%%DATADIR%%/resources/opencrystal/16x16/binary.png
+%%DATADIR%%/resources/opencrystal/16x16/bookmarks.png
+%%DATADIR%%/resources/opencrystal/16x16/cancel.png
+%%DATADIR%%/resources/opencrystal/16x16/compare.png
+%%DATADIR%%/resources/opencrystal/16x16/disconnect.png
+%%DATADIR%%/resources/opencrystal/16x16/download.png
+%%DATADIR%%/resources/opencrystal/16x16/downloadadd.png
+%%DATADIR%%/resources/opencrystal/16x16/file.png
+%%DATADIR%%/resources/opencrystal/16x16/filter.png
+%%DATADIR%%/resources/opencrystal/16x16/folder.png
+%%DATADIR%%/resources/opencrystal/16x16/folderback.png
+%%DATADIR%%/resources/opencrystal/16x16/folderclosed.png
+%%DATADIR%%/resources/opencrystal/16x16/folderup.png
+%%DATADIR%%/resources/opencrystal/16x16/help.png
+%%DATADIR%%/resources/opencrystal/16x16/localtreeview.png
+%%DATADIR%%/resources/opencrystal/16x16/lock.png
+%%DATADIR%%/resources/opencrystal/16x16/logview.png
+%%DATADIR%%/resources/opencrystal/16x16/processqueue.png
+%%DATADIR%%/resources/opencrystal/16x16/queueview.png
+%%DATADIR%%/resources/opencrystal/16x16/reconnect.png
+%%DATADIR%%/resources/opencrystal/16x16/refresh.png
+%%DATADIR%%/resources/opencrystal/16x16/remotetreeview.png
+%%DATADIR%%/resources/opencrystal/16x16/server.png
+%%DATADIR%%/resources/opencrystal/16x16/showhidden.png
+%%DATADIR%%/resources/opencrystal/16x16/sitemanager.png
+%%DATADIR%%/resources/opencrystal/16x16/speedlimits.png
+%%DATADIR%%/resources/opencrystal/16x16/synchronize.png
+%%DATADIR%%/resources/opencrystal/16x16/upload.png
+%%DATADIR%%/resources/opencrystal/16x16/uploadadd.png
+%%DATADIR%%/resources/opencrystal/32x32/ascii.png
+%%DATADIR%%/resources/opencrystal/32x32/auto.png
+%%DATADIR%%/resources/opencrystal/32x32/binary.png
+%%DATADIR%%/resources/opencrystal/32x32/bookmarks.png
+%%DATADIR%%/resources/opencrystal/32x32/cancel.png
+%%DATADIR%%/resources/opencrystal/32x32/compare.png
+%%DATADIR%%/resources/opencrystal/32x32/disconnect.png
+%%DATADIR%%/resources/opencrystal/32x32/download.png
+%%DATADIR%%/resources/opencrystal/32x32/downloadadd.png
+%%DATADIR%%/resources/opencrystal/32x32/file.png
+%%DATADIR%%/resources/opencrystal/32x32/filter.png
+%%DATADIR%%/resources/opencrystal/32x32/folder.png
+%%DATADIR%%/resources/opencrystal/32x32/folderback.png
+%%DATADIR%%/resources/opencrystal/32x32/folderclosed.png
+%%DATADIR%%/resources/opencrystal/32x32/folderup.png
+%%DATADIR%%/resources/opencrystal/32x32/help.png
+%%DATADIR%%/resources/opencrystal/32x32/localtreeview.png
+%%DATADIR%%/resources/opencrystal/32x32/lock.png
+%%DATADIR%%/resources/opencrystal/32x32/logview.png
+%%DATADIR%%/resources/opencrystal/32x32/processqueue.png
+%%DATADIR%%/resources/opencrystal/32x32/queueview.png
+%%DATADIR%%/resources/opencrystal/32x32/reconnect.png
+%%DATADIR%%/resources/opencrystal/32x32/refresh.png
+%%DATADIR%%/resources/opencrystal/32x32/remotetreeview.png
+%%DATADIR%%/resources/opencrystal/32x32/showhidden.png
+%%DATADIR%%/resources/opencrystal/32x32/sitemanager.png
+%%DATADIR%%/resources/opencrystal/32x32/speedlimits.png
+%%DATADIR%%/resources/opencrystal/32x32/synchronize.png
+%%DATADIR%%/resources/opencrystal/32x32/upload.png
+%%DATADIR%%/resources/opencrystal/32x32/uploadadd.png
+%%DATADIR%%/resources/opencrystal/48x48/ascii.png
+%%DATADIR%%/resources/opencrystal/48x48/auto.png
+%%DATADIR%%/resources/opencrystal/48x48/binary.png
+%%DATADIR%%/resources/opencrystal/48x48/bookmarks.png
+%%DATADIR%%/resources/opencrystal/48x48/cancel.png
+%%DATADIR%%/resources/opencrystal/48x48/compare.png
+%%DATADIR%%/resources/opencrystal/48x48/disconnect.png
+%%DATADIR%%/resources/opencrystal/48x48/download.png
+%%DATADIR%%/resources/opencrystal/48x48/downloadadd.png
+%%DATADIR%%/resources/opencrystal/48x48/file.png
+%%DATADIR%%/resources/opencrystal/48x48/filter.png
+%%DATADIR%%/resources/opencrystal/48x48/folder.png
+%%DATADIR%%/resources/opencrystal/48x48/folderback.png
+%%DATADIR%%/resources/opencrystal/48x48/folderclosed.png
+%%DATADIR%%/resources/opencrystal/48x48/folderup.png
+%%DATADIR%%/resources/opencrystal/48x48/help.png
+%%DATADIR%%/resources/opencrystal/48x48/localtreeview.png
+%%DATADIR%%/resources/opencrystal/48x48/lock.png
+%%DATADIR%%/resources/opencrystal/48x48/logview.png
+%%DATADIR%%/resources/opencrystal/48x48/processqueue.png
+%%DATADIR%%/resources/opencrystal/48x48/queueview.png
+%%DATADIR%%/resources/opencrystal/48x48/reconnect.png
+%%DATADIR%%/resources/opencrystal/48x48/refresh.png
+%%DATADIR%%/resources/opencrystal/48x48/remotetreeview.png
+%%DATADIR%%/resources/opencrystal/48x48/showhidden.png
+%%DATADIR%%/resources/opencrystal/48x48/sitemanager.png
+%%DATADIR%%/resources/opencrystal/48x48/speedlimits.png
+%%DATADIR%%/resources/opencrystal/48x48/synchronize.png
+%%DATADIR%%/resources/opencrystal/48x48/upload.png
+%%DATADIR%%/resources/opencrystal/48x48/uploadadd.png
+%%DATADIR%%/resources/opencrystal/theme.xml
%%DATADIR%%/resources/48x48/filezilla.png
%%DATADIR%%/resources/defaultfilters.xml
%%DATADIR%%/resources/dialogs.xrc
@@ -210,58 +396,26 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/theme.xml
%%DATADIR%%/resources/toolbar.xrc
%%DATADIR%%/resources/up.png
+share/icons/hicolor/16x16/apps/filezilla.png
+share/icons/hicolor/32x32/apps/filezilla.png
+share/icons/hicolor/48x48/apps/filezilla.png
share/applications/filezilla.desktop
-@dirrmtry share/locale/vi_VN/LC_MESSAGES
-@dirrmtry share/locale/vi_VN
-@dirrmtry share/locale/uk_UA/LC_MESSAGES
-@dirrmtry share/locale/uk_UA
-@dirrmtry share/locale/th_TH/LC_MESSAGES
-@dirrmtry share/locale/th_TH
-@dirrmtry share/locale/sl_SI/LC_MESSAGES
-@dirrmtry share/locale/sl_SI
-@dirrmtry share/locale/sk_SK/LC_MESSAGES
-@dirrmtry share/locale/sk_SK
-@dirrmtry share/locale/ro_RO/LC_MESSAGES
-@dirrmtry share/locale/ro_RO
-@dirrmtry share/locale/pl_PL/LC_MESSAGES
-@dirrmtry share/locale/pl_PL
-@dirrmtry share/locale/nb_NO/LC_MESSAGES
-@dirrmtry share/locale/nb_NO
-@dirrmtry share/locale/mk_MK/LC_MESSAGES
-@dirrmtry share/locale/mk_MK
-@dirrmtry share/locale/lv_LV/LC_MESSAGES
-@dirrmtry share/locale/lv_LV
-@dirrmtry share/locale/lt_LT/LC_MESSAGES
-@dirrmtry share/locale/lt_LT
-@dirrmtry share/locale/ko_KR/LC_MESSAGES
-@dirrmtry share/locale/ko_KR
-@dirrmtry share/locale/km_KH/LC_MESSAGES
-@dirrmtry share/locale/km_KH
-@dirrmtry share/locale/ja_JP/LC_MESSAGES
-@dirrmtry share/locale/ja_JP
-@dirrmtry share/locale/id_ID/LC_MESSAGES
-@dirrmtry share/locale/id_ID
-@dirrmtry share/locale/hu_HU/LC_MESSAGES
-@dirrmtry share/locale/hu_HU
-@dirrmtry share/locale/he_IL/LC_MESSAGES
-@dirrmtry share/locale/he_IL
-@dirrmtry share/locale/gl_ES/LC_MESSAGES
-@dirrmtry share/locale/gl_ES
-@dirrmtry share/locale/fr_CA/LC_MESSAGES
-@dirrmtry share/locale/fr_CA
-@dirrmtry share/locale/fi_FI/LC_MESSAGES
-@dirrmtry share/locale/fi_FI
-@dirrmtry share/locale/et_EE/LC_MESSAGES
-@dirrmtry share/locale/et_EE
-@dirrmtry share/locale/da_DK/LC_MESSAGES
-@dirrmtry share/locale/da_DK
-@dirrmtry share/locale/cs_CZ/LC_MESSAGES
-@dirrmtry share/locale/cs_CZ
-@dirrmtry share/locale/ca_ES@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca_ES@valencia
-@dirrmtry share/locale/bg_BG/LC_MESSAGES
-@dirrmtry share/locale/bg_BG
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
@dirrmtry share/applications
+@dirrm %%DATADIR%%/resources/opencrystal/48x48
+@dirrm %%DATADIR%%/resources/opencrystal/32x32
+@dirrm %%DATADIR%%/resources/opencrystal/16x16
+@dirrm %%DATADIR%%/resources/opencrystal
+@dirrm %%DATADIR%%/resources/lone/48x48
+@dirrm %%DATADIR%%/resources/lone/32x32
+@dirrm %%DATADIR%%/resources/lone/16x16
+@dirrm %%DATADIR%%/resources/lone
@dirrm %%DATADIR%%/resources/cyril/16x16
@dirrm %%DATADIR%%/resources/cyril
@dirrm %%DATADIR%%/resources/blukis/48x48