aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/filezilla
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2015-05-03 21:25:57 +0800
committerzi <zi@FreeBSD.org>2015-05-03 21:25:57 +0800
commit3012b5ba8dec61bf61d695c515c0cb9eb5863241 (patch)
tree1053042eb7b66b9a1ba4c1d3707aa5bef981417b /ftp/filezilla
parentf8e81d6ce324944ac43510cc66842bfeafa6b4b7 (diff)
downloadfreebsd-ports-gnome-3012b5ba8dec61bf61d695c515c0cb9eb5863241.tar.gz
freebsd-ports-gnome-3012b5ba8dec61bf61d695c515c0cb9eb5863241.tar.zst
freebsd-ports-gnome-3012b5ba8dec61bf61d695c515c0cb9eb5863241.zip
- Update to 3.10.3
PR: 199844 Submitted by: matthew@reztek.cz (maintainer)
Diffstat (limited to 'ftp/filezilla')
-rw-r--r--ftp/filezilla/Makefile10
-rw-r--r--ftp/filezilla/distinfo4
-rw-r--r--ftp/filezilla/files/patch-src_interface_Mainfrm.h11
3 files changed, 9 insertions, 16 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index fc2cb4a1a671..02e55f0d6494 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= filezilla
-PORTVERSION= 3.10.2
+PORTVERSION= 3.10.3
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/FileZilla_Client/${PORTVERSION}
DISTNAME= FileZilla_${PORTVERSION}_src
@@ -20,7 +20,7 @@ LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libtinyxml.so:${PORTSDIR}/textproc/tinyxml
INSTALLS_ICONS= yes
-USES= gmake pkgconfig tar:bzip2
+USES= compiler:c++11-lib gmake pkgconfig tar:bzip2
USE_SQLITE= 3
USE_WX= 3.0
WX_CONF_ARGS= relative
@@ -47,7 +47,11 @@ CONFIGURE_ARGS+= --disable-manualupdatecheck
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-USE_GCC= yes
+# can't count on Clang having lic++ before 10, so compiler uses selects gcc
+.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
+# needed for __atomic_exchange_8, __atmoic_fetch_add_8, __atomic_store_8
+CFLAGS+= -march=i586
+.endif
.endif
post-patch:
diff --git a/ftp/filezilla/distinfo b/ftp/filezilla/distinfo
index 6e7bf0be0b5c..b4e5a116682d 100644
--- a/ftp/filezilla/distinfo
+++ b/ftp/filezilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FileZilla_3.10.2_src.tar.bz2) = c08ee3bff4ce35010a5f32610ef699081662c9f8c51c20740f719e653ce9b611
-SIZE (FileZilla_3.10.2_src.tar.bz2) = 4232889
+SHA256 (FileZilla_3.10.3_src.tar.bz2) = 7968e2799437c0b89741bd7afbc077156525d930e9a18543fd087fbd8979de8d
+SIZE (FileZilla_3.10.3_src.tar.bz2) = 4430113
diff --git a/ftp/filezilla/files/patch-src_interface_Mainfrm.h b/ftp/filezilla/files/patch-src_interface_Mainfrm.h
deleted file mode 100644
index 06c02e0defca..000000000000
--- a/ftp/filezilla/files/patch-src_interface_Mainfrm.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/interface/Mainfrm.h.orig 2015-03-05 03:48:01 UTC
-+++ src/interface/Mainfrm.h
-@@ -28,6 +28,8 @@ class CWindowStateManager;
-
- #if FZ_MANUALUPDATECHECK
- #include "updater.h"
-+#else
-+#include <wx/timer.h>
- #endif
- class CWindowStateManager;
-