aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/horde-gollem/Makefile
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2006-04-16 00:29:25 +0800
committerscrappy <scrappy@FreeBSD.org>2006-04-16 00:29:25 +0800
commit5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20 (patch)
tree5d7dc1df3f58d54ca285e535404de2237aab908c /ftp/horde-gollem/Makefile
parent0bf7f3b33d0856b0230169fbe63d6bdb650ffbf6 (diff)
downloadfreebsd-ports-gnome-5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20.tar.gz
freebsd-ports-gnome-5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20.tar.zst
freebsd-ports-gnome-5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20.zip
After a recent discussion on freebsd-ports, I have modified the Horde
ports, so that they now do not overwrite existing configuration files. Rather than backing up the old ones and allowing the user to merge the files by hand, config files are left untouched. PR: Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'ftp/horde-gollem/Makefile')
-rw-r--r--ftp/horde-gollem/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/ftp/horde-gollem/Makefile b/ftp/horde-gollem/Makefile
index c6378f7ca1dc..37334847cb17 100644
--- a/ftp/horde-gollem/Makefile
+++ b/ftp/horde-gollem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gollem
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
ftp://ftp.planetmirror.com/pub/horde/gollem/ \
@@ -18,7 +19,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
http://ftp.horde.org/pub/gollem/
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= Gollem is the Horde web-based File Manager
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
@@ -30,7 +31,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= GOLLEMDIR=${GOLLEMDIR}
DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -61,11 +62,7 @@ do-install:
@${MKDIR} ${GOLLEMDIR}
@${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${GOLLEMDIR}
@${CP} -p ${WRKSRC}/*.php ${GOLLEMDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${GOLLEMDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-gollem.conf ${HORDE_INC}
@@ -76,6 +73,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}