aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/jftpgw
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2002-04-12 04:12:21 +0800
committerStefan Eßer <se@FreeBSD.org>2002-04-12 04:12:21 +0800
commitdaaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc (patch)
tree253adb1f979d41b485e6ffb1db6dae04f4618708 /ftp/jftpgw
parent4ba9a9ad70fd0a27c31f6f1d432a3147c37ac532 (diff)
downloadfreebsd-ports-gnome-daaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc.tar.gz
freebsd-ports-gnome-daaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc.tar.zst
freebsd-ports-gnome-daaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc.zip
Upgrade to release 0.13.1.
Seems that privileges are dropped in a way, that restricts writing of the PID file to driectories that can be written into by the UID the process is running under (i.e. nobody). This will be fixed later ...
Diffstat (limited to 'ftp/jftpgw')
-rw-r--r--ftp/jftpgw/Makefile9
-rw-r--r--ftp/jftpgw/distinfo4
-rw-r--r--ftp/jftpgw/files/jftpgw.sh.in10
-rw-r--r--ftp/jftpgw/files/patch-config.h.in12
-rw-r--r--ftp/jftpgw/files/patch-configure11
-rw-r--r--ftp/jftpgw/files/patch-configure.in11
-rw-r--r--ftp/jftpgw/files/patch-jftpgw.h12
-rw-r--r--ftp/jftpgw/files/patch-util.c18
8 files changed, 14 insertions, 73 deletions
diff --git a/ftp/jftpgw/Makefile b/ftp/jftpgw/Makefile
index 0e3b5a0f57bf..af0527c65b7a 100644
--- a/ftp/jftpgw/Makefile
+++ b/ftp/jftpgw/Makefile
@@ -6,22 +6,23 @@
#
PORTNAME= jftpgw
-PORTVERSION= 0.0.13j
+PORTVERSION= 0.13.1
CATEGORIES= ftp
MASTER_SITES= http://www.mcknight.de/jftpgw/
-DISTNAME= jftpgw-0.13.beta.j
MAINTAINER= se@FreeBSD.org
+USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-confpath=${PREFIX}/etc \
- --with-logpath=/var/log \
+CONFIGURE_ARGS= --with-logpath=/var/log \
--enable-crypt \
--enable-sftp
+MAN1= jftpgw.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/jftpgw ${PREFIX}/sbin/
${INSTALL_DATA} ${WRKSRC}/jftpgw.conf.sample ${PREFIX}/etc/
+ ${INSTALL_MAN} ${WRKSRC}/jftpgw.1 ${PREFIX}/man/man1/
@${SED} -e 's:@PREFIX@:${PREFIX}:g' \
${FILESDIR}/jftpgw.sh.in > ${WRKDIR}/jftpgw.sh
${INSTALL_SCRIPT} ${WRKDIR}/jftpgw.sh ${PREFIX}/etc/rc.d
diff --git a/ftp/jftpgw/distinfo b/ftp/jftpgw/distinfo
index be8816f1fdfa..1ee45047370b 100644
--- a/ftp/jftpgw/distinfo
+++ b/ftp/jftpgw/distinfo
@@ -1,2 +1,2 @@
-MD5 (jftpgw-0.13.beta.j.tar.gz) = c638d6cae6de541ddda6fbc8fdae6246
-SIZE (jftpgw-0.13.beta.j.tar.gz) = 220094
+MD5 (jftpgw-0.13.1.tar.bz2) = 840a75b3d0fdf1bd529c0be370a40b67
+SIZE (jftpgw-0.13.1.tar.bz2) = 182500
diff --git a/ftp/jftpgw/files/jftpgw.sh.in b/ftp/jftpgw/files/jftpgw.sh.in
index 367c08163872..f986f2e943f6 100644
--- a/ftp/jftpgw/files/jftpgw.sh.in
+++ b/ftp/jftpgw/files/jftpgw.sh.in
@@ -1,12 +1,14 @@
#!/bin/sh
PROGRAM=@PREFIX@/sbin/jftpgw
+CFGFILE=@PREFIX@/etc/jftpgw.conf
+
PIDFILE=/var/run/jftpgw.pid
case "$1" in
start)
- if [ -x $PROGRAM ] && [ -r @PREFIX@/etc/jftpgw.conf ]
+ if [ -x $PROGRAM ] && [ -r $CFGFILE ]
then
$PROGRAM
echo -n "jftpgw "
@@ -14,8 +16,10 @@ start)
;;
stop)
- PID=`cat $PIDFILE 2>/dev/null`
- ps -p "$PID" | tail +2 | grep -sqw $PROGRAM && kill $PID
+# work around PID file creation problem
+ killall jftpgw
+# PID=`cat $PIDFILE 2>/dev/null`
+# ps -p "$PID" | tail +2 | grep -sqw $PROGRAM && kill $PID
;;
*)
diff --git a/ftp/jftpgw/files/patch-config.h.in b/ftp/jftpgw/files/patch-config.h.in
deleted file mode 100644
index 053ed9e80b88..000000000000
--- a/ftp/jftpgw/files/patch-config.h.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- config.h.in~ Thu Feb 14 22:40:52 2002
-+++ config.h.in Thu Feb 14 22:42:17 2002
-@@ -100,6 +100,9 @@
- /* Define if you have the strdup function. */
- #undef HAVE_STRDUP
-
-+/* Define if you have the strcasestr function. */
-+#undef HAVE_STRCASESTR
-+
- /* Define if you have the strerror function. */
- #undef HAVE_STRERROR
-
diff --git a/ftp/jftpgw/files/patch-configure b/ftp/jftpgw/files/patch-configure
deleted file mode 100644
index 536e6860436c..000000000000
--- a/ftp/jftpgw/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure~ Sun Feb 3 12:20:16 2002
-+++ configure Thu Feb 14 22:27:32 2002
-@@ -1861,7 +1861,7 @@
-
- fi
-
--for ac_func in getcwd strdup seteuid setegid
-+for ac_func in getcwd strdup strcasestr seteuid setegid
- do
- echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
- echo "configure:1868: checking for $ac_func" >&5
diff --git a/ftp/jftpgw/files/patch-configure.in b/ftp/jftpgw/files/patch-configure.in
deleted file mode 100644
index 7cc437c454a3..000000000000
--- a/ftp/jftpgw/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in~ Sun Feb 3 01:25:28 2002
-+++ configure.in Thu Feb 14 22:21:33 2002
-@@ -49,7 +49,7 @@
-
- dnl Checks for library functions.
- AC_FUNC_WAIT3
--AC_CHECK_FUNCS(getcwd strdup seteuid setegid)
-+AC_CHECK_FUNCS(getcwd strdup strcasestr seteuid setegid)
-
- dnl From icecast
- AC_MSG_CHECKING([for unix98 socklen_t])
diff --git a/ftp/jftpgw/files/patch-jftpgw.h b/ftp/jftpgw/files/patch-jftpgw.h
deleted file mode 100644
index 248ca42d9a54..000000000000
--- a/ftp/jftpgw/files/patch-jftpgw.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- jftpgw.h~ Sat Feb 2 19:11:30 2002
-+++ jftpgw.h Thu Feb 14 22:29:34 2002
-@@ -360,7 +360,9 @@
- char* char_append(const char*, const char*);
- char* char_enclose(const char*, const char*, const char*);
- char* strnulldup(const char*);
-+#ifndef HAVE_STRCASESTR
- const char* strcasestr(const char* haystack, const char* needle);
-+#endif
-
- /* from config.c */
- int config_read_options(FILE*);
diff --git a/ftp/jftpgw/files/patch-util.c b/ftp/jftpgw/files/patch-util.c
deleted file mode 100644
index 449035ad1a40..000000000000
--- a/ftp/jftpgw/files/patch-util.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- util.c~ Sun Feb 3 10:10:54 2002
-+++ util.c Thu Feb 14 22:30:36 2002
-@@ -91,6 +91,7 @@
- }
-
-
-+#ifndef HAVE_STRCASESTR
- const char* strcasestr(const char* haystack, const char* needle) {
- char* nhay = strdup(haystack);
- char* nneed = strdup(needle);
-@@ -121,6 +122,7 @@
-
- return match;
- }
-+#endif
-
-
- /* writes a char* to an fd and checks the return value */