aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/linux-c6-curl
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2015-08-10 03:14:13 +0800
committernetchild <netchild@FreeBSD.org>2015-08-10 03:14:13 +0800
commit8725235f35a03fb0dd1da17304424701f84e15dd (patch)
tree5205db7c3150c2000d8091bebe7ce6fc273be03c /ftp/linux-c6-curl
parentb3c031084f5535608ae04c365e4eea69d5c7ad16 (diff)
downloadfreebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.tar.gz
freebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.tar.zst
freebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.zip
Re-commit of
64 bit linuxulator support (not activated by default): - most of the work was done by Alan Jude - all errors are mine - 64bit (may) have rough edges - I validated * that the 32bit part doesn't has deinstall regressions (incl. EXP runs by antoine) * 29 of 72 64bit ports ports don't have deinstall leftovers (more validation later, when I dare to activate the 64bit linuxulator in the kernel) - the infrastructure part looks mature enough to let more test-bunnies get some experience with the new 64 bit parts - to use it you shall have no linux ports installed and have to specify (on your own risk) the following in make.conf before installing the ports: OVERRIDE_LINUX_BASE_PORT=c6_64 OVERRIDE_LINUX_NONBASE_PORTS=c6_64 This is on top of the exiting c6 linux ports. Given that CentOS 7 is 64bits only, we decided to have it as an "overlay" instead of new ports. The 64bit part only installs 64bit executables, the 32bit ports can not be installed at the same time (if needed we can think of letting the 64bit overlay install the 32bit parts too, but given the CentOS 7 comment above...). Differential Revision: https://reviews.freebsd.org/D174 Submitted by: alanjude Sponsored by: Essen FreeBSD Hackathon 2015 Reviewed by: xmj, eadler (earlier versions) Approved by: portmgr (antoine after some EXP-runs)
Diffstat (limited to 'ftp/linux-c6-curl')
-rw-r--r--ftp/linux-c6-curl/Makefile4
-rw-r--r--ftp/linux-c6-curl/distinfo.x86_646
-rw-r--r--ftp/linux-c6-curl/pkg-plist.i6864
-rw-r--r--ftp/linux-c6-curl/pkg-plist.x86_644
4 files changed, 15 insertions, 3 deletions
diff --git a/ftp/linux-c6-curl/Makefile b/ftp/linux-c6-curl/Makefile
index ebfda72a6478..a8871a9c2889 100644
--- a/ftp/linux-c6-curl/Makefile
+++ b/ftp/linux-c6-curl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.19.7
-PORTREVISION= 2
+PORTREVISION= 4
CATEGORIES= ftp linux
DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.${LINUX_RPM_ARCH}.rpm \
libcurl-${PORTVERSION}-${RPMVERSION}.${LINUX_RPM_ARCH}.rpm
@@ -23,8 +23,6 @@ RPMVERSION= 40.el6_6.4
BRANDELF_FILES= usr/bin/curl
USE_LDCONFIG= yes
-PLIST_FILES= usr/bin/curl usr/lib/libcurl.so.4 usr/lib/libcurl.so.4.1.1 \
- usr/share/man/man1/curl.1.gz
DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= BUGS COPYING FEATURES README TODO CHANGES FAQ MANUAL RESOURCES TheArtOfHttpScripting
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/ftp/linux-c6-curl/distinfo.x86_64 b/ftp/linux-c6-curl/distinfo.x86_64
new file mode 100644
index 000000000000..c2c00f2b9aad
--- /dev/null
+++ b/ftp/linux-c6-curl/distinfo.x86_64
@@ -0,0 +1,6 @@
+SHA256 (rpm/x86_64/centos/6.6/curl-7.19.7-40.el6_6.4.x86_64.rpm) = 43ac2a840e3bc14b3397ab4bc094315f6e285e291739d53146d4ec9c8287d221
+SIZE (rpm/x86_64/centos/6.6/curl-7.19.7-40.el6_6.4.x86_64.rpm) = 199100
+SHA256 (rpm/x86_64/centos/6.6/libcurl-7.19.7-40.el6_6.4.x86_64.rpm) = f05250feaea200500e271cf1bff1725bdebef29f002bb8fb80dfd9653dfc9f30
+SIZE (rpm/x86_64/centos/6.6/libcurl-7.19.7-40.el6_6.4.x86_64.rpm) = 170256
+SHA256 (rpm/x86_64/centos/6.6/curl-7.19.7-40.el6_6.4.src.rpm) = 44dfa657f77c2777366f6255b71938278db86014fc407e659c228dd3665a4e6b
+SIZE (rpm/x86_64/centos/6.6/curl-7.19.7-40.el6_6.4.src.rpm) = 2115665
diff --git a/ftp/linux-c6-curl/pkg-plist.i686 b/ftp/linux-c6-curl/pkg-plist.i686
new file mode 100644
index 000000000000..0817d154155e
--- /dev/null
+++ b/ftp/linux-c6-curl/pkg-plist.i686
@@ -0,0 +1,4 @@
+usr/bin/curl
+usr/lib/libcurl.so.4
+usr/lib/libcurl.so.4.1.1
+usr/share/man/man1/curl.1.gz
diff --git a/ftp/linux-c6-curl/pkg-plist.x86_64 b/ftp/linux-c6-curl/pkg-plist.x86_64
new file mode 100644
index 000000000000..ca0e96a58b1b
--- /dev/null
+++ b/ftp/linux-c6-curl/pkg-plist.x86_64
@@ -0,0 +1,4 @@
+usr/bin/curl
+usr/lib64/libcurl.so.4
+usr/lib64/libcurl.so.4.1.1
+usr/share/man/man1/curl.1.gz