aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/linux-c7-curl
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-02-01 00:54:21 +0800
committertijl <tijl@FreeBSD.org>2017-02-01 00:54:21 +0800
commit844eb16a686a8eaf36b88417fa047f2a37149374 (patch)
tree31bde26cde7c64937193d64587b12c96997aad8c /ftp/linux-c7-curl
parent475d84cbbcf4a6fe952d02d30a5c2201b7236bbd (diff)
downloadfreebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.tar.gz
freebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.tar.zst
freebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.zip
- Autodetect the installed linux_base port and use LINUX_DEFAULT only as
a last resort. - Construct a list of DISTFILES for every architecture (amd64, i386). Select one list for regular make and all lists for make makesum so linux ports can have one combined distinfo file. - Set DIST_SUBDIR?=centos so there's only one copy of common distfiles. - Use MASTER_SITES and DISTFILES groups so make fetch is a bit smarter. - Regenerate all distinfo files. - For linux_base-c6 (just like linux_base-c7 already does) turn bin, lib, lib64 and sbin into symbolic links to the same directory under usr. This fixes the problem where some programs/libraries exist under / on FreeBSD and /usr on Linux or vice versa and then depending on the order of search paths Linux programs may run/load FreeBSD programs/libraries and fail. - Turn usr/share/icons into a symbolic link to LOCALBASE/share/icons so Linux programs can find desktop theme icons. This eliminates the need for x11-themes/linux*-hicolor-icon-theme. - Rename pkg-plist.x86_64 to pkg-plist.amd64. - Regenerate all pkg-plist files. - Add @preexec to linux_base pkg-plist that moves existing files in bin, lib, lib64, sbin and icons to the new destination before the directories are turned into symbolic links. - Remove several empty directories from linux_base ports. - Sweep over all linux ports: use consistent style, remove old CONFLICTS, remove unused pkg-descr files, add NLS option,... - Remove old linux arts, esound and openssl-compat ports.
Diffstat (limited to 'ftp/linux-c7-curl')
-rw-r--r--ftp/linux-c7-curl/Makefile7
-rw-r--r--ftp/linux-c7-curl/distinfo (renamed from ftp/linux-c7-curl/distinfo.x86_64)6
-rw-r--r--ftp/linux-c7-curl/pkg-plist.amd6416
-rw-r--r--ftp/linux-c7-curl/pkg-plist.x86_646
4 files changed, 21 insertions, 14 deletions
diff --git a/ftp/linux-c7-curl/Makefile b/ftp/linux-c7-curl/Makefile
index 77f0f16541c6..0781c389b753 100644
--- a/ftp/linux-c7-curl/Makefile
+++ b/ftp/linux-c7-curl/Makefile
@@ -5,8 +5,7 @@ PORTNAME= curl
PORTVERSION= 7.29.0
PORTREVISION= 2
CATEGORIES= ftp linux
-LIB_DISTFILES= lib${DISTNAME}${EXTRACT_SUFX}
-SRC_DISTFILES= ${DISTNAME}${SRC_SUFX}:SOURCE
+LIB_DISTNAMES= lib${DISTNAME}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Tool for transferring files with URL syntax (Linux CentOS ${LINUX_DIST_VER})
@@ -15,13 +14,11 @@ LICENSE= MIT
CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
RPMVERSION= 35.el7.centos
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= libssh2 nspr nss openldap
USE_LINUX_RPM= nolib
-PORTDOCS= BUGS COPYING FEATURES README TODO CHANGES FAQ MANUAL RESOURCES TheArtOfHttpScripting
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-
.include <bsd.port.mk>
diff --git a/ftp/linux-c7-curl/distinfo.x86_64 b/ftp/linux-c7-curl/distinfo
index b92d3d498211..19e95267ef41 100644
--- a/ftp/linux-c7-curl/distinfo.x86_64
+++ b/ftp/linux-c7-curl/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1482093396
+TIMESTAMP = 1485538844
+SHA256 (centos/curl-7.29.0-35.el7.centos.x86_64.rpm) = b5033a0264884f1f58e45313508fe4f59729781085556b300aaa830708c57925
+SIZE (centos/curl-7.29.0-35.el7.centos.x86_64.rpm) = 271788
SHA256 (centos/libcurl-7.29.0-35.el7.centos.i686.rpm) = cdf194606bbe5b2d7320d7a7f59d5b4cc1d792a3adeaa582ef19b3c93a4ff79b
SIZE (centos/libcurl-7.29.0-35.el7.centos.i686.rpm) = 225880
SHA256 (centos/libcurl-7.29.0-35.el7.centos.x86_64.rpm) = e5c842119c77de93b4b6c4b6b33c0fc03b9814bfe3bb3d3ed2c145e48fb0de49
SIZE (centos/libcurl-7.29.0-35.el7.centos.x86_64.rpm) = 223176
-SHA256 (centos/curl-7.29.0-35.el7.centos.x86_64.rpm) = b5033a0264884f1f58e45313508fe4f59729781085556b300aaa830708c57925
-SIZE (centos/curl-7.29.0-35.el7.centos.x86_64.rpm) = 271788
SHA256 (centos/curl-7.29.0-35.el7.centos.src.rpm) = da6c27444a5ff5591250098c562926faf561b0282981f0a9219bad8d508806bf
SIZE (centos/curl-7.29.0-35.el7.centos.src.rpm) = 2283630
diff --git a/ftp/linux-c7-curl/pkg-plist.amd64 b/ftp/linux-c7-curl/pkg-plist.amd64
new file mode 100644
index 000000000000..45e39e81a43c
--- /dev/null
+++ b/ftp/linux-c7-curl/pkg-plist.amd64
@@ -0,0 +1,16 @@
+usr/bin/curl
+usr/lib/libcurl.so.4
+usr/lib/libcurl.so.4.3.0
+usr/lib64/libcurl.so.4
+usr/lib64/libcurl.so.4.3.0
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/FEATURES
+%%PORTDOCS%%%%DOCSDIR%%/MANUAL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/RESOURCES
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/TheArtOfHttpScripting
+usr/share/man/man1/curl.1.gz
diff --git a/ftp/linux-c7-curl/pkg-plist.x86_64 b/ftp/linux-c7-curl/pkg-plist.x86_64
deleted file mode 100644
index a795b86c115b..000000000000
--- a/ftp/linux-c7-curl/pkg-plist.x86_64
+++ /dev/null
@@ -1,6 +0,0 @@
-usr/bin/curl
-usr/lib/libcurl.so.4
-usr/lib/libcurl.so.4.3.0
-usr/lib64/libcurl.so.4
-usr/lib64/libcurl.so.4.3.0
-usr/share/man/man1/curl.1.gz