aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd-devel
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2005-10-10 13:28:57 +0800
committermharo <mharo@FreeBSD.org>2005-10-10 13:28:57 +0800
commit7b876c08ce49a847e4bb7b31d32f4bb80b3cae9e (patch)
treee95bb80de1064ad75c1e80ead18d077c94569139 /ftp/proftpd-devel
parent31b8f1cf2c00fc308a91b6629b3392a5f86f39be (diff)
downloadfreebsd-ports-gnome-7b876c08ce49a847e4bb7b31d32f4bb80b3cae9e.tar.gz
freebsd-ports-gnome-7b876c08ce49a847e4bb7b31d32f4bb80b3cae9e.tar.zst
freebsd-ports-gnome-7b876c08ce49a847e4bb7b31d32f4bb80b3cae9e.zip
Fix WITH_CTRLS option
PR: 80832 Submitted by: Matus UHLAR - fantomas
Diffstat (limited to 'ftp/proftpd-devel')
-rw-r--r--ftp/proftpd-devel/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index 249ce787b828..00863adb9752 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.0rc2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -129,8 +129,10 @@ MODULES:=${MODULES}:mod_tls
.if defined(WITH_CTRLS)
CONFIGURE_ARGS+= --enable-ctrls
-MAN8+= ftpdctl.8
-.else
+PLIST_FILES+= sbin/ftpdctl
+.if !defined(WITHOUT_CTRLS_ADMIN)
+MODULES:=${MODULES}:mod_ctrls_admin
+.endif
.endif
.if defined(WITH_QUOTA)
@@ -189,4 +191,9 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
+.if defined(WITH_CTRLS)
+ @${INSTALL_PROGRAM} ${WRKSRC}/ftpdctl ${PREFIX}/sbin/ftpdctl
+ @${INSTALL_MAN} ${WRKSRC}/src/ftpdctl.8 ${PREFIX}/man/man8/ftpdctl.8
+.endif
+
.include <bsd.port.post.mk>