aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd/Makefile
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-12-30 04:58:59 +0800
committermm <mm@FreeBSD.org>2011-12-30 04:58:59 +0800
commitf7c89c06cd59e3a4c1e0485938cff188e2f6f7ee (patch)
tree8e1879a3f6cd7adb10de08b26fe9151873a21222 /ftp/proftpd/Makefile
parent4e4bca283ca2d32d17000fb41089500ed23bdcc5 (diff)
downloadfreebsd-ports-gnome-f7c89c06cd59e3a4c1e0485938cff188e2f6f7ee.tar.gz
freebsd-ports-gnome-f7c89c06cd59e3a4c1e0485938cff188e2f6f7ee.tar.zst
freebsd-ports-gnome-f7c89c06cd59e3a4c1e0485938cff188e2f6f7ee.zip
As of FreeBSD-SA-11:07.chroot, the port now works on both patched and
unpatched systems. On unpatched systems chroot automatically fails. FreeBSD-SA-11:07.chroot Add MOD_DYNMASQ
Diffstat (limited to 'ftp/proftpd/Makefile')
-rw-r--r--ftp/proftpd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 4e2c0d081003..78d533cc9782 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
PORTVERSION= 1.3.3g
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -55,6 +55,7 @@ CONFIGURE_ARGS= --localstatedir=${LOCALSTATEDIR} \
OPTIONS= BAN "Include mod_ban (Requires CTRLS)" off \
CLAMAV "Include mod_clamav" off \
CTRLS "Include controls" off \
+ DYNMASQ "Include mod_dynmasq" off \
EXEC "Include mod_exec" off \
HTMLDOCS "Include HTML documentation" off \
IFSESSION "Include mod_ifsession" on \
@@ -143,6 +144,10 @@ LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
MODULES:=${MODULES}:mod_wrap2_sql
.endif
+.if defined(WITH_DYNMASQ)
+MODULES:=${MODULES}:mod_dynmasq
+.endif
+
.if defined(WITH_EXEC)
MODULES:=${MODULES}:mod_exec
.endif