aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-31 06:45:40 +0800
committermiwi <miwi@FreeBSD.org>2006-12-31 06:45:40 +0800
commit67ef46f1e9121a68e461c81dafb7b477769dd81e (patch)
tree1b58d5e34336b6a7f4f32d39d0e50ed3db55151e /ftp/proftpd
parent97229f654522d031cdc68323d10e9af23783922d (diff)
downloadfreebsd-ports-gnome-67ef46f1e9121a68e461c81dafb7b477769dd81e.tar.gz
freebsd-ports-gnome-67ef46f1e9121a68e461c81dafb7b477769dd81e.tar.zst
freebsd-ports-gnome-67ef46f1e9121a68e461c81dafb7b477769dd81e.zip
- Fixed Makefile
- Added patch - patch-getopt.c (Upgrades lib/getopt.c to version 1.4 - Bumped PORTREVISION PR: ports/107221 ports/107107 ports/105947 Submitted by: Beech Rintoul <beech@alaskaparadise.com> (maintainer) Johan Svensson<johan@loxley.se> Matus UHLAR - fantomas<uhlar@fantomas.sk>
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile13
-rw-r--r--ftp/proftpd/files/extra-patch-nls-Makefile.in15
-rw-r--r--ftp/proftpd/files/patch-contrib-mod_wrap2-Makefile.in11
-rw-r--r--ftp/proftpd/files/patch-getopt.c20
4 files changed, 52 insertions, 7 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 7828bb5d066a..e3a7e4c8a74e 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1rc1
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -54,11 +55,10 @@ OPTIONS= IPV6 "Use IPv6" off \
WRAP "Include mod_wrap2" on \
WRAP_FILE "include mod_wrap2_file" off \
WRAP_SQL "include mod_wrap2_sql" off \
- LANG "include mod_lang" off \
RADIUS "Include mod_radius" off \
QUOTATAB_RADIUS "include mod_quotatab_radius" off \
BAN "include mod_ban (Requires CTRLS)" off \
- NLS "Use nls" off
+ NLS "Use nls-builds mod_lang" off
MODULES?=
LIBDIRS?=
@@ -109,10 +109,6 @@ MODULES:=${MODULES}:mod_radius
MODULES:=${MODULES}:mod_quotatab_radius
.endif
-.if defined(WITH_LANG)
-MODULES:=${MODULES}:mod_lang
-.endif
-
.if defined(WITH_BAN)
MODULES:=${MODULES}:mod_ban
.endif
@@ -137,10 +133,13 @@ CONFIGURE_ARGS+= --disable-ipv6
INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
CONFIGURE_ARGS+= --enable-nls
+USE_GETTEXT=yes
+PROFTPD_LIBS+= -lintl -L${LOCALBASE}/lib
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-nls-Makefile.in
.endif
#allow user to override
-MODULES?= mod_ratio:mod_readme:mod_rewrite:mod_wrap:mod_ifsession
+MODULES?= mod_ratio:mod_readme:mod_rewrite:mod_wrap2:mod_ifsession
INCLUDEDIRS?=
LIBDIRS?=
diff --git a/ftp/proftpd/files/extra-patch-nls-Makefile.in b/ftp/proftpd/files/extra-patch-nls-Makefile.in
new file mode 100644
index 000000000000..cf0ceb981612
--- /dev/null
+++ b/ftp/proftpd/files/extra-patch-nls-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in Fri Dec 29 09:19:12 2006
++++ Makefile.in.new Fri Dec 29 09:19:22 2006
+@@ -63,10 +63,10 @@
+ $(CC) $(LDFLAGS) -o $@ $(BUILD_FTPSHUT_OBJS)
+
+ ftptop$(EXEEXT): lib utils
+- $(CC) $(LDFLAGS) -o $@ $(BUILD_FTPTOP_OBJS) $(CURSES_LIBS) -lsupp
++ $(CC) $(LDFLAGS) -o $@ $(BUILD_FTPTOP_OBJS) $(CURSES_LIBS) -lsupp -lintl
+
+ ftpwho$(EXEEXT): lib utils
+- $(CC) $(LDFLAGS) -o $@ $(BUILD_FTPWHO_OBJS) -lsupp
++ $(CC) $(LDFLAGS) -o $@ $(BUILD_FTPWHO_OBJS) -lsupp -lintl
+
+
+ # BSD install -d doesn't work, so ...
diff --git a/ftp/proftpd/files/patch-contrib-mod_wrap2-Makefile.in b/ftp/proftpd/files/patch-contrib-mod_wrap2-Makefile.in
new file mode 100644
index 000000000000..ad39d6af333e
--- /dev/null
+++ b/ftp/proftpd/files/patch-contrib-mod_wrap2-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/mod_wrap2/Makefile.in.orig Wed Sep 6 15:11:47 2006
++++ contrib/mod_wrap2/Makefile.in Thu Dec 28 11:41:24 2006
+@@ -13,7 +13,7 @@
+ MODULE_NAME=mod_wrap2
+
+ # Necessary redefinitions
+-INCLUDES=-I. -I../.. -I../../include
++INCLUDES=-I. -I../.. -I../../include -I/usr/local/include
+ CPPFLAGS= -DHAVE_CONFIG_H $(DEFAULT_PATHS) $(PLATFORM) $(INCLUDES)
+ LDFLAGS=-L../../lib
+
diff --git a/ftp/proftpd/files/patch-getopt.c b/ftp/proftpd/files/patch-getopt.c
new file mode 100644
index 000000000000..4dae5eb270b2
--- /dev/null
+++ b/ftp/proftpd/files/patch-getopt.c
@@ -0,0 +1,20 @@
+--- lib/getopt.c.orig Thu Feb 28 10:30:01 2002
++++ lib/getopt.c Tue Dec 26 13:39:53 2006
+@@ -76,7 +76,7 @@
+ # endif
+ #endif
+
+-#ifndef _
++#if defined(PR_USE_NLS) && !defined(_)
+ /* This is for other GNU distributions with internationalized messages.
+ When compiling libc, the _ macro is predefined. */
+ # ifdef HAVE_LIBINTL_H
+@@ -85,6 +85,8 @@
+ # else
+ # define _(msgid) (msgid)
+ # endif
++#else
++# define _(msgid) (msgid)
+ #endif
+
+ /* This version of `getopt' appears to the caller like standard Unix `getopt'