aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wget/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-03-03 08:52:42 +0800
committersf <sf@FreeBSD.org>2003-03-03 08:52:42 +0800
commitc987d8d5c9ed6ae1f3624cd1a8441073be40ef07 (patch)
tree2ee0826c53cb8b8faa5028ad9771347ad799556e /ftp/wget/Makefile
parent8cd9cef2ae1b94abd52aac45bc2c96d2c6cc7ce3 (diff)
downloadfreebsd-ports-gnome-c987d8d5c9ed6ae1f3624cd1a8441073be40ef07.tar.gz
freebsd-ports-gnome-c987d8d5c9ed6ae1f3624cd1a8441073be40ef07.tar.zst
freebsd-ports-gnome-c987d8d5c9ed6ae1f3624cd1a8441073be40ef07.zip
o import Debian patches.
- fix .netrc parsing bug - fix 2GB limitation - re-add IPv6 capability - fix SEGV with special url line check debian/changelog for more detail. o replace /usr/local with ${PREFIX} in wgetrc and info. PR: 38824 reported 2GB limitation Obtained from: Debian GNU/Linux
Diffstat (limited to 'ftp/wget/Makefile')
-rw-r--r--ftp/wget/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 97b9c6889d14..61167947bf27 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -7,15 +7,21 @@
PORTNAME= wget
PORTVERSION= 1.8.2
-PORTREVISION= 2
-CATEGORIES= ftp www
+PORTREVISION= 3
+CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= wget
+PATCH_SITES= ${MASTER_SITE_DEBIAN}
+PATCH_SITE_SUBDIR= pool/main/w/wget
+PATCHFILES= wget_${PORTVERSION}-9.diff.gz
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= sf@FreeBSD.org
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+USE_REINPLACE= yes
USE_PERL5_BUILD= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -34,6 +40,9 @@ post-patch:
${RM} -f ${WRKSRC}/doc/wget.info*
# we don't need to run autoconf.
${TOUCH} ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,/etc/wgetrc,${PREFIX}/etc/wgetrc,' \
+ -e 's,@file{},@file{${PREFIX}},' \
+ ${WRKSRC}/doc/sample.wgetrc* ${WRKSRC}/doc/wget.texi
post-install:
install-info ${PREFIX}/info/wget.info ${PREFIX}/info/dir