aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2012-03-11 03:39:02 +0800
committercy <cy@FreeBSD.org>2012-03-11 03:39:02 +0800
commit8281d9d1f0a3216e1fdf1489dd37a8efefa36010 (patch)
tree491c86bdaca0a3334aea1568acab45c963f63fef /ftp
parent9526452f4d6e6688c34e71db34ef2c7beed1e92c (diff)
downloadfreebsd-ports-gnome-8281d9d1f0a3216e1fdf1489dd37a8efefa36010.tar.gz
freebsd-ports-gnome-8281d9d1f0a3216e1fdf1489dd37a8efefa36010.tar.zst
freebsd-ports-gnome-8281d9d1f0a3216e1fdf1489dd37a8efefa36010.zip
Fix select() issue.
Feature safe: yes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/llnlxftp/Makefile2
-rw-r--r--ftp/llnlxftp/files/patch-local.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/ftp/llnlxftp/Makefile b/ftp/llnlxftp/Makefile
index 99af72fac657..07b7d6474cf7 100644
--- a/ftp/llnlxftp/Makefile
+++ b/ftp/llnlxftp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= llnlxftp
PORTVERSION= 2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= https://computing.llnl.gov/resources/xdir/
DISTNAME= llnlxftp2.1
diff --git a/ftp/llnlxftp/files/patch-local.c b/ftp/llnlxftp/files/patch-local.c
new file mode 100644
index 000000000000..896db7ca85c3
--- /dev/null
+++ b/ftp/llnlxftp/files/patch-local.c
@@ -0,0 +1,18 @@
+--- local.c.orig 1995-10-19 08:20:22.000000000 -0700
++++ local.c 2012-03-10 11:24:10.000000000 -0800
+@@ -201,11 +201,15 @@
+ #ifdef _SC_OPEN_MAX /* POSIX */
+ if ((max_files = sysconf(_SC_OPEN_MAX)) == -1)
+ fatal_error("Trouble in max_fds() - sysconf() failed");
++ if (max_files > 1024)
++ max_files=1024;
+ #else
+ #ifdef _NFILE /* Might be overkill */
+ max_files = _NFILE;
+ #else /* Assume BSD */
+ max_files = getdtablesize();
++ if ((max_files = getdtablesize()) > 1024)
++ max_files=1024;
+ #endif
+ #endif
+