aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-02-21 22:12:07 +0800
committerThomas Zander <riggs@FreeBSD.org>2015-02-21 22:12:07 +0800
commit88757777924d8e17c9b36fbe1bccd2562b72a924 (patch)
treee2c4cd0fe082f09f2d615eef50025f405b2f4608 /ftp
parentb3b7e8761b778ad7fea086588ca6bf40c44f7eee (diff)
downloadfreebsd-ports-gnome-88757777924d8e17c9b36fbe1bccd2562b72a924.tar.gz
freebsd-ports-gnome-88757777924d8e17c9b36fbe1bccd2562b72a924.tar.zst
freebsd-ports-gnome-88757777924d8e17c9b36fbe1bccd2562b72a924.zip
- Fix build with PF OPTION selected [1]
- Move IPFILTER / PF OPTIONS into OPTIONS_RADIO because port does not build if both are selected [2] PR: 197412 Submitted by: fidaj@ukr.net [1] Reviewed by: riggs [2] Approved by: maintainer timeout
Diffstat (limited to 'ftp')
-rw-r--r--ftp/frox/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index 217a53e4d150..5aa2cc84df15 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -30,9 +30,12 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ARGS= --enable-configfile=${PREFIX}/etc/frox.conf
-OPTIONS_DEFINE= IPFILTER PF VIRUS_SCAN HTTP_CACHE LOCAL_CACHE CCP ROOT_RUN DOCS
+OPTIONS_DEFINE= VIRUS_SCAN HTTP_CACHE LOCAL_CACHE CCP ROOT_RUN DOCS
OPTIONS_DEFAULT= HTTP_CACHE CCP
+OPTIONS_RADIO= PFILTER
+OPTIONS_RADIO_PFILTER= IPFILTER PF
+
IPFILTER_DESC= Use ipfilter instead of ipfw
PF_DESC= Build with pf(4) support
VIRUS_SCAN_DESC= Run external virus scaner on each download
@@ -42,7 +45,7 @@ CCP_DESC= Ftp-proxy style command control programs
ROOT_RUN_DESC= Allow frox running as root (not recomended)
IPFILTER_CONFIGURE_ENABLE= ipfilter
-PF_CPPFLAGS= DPF
+PF_CPPFLAGS= -DPF
VIRUS_SCAN_CONFIGURE_ENABLE= virus-scan
HTTP_CACHE_CONFIGURE_ENABLE= http-cache
LOCAL_CACHE_CONFIGURE_ENABLE= local-cache