aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /ftp
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/pureadmin/Makefile3
-rw-r--r--ftp/wzdftpd/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/ftp/pureadmin/Makefile b/ftp/pureadmin/Makefile
index 270b427de160..d8943c847f35 100644
--- a/ftp/pureadmin/Makefile
+++ b/ftp/pureadmin/Makefile
@@ -15,9 +15,8 @@ MASTER_SITES= SF/purify/Default/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Management utility for the PureFTPd
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_GNOME= gnomehack libglade2
+USE_PKGCONFIG= yes
USE_FAM= yes
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index f7b228c66940..f63835478fdd 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -14,13 +14,12 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-sources/${PORTNAME}-0.8
MAINTAINER= ports@FreeBSD.org
COMMENT= Modular FTP server configurable online using SITE commands
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_AUTOTOOLS= libtool
USE_RC_SUBR= wzdftpd.sh
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
USE_GNOME= ltverhack
CONFIGURE_ARGS+= --without-pam --disable-pgsql --disable-bonjour
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}