aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-08 09:12:10 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-08 09:12:10 +0800
commit9ccc7e92dea72d32d4ae04470bbce43e6f9227da (patch)
tree20264757b2346c435477e3f6cfdf324086bbafe9 /ftp
parent07d9e093a64a0c7f96ed0775d50e0f818d98fd80 (diff)
downloadfreebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.tar.gz
freebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.tar.zst
freebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Diffstat (limited to 'ftp')
-rw-r--r--ftp/ftpsync/Makefile8
-rw-r--r--ftp/p5-File-Fetch/Makefile8
-rw-r--r--ftp/p5-Net-FTP-Common/Makefile8
-rw-r--r--ftp/p5-Net-FTPServer/Makefile4
4 files changed, 3 insertions, 25 deletions
diff --git a/ftp/ftpsync/Makefile b/ftp/ftpsync/Makefile
index 101950674925..d89a7d66d41b 100644
--- a/ftp/ftpsync/Makefile
+++ b/ftp/ftpsync/Makefile
@@ -20,13 +20,7 @@ USE_BZIP2= yes
USE_PERL5= yes
PLIST_FILES= bin/${PORTNAME}.pl
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
-.endif
-
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/p5-File-Fetch/Makefile b/ftp/p5-File-Fetch/Makefile
index 9e7a1c97f4ee..773fb36cb9fd 100644
--- a/ftp/p5-File-Fetch/Makefile
+++ b/ftp/p5-File-Fetch/Makefile
@@ -24,10 +24,4 @@ MAN3= File::Fetch.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/p5-Net-FTP-Common/Makefile b/ftp/p5-Net-FTP-Common/Makefile
index 9fb27634068e..1a873936c217 100644
--- a/ftp/p5-Net-FTP-Common/Makefile
+++ b/ftp/p5-Net-FTP-Common/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Net::FTP::Common.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600 # inherited from security/p5-Authen-SASL
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/p5-Net-FTPServer/Makefile b/ftp/p5-Net-FTPServer/Makefile
index 5f2355dc7b86..73495673ecd7 100644
--- a/ftp/p5-Net-FTPServer/Makefile
+++ b/ftp/p5-Net-FTPServer/Makefile
@@ -55,10 +55,6 @@ DOCS= FAQ README TODO doc/*
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 then try again
-.endif
-
.if ${PERL_LEVEL} < 500703
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net