aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-10-09 03:22:45 +0800
committerbeech <beech@FreeBSD.org>2007-10-09 03:22:45 +0800
commitba0022b45b22dc9be9734814e26125dc21607c9c (patch)
tree5d0309a5b6b3320de59d199fb52a15e7d8166845 /ftp
parenta29c417a56012205d877d53c2563fbd37b52c540 (diff)
downloadfreebsd-ports-gnome-ba0022b45b22dc9be9734814e26125dc21607c9c.tar.gz
freebsd-ports-gnome-ba0022b45b22dc9be9734814e26125dc21607c9c.tar.zst
freebsd-ports-gnome-ba0022b45b22dc9be9734814e26125dc21607c9c.zip
- Add vendor patch to fix bug - Authoritative PAM is not honored
- Bump portrevision Reported by: TJ Saunders <tj@castaglia.org> (developer) Approved by: sat (mentor, implicit)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd-devel/Makefile1
-rw-r--r--ftp/proftpd-devel/files/patch-src-auth.c43
-rw-r--r--ftp/proftpd/Makefile1
-rw-r--r--ftp/proftpd/files/patch-src-auth.c43
4 files changed, 88 insertions, 0 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index bf8501c4ef26..e3ab3a76a711 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
diff --git a/ftp/proftpd-devel/files/patch-src-auth.c b/ftp/proftpd-devel/files/patch-src-auth.c
new file mode 100644
index 000000000000..61386a883e9f
--- /dev/null
+++ b/ftp/proftpd-devel/files/patch-src-auth.c
@@ -0,0 +1,43 @@
+ndex: src/auth.c
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/src/auth.c,v
+retrieving revision 1.52
+diff -u -r1.52 auth.c
+--- src/auth.c 5 Oct 2007 17:04:13 -0000 1.52
++++ src/auth.c 8 Oct 2007 18:44:21 -0000
+@@ -503,6 +503,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+
+@@ -566,6 +577,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index bf8501c4ef26..e3ab3a76a711 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
diff --git a/ftp/proftpd/files/patch-src-auth.c b/ftp/proftpd/files/patch-src-auth.c
new file mode 100644
index 000000000000..61386a883e9f
--- /dev/null
+++ b/ftp/proftpd/files/patch-src-auth.c
@@ -0,0 +1,43 @@
+ndex: src/auth.c
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/src/auth.c,v
+retrieving revision 1.52
+diff -u -r1.52 auth.c
+--- src/auth.c 5 Oct 2007 17:04:13 -0000 1.52
++++ src/auth.c 8 Oct 2007 18:44:21 -0000
+@@ -503,6 +503,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+
+@@ -566,6 +577,17 @@
+ return res;
+ }
+
++ if (MODRET_ISERROR(mr)) {
++ res = MODRET_ERROR(mr);
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
+ m = NULL;
+ }
+