aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2019-03-28 22:04:14 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2019-03-28 22:04:14 +0800
commitbce89de29443858e5e73bb420f5c7d5d1966dfd4 (patch)
tree008b7502d6eb6d4f50d27a935d92ce2372de689e /ftp
parent5156222ab3d191ffbe6c66cbab63aabff9555688 (diff)
downloadfreebsd-ports-gnome-bce89de29443858e5e73bb420f5c7d5d1966dfd4.tar.gz
freebsd-ports-gnome-bce89de29443858e5e73bb420f5c7d5d1966dfd4.tar.zst
freebsd-ports-gnome-bce89de29443858e5e73bb420f5c7d5d1966dfd4.zip
ftp client/server for asyncio
WWW: https://aioftp.readthedocs.io/
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/py-aioftp/Makefile29
-rw-r--r--ftp/py-aioftp/distinfo3
-rw-r--r--ftp/py-aioftp/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 2532b9e97259..557be6bb5c68 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -75,6 +75,7 @@
SUBDIR += puf
SUBDIR += pure-ftpd
SUBDIR += pureadmin
+ SUBDIR += py-aioftp
SUBDIR += py-ftputil
SUBDIR += py-pycurl
SUBDIR += py-pyftpdlib
diff --git a/ftp/py-aioftp/Makefile b/ftp/py-aioftp/Makefile
new file mode 100644
index 000000000000..3b844b4b25fb
--- /dev/null
+++ b/ftp/py-aioftp/Makefile
@@ -0,0 +1,29 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aioftp
+PORTVERSION= 0.13.0
+CATEGORIES= ftp
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= ftp client/server for asyncio
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}trustme>=0:security/py-trustme@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}async_timeout>0:devel/py-async_timeout@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/ftp/py-aioftp/distinfo b/ftp/py-aioftp/distinfo
new file mode 100644
index 000000000000..c5b1c62aca90
--- /dev/null
+++ b/ftp/py-aioftp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1553707731
+SHA256 (aioftp-0.13.0.tar.gz) = 5711c03433b510c101e9337069033133cca19b508b5162b414bed24320de6c18
+SIZE (aioftp-0.13.0.tar.gz) = 87069
diff --git a/ftp/py-aioftp/pkg-descr b/ftp/py-aioftp/pkg-descr
new file mode 100644
index 000000000000..78e447942dab
--- /dev/null
+++ b/ftp/py-aioftp/pkg-descr
@@ -0,0 +1,3 @@
+ftp client/server for asyncio
+
+WWW: https://aioftp.readthedocs.io/