aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-09-20 20:54:54 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2013-09-20 20:54:54 +0800
commitc93dfc2e9f8b7b990c22c6baa6cdab361cd12e16 (patch)
treee61ab76efa292f985d8e20e449572329fa964c1c /ftp
parentb10d5a64b7ea8bb32e9735304272e7344926e3b2 (diff)
downloadfreebsd-ports-gnome-c93dfc2e9f8b7b990c22c6baa6cdab361cd12e16.tar.gz
freebsd-ports-gnome-c93dfc2e9f8b7b990c22c6baa6cdab361cd12e16.tar.zst
freebsd-ports-gnome-c93dfc2e9f8b7b990c22c6baa6cdab361cd12e16.zip
SSP support has been added to ports with WITH_SSP for i386 and amd64
on FreeBSD 10, and amd64 on earlier versions. SSP_UNSAFE is added to disable in a port if it fails to build, but this should only be used in rare circumstances such as kernel modules. Otherwise, the port may just be failing due to lack of respecting LDFLAGS. On FreeBSD 10, this uses an ldscript in /usr/lib/libc.so to pull in libssp_nonshared.a to address issues linking on i386 [1]. On earlier FreeBSD versions the WITH_SSP knob will add -lssp_nonshared to LDFLAGS on i386. This is not needed on amd64. However, several hundred ports do not currently respect LDFLAGS, so this support is disabled currently as it causes build failures if a dependency is looking for the stack_chk symbols. Many thanks to jlh@ for this as he had many years of patience in getting all of the necessary pieces [1][2] in. [1] http://svnweb.freebsd.org/base/head/lib/libc/libc.ldscript?revision=251668&view=markup PR: ports/138228 [2] Submitted by: jlh (bsd.ssp.mk based on) Reviewed by: bapt With hat: portmgr exp-runs done: 37 over a month on 91i386,91amd64,10i386,10amd64
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl-hiphop/Makefile8
-rw-r--r--ftp/curl/Makefile2
2 files changed, 5 insertions, 5 deletions
diff --git a/ftp/curl-hiphop/Makefile b/ftp/curl-hiphop/Makefile
index f50778cd0bad..1ee9655e78ac 100644
--- a/ftp/curl-hiphop/Makefile
+++ b/ftp/curl-hiphop/Makefile
@@ -1,15 +1,13 @@
-# New ports collection makefile for: curl-hiphop
-# Date created: 16 July 2012
-# Whom: Martin Matuska <mm@FreeBSd.org>
-#
+# Created by: Martin Matuska <mm@FreeBSD.org>
# $FreeBSD$
-#
PKGNAMESUFFIX= -hiphop
MAINTAINER= mm@FreeBSD.org
COMMENT= Static libcurl with custom patches for HipHop
+SSP_UNSAFE= Refuses -l in LDFLAGS
+
BUILDING_HIPHOP= yes
HIPHOP_DIR= share/hiphop-php
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 370e51815d8d..a949fd29071e 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -14,6 +14,8 @@ COMMENT?= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
LICENSE= MIT
+SSP_UNSAFE= Refuses -l in LDFLAGS
+
OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES GSSAPI IDN IPV6 LDAP LDAPS LIBSSH2 NTLM PROXY RTMP SPNEGO TLS_SRP
OPTIONS_RADIO= RESOLV SSL
OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER