aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2017-12-14 01:22:46 +0800
committerJochen Neumeister <joneum@FreeBSD.org>2017-12-14 01:22:46 +0800
commitce975ccd400aa6e3bedb17ad2feac8f94cc75d51 (patch)
tree1d586cc256f558a611a16bc227a2bf9add364bbb /ftp
parent12ee0ea93efae82d3e10820a5b123e888781d718 (diff)
downloadfreebsd-ports-gnome-ce975ccd400aa6e3bedb17ad2feac8f94cc75d51.tar.gz
freebsd-ports-gnome-ce975ccd400aa6e3bedb17ad2feac8f94cc75d51.tar.zst
freebsd-ports-gnome-ce975ccd400aa6e3bedb17ad2feac8f94cc75d51.zip
ftp/php*-fastdfs: Remake to Master/Slave Ports
PR: 223714 Submitted by: Daniel Ylitalo <daniel@blodan.se> (maintainer) Approved by: tz (mentor) Differential Revision: https://reviews.freebsd.org/D13454
Diffstat (limited to 'ftp')
-rw-r--r--ftp/php56-fastdfs/Makefile9
-rw-r--r--ftp/php70-fastdfs/Makefile25
-rw-r--r--ftp/php70-fastdfs/distinfo3
-rw-r--r--ftp/php70-fastdfs/pkg-descr3
-rw-r--r--ftp/php70-fastdfs/pkg-message15
-rw-r--r--ftp/php71-fastdfs/Makefile25
-rw-r--r--ftp/php71-fastdfs/distinfo3
-rw-r--r--ftp/php71-fastdfs/pkg-descr3
-rw-r--r--ftp/php71-fastdfs/pkg-message15
9 files changed, 13 insertions, 88 deletions
diff --git a/ftp/php56-fastdfs/Makefile b/ftp/php56-fastdfs/Makefile
index 5db9a234e737..ea2e5e097937 100644
--- a/ftp/php56-fastdfs/Makefile
+++ b/ftp/php56-fastdfs/Makefile
@@ -1,12 +1,13 @@
# $FreeBSD$
PORTNAME= fastdfs
-PORTVERSION= 5.0.11
+DISTVERSION= 5.0.11
CATEGORIES= ftp
-PKGNAMEPREFIX= php56-
+PKGNAMEPREFIX?= php56-
+IGNORE_WITH_PHP?= 70 71 72
MAINTAINER= daniel@blodan.se
-COMMENT= PHP 5.6 module for accessing a FastDFS cluster
+COMMENT?= PHP 5.6 module for accessing a FastDFS cluster
LICENSE= GPLv3+
@@ -19,7 +20,7 @@ GH_PROJECT= fastdfs
GH_TAGNAME= 1e50b4f
USES= php:ext
-PHP_VER= 56
+PHP_VER?= 56
WRKSRC_SUBDIR= php_client
CONFIGURE_ENV= ROOT=${LOCALBASE}
diff --git a/ftp/php70-fastdfs/Makefile b/ftp/php70-fastdfs/Makefile
index 79fb2681bd07..47e7e0bb792b 100644
--- a/ftp/php70-fastdfs/Makefile
+++ b/ftp/php70-fastdfs/Makefile
@@ -1,29 +1,12 @@
# $FreeBSD$
-PORTNAME= fastdfs
-PORTVERSION= 5.0.11
-CATEGORIES= ftp
+MASTERDIR= ${.CURDIR}/../php56-fastdfs
+
PKGNAMEPREFIX= php70-
-MAINTAINER= daniel@blodan.se
COMMENT= PHP 7 module for accessing a FastDFS cluster
-LICENSE= GPLv3+
-
-LIB_DEPENDS= libfastcommon.so:devel/libfastcommon \
- libfdfsclient.so:ftp/fastdfs
-
-USE_GITHUB= yes
-GH_ACCOUNT= happyfish100
-GH_PROJECT= fastdfs
-GH_TAGNAME= 1e50b4f
-
-USES= php:ext
+IGNORE_WITH_PHP= 56 71 72
PHP_VER= 70
-WRKSRC_SUBDIR= php_client
-CONFIGURE_ENV= ROOT=${LOCALBASE}
-
-PHP_MODNAME= fastdfs_client
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/ftp/php70-fastdfs/distinfo b/ftp/php70-fastdfs/distinfo
deleted file mode 100644
index a2955a52edd8..000000000000
--- a/ftp/php70-fastdfs/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1502819550
-SHA256 (happyfish100-fastdfs-5.0.11-1e50b4f_GH0.tar.gz) = 42ef67951c55fb416282cd20389dde5709016913debbb87465b9b744fa3dacf9
-SIZE (happyfish100-fastdfs-5.0.11-1e50b4f_GH0.tar.gz) = 336996
diff --git a/ftp/php70-fastdfs/pkg-descr b/ftp/php70-fastdfs/pkg-descr
deleted file mode 100644
index d90caa5fc86a..000000000000
--- a/ftp/php70-fastdfs/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-PHP module for accessing a FastDFS cluster
-
-WWW: https://github.com/happyfish100/fastdfs
diff --git a/ftp/php70-fastdfs/pkg-message b/ftp/php70-fastdfs/pkg-message
deleted file mode 100644
index 993d158f9115..000000000000
--- a/ftp/php70-fastdfs/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
-Before you can start using this module;
-- Make sure you have configured client.conf to point to your FastDFS cluster
- and that you see the cluster with fdfs_monitor
-- Add this to your php.ini file
-==================================================================
-fastdfs_client.base_path = /var/tmp
-fastdfs_client.connect_timeout = 2
-fastdfs_client.network_timeout = 60
-fastdfs_client.log_level = info
-fastdfs_client.log_filename =
-fastdfs_client.http.anti_steal_secret_key =
-fastdfs_client.tracker_group_count = 1
-fastdfs_client.tracker_group0 = /usr/local/etc/fdfs/client.conf
-fastdfs_client.use_connection_pool = false
-fastdfs_client.connection_pool_max_idle_time = 3600
diff --git a/ftp/php71-fastdfs/Makefile b/ftp/php71-fastdfs/Makefile
index feee1ee711a2..fd0b7708f285 100644
--- a/ftp/php71-fastdfs/Makefile
+++ b/ftp/php71-fastdfs/Makefile
@@ -1,29 +1,12 @@
# $FreeBSD$
-PORTNAME= fastdfs
-PORTVERSION= 5.0.11
-CATEGORIES= ftp
+MASTERDIR= ${.CURDIR}/../php56-fastdfs
+
PKGNAMEPREFIX= php71-
-MAINTAINER= daniel@blodan.se
COMMENT= PHP 7.1 module for accessing a FastDFS cluster
-LICENSE= GPLv3+
-
-LIB_DEPENDS= libfastcommon.so:devel/libfastcommon \
- libfdfsclient.so:ftp/fastdfs
-
-USE_GITHUB= yes
-GH_ACCOUNT= happyfish100
-GH_PROJECT= fastdfs
-GH_TAGNAME= 1e50b4f
-
-USES= php:ext
+IGNORE_WITH_PHP= 56 70 72
PHP_VER= 71
-WRKSRC_SUBDIR= php_client
-CONFIGURE_ENV= ROOT=${LOCALBASE}
-
-PHP_MODNAME= fastdfs_client
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/ftp/php71-fastdfs/distinfo b/ftp/php71-fastdfs/distinfo
deleted file mode 100644
index a238a2ad4cb4..000000000000
--- a/ftp/php71-fastdfs/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1502819531
-SHA256 (happyfish100-fastdfs-5.0.11-1e50b4f_GH0.tar.gz) = 42ef67951c55fb416282cd20389dde5709016913debbb87465b9b744fa3dacf9
-SIZE (happyfish100-fastdfs-5.0.11-1e50b4f_GH0.tar.gz) = 336996
diff --git a/ftp/php71-fastdfs/pkg-descr b/ftp/php71-fastdfs/pkg-descr
deleted file mode 100644
index d90caa5fc86a..000000000000
--- a/ftp/php71-fastdfs/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-PHP module for accessing a FastDFS cluster
-
-WWW: https://github.com/happyfish100/fastdfs
diff --git a/ftp/php71-fastdfs/pkg-message b/ftp/php71-fastdfs/pkg-message
deleted file mode 100644
index 993d158f9115..000000000000
--- a/ftp/php71-fastdfs/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
-Before you can start using this module;
-- Make sure you have configured client.conf to point to your FastDFS cluster
- and that you see the cluster with fdfs_monitor
-- Add this to your php.ini file
-==================================================================
-fastdfs_client.base_path = /var/tmp
-fastdfs_client.connect_timeout = 2
-fastdfs_client.network_timeout = 60
-fastdfs_client.log_level = info
-fastdfs_client.log_filename =
-fastdfs_client.http.anti_steal_secret_key =
-fastdfs_client.tracker_group_count = 1
-fastdfs_client.tracker_group0 = /usr/local/etc/fdfs/client.conf
-fastdfs_client.use_connection_pool = false
-fastdfs_client.connection_pool_max_idle_time = 3600