aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-07 04:12:24 +0800
committermiwi <miwi@FreeBSD.org>2007-03-07 04:12:24 +0800
commitd52adaf3bc03ae27314b012f8c70e2ca208702b3 (patch)
treea393ed9cd3a99d207075062f2e9bcbccada6727c /ftp
parent919a2a6dd659b1d7f03cfe8072ccf557dba53a59 (diff)
downloadfreebsd-ports-gnome-d52adaf3bc03ae27314b012f8c70e2ca208702b3.tar.gz
freebsd-ports-gnome-d52adaf3bc03ae27314b012f8c70e2ca208702b3.tar.zst
freebsd-ports-gnome-d52adaf3bc03ae27314b012f8c70e2ca208702b3.zip
Python FTP server library provides an high-level portable interface to easily
write asynchronous FTP servers with Python. Based on asyncore / asynchat frameworks pyftpdlib is actually the most complete RFC959 FTP server implementation available for Python language. WWW: http://billiejoex.altervista.org/pyftpdlib.html PR: ports/109934 Submitted by: Li-Wen Hsu <lwhsu at lwhsu.org>
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/py-pyftpdlib/Makefile34
-rw-r--r--ftp/py-pyftpdlib/distinfo3
-rw-r--r--ftp/py-pyftpdlib/pkg-descr6
-rw-r--r--ftp/py-pyftpdlib/pkg-plist15
5 files changed, 59 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index d92e8c405a6d..82a1fe069c14 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -90,6 +90,7 @@
SUBDIR += pureadmin
SUBDIR += py-curl
SUBDIR += py-ftputil
+ SUBDIR += py-pyftpdlib
SUBDIR += quftp
SUBDIR += rexx-curl
SUBDIR += smbftpd
diff --git a/ftp/py-pyftpdlib/Makefile b/ftp/py-pyftpdlib/Makefile
new file mode 100644
index 000000000000..53fd0cf63a19
--- /dev/null
+++ b/ftp/py-pyftpdlib/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-pyftpdlib
+# Date created: Mar. 06, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyftpdlib
+PORTVERSION= 0.1
+CATEGORIES= ftp python
+MASTER_SITES= http://pyftpdlib.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Python FTP server library
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${TARGETDIR}/share/doc/py-${PORTNAME}
+.endif
+EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/demo/ ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/ftp/py-pyftpdlib/distinfo b/ftp/py-pyftpdlib/distinfo
new file mode 100644
index 000000000000..d5713e56e8b7
--- /dev/null
+++ b/ftp/py-pyftpdlib/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyftpdlib_0.1.tar.gz) = 32c17f1e142c6e235256706e2905aa5c
+SHA256 (pyftpdlib_0.1.tar.gz) = e8137eb65f03bd0e1c7a1b8f91d7960f5f9825b4aeb224035368ae99e750a6e0
+SIZE (pyftpdlib_0.1.tar.gz) = 47884
diff --git a/ftp/py-pyftpdlib/pkg-descr b/ftp/py-pyftpdlib/pkg-descr
new file mode 100644
index 000000000000..202d422a8783
--- /dev/null
+++ b/ftp/py-pyftpdlib/pkg-descr
@@ -0,0 +1,6 @@
+Python FTP server library provides an high-level portable interface to easily
+write asynchronous FTP servers with Python. Based on asyncore / asynchat
+frameworks pyftpdlib is actually the most complete RFC959 FTP server
+implementation available for Python language.
+
+WWW: http://billiejoex.altervista.org/pyftpdlib.html
diff --git a/ftp/py-pyftpdlib/pkg-plist b/ftp/py-pyftpdlib/pkg-plist
new file mode 100644
index 000000000000..bf7a0b48052b
--- /dev/null
+++ b/ftp/py-pyftpdlib/pkg-plist
@@ -0,0 +1,15 @@
+%%PYTHON_SITELIBDIR%%/pyftpdlib/FTPServer.py
+%%PYTHON_SITELIBDIR%%/pyftpdlib/FTPServer.pyc
+%%PYTHON_SITELIBDIR%%/pyftpdlib/FTPServer.pyo
+%%PYTHON_SITELIBDIR%%/pyftpdlib/__init__.py
+%%PYTHON_SITELIBDIR%%/pyftpdlib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pyftpdlib/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/pyftpdlib
+%%EXAMPLESDIR%%/unix_ftpd.py
+%%EXAMPLESDIR%%/md5_ftpd.py
+%%EXAMPLESDIR%%/basic_ftpd.py
+%%EXAMPLESDIR%%/winNT_ftpd.py
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/pyftpdlib.css
+%%PORTDOCS%%%%DOCSDIR%%/pyftpdlib.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%