aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-03-30 00:34:34 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-03-30 00:34:34 +0800
commite038d12ad5efa7435b1cdb54d1c403ba99eb13cd (patch)
treef39d42e54e0d1af1d59f1fe3a2e26d0a6db2e599 /ftp
parente4b4077ed1cc008f34174e2cc063449334a03a26 (diff)
downloadfreebsd-ports-gnome-e038d12ad5efa7435b1cdb54d1c403ba99eb13cd.tar.gz
freebsd-ports-gnome-e038d12ad5efa7435b1cdb54d1c403ba99eb13cd.tar.zst
freebsd-ports-gnome-e038d12ad5efa7435b1cdb54d1c403ba99eb13cd.zip
Do not install curl.fish to avoid conflicts with shells/fish
- Bump PORTREVISION for package change PR: 236878 Reported by: Laszlo Karolyi <laszlo@karolyi.hu>
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile1
-rw-r--r--ftp/curl/files/patch-scripts-Makefile.in21
-rw-r--r--ftp/curl/pkg-plist1
3 files changed, 22 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 1f90dd9c440e..cf69ede606af 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.64.1
+PORTREVISION= 1
CATEGORIES= ftp net www
MASTER_SITES= https://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/curl/files/patch-scripts-Makefile.in b/ftp/curl/files/patch-scripts-Makefile.in
new file mode 100644
index 000000000000..0ced59737639
--- /dev/null
+++ b/ftp/curl/files/patch-scripts-Makefile.in
@@ -0,0 +1,21 @@
+--- scripts/Makefile.in.orig 2019-03-25 21:03:52 UTC
++++ scripts/Makefile.in
+@@ -558,7 +558,7 @@ uninstall-am:
+ .PRECIOUS: Makefile
+
+
+-all-local: $(ZSH_COMPLETION_FUNCTION_FILENAME) $(FISH_COMPLETION_FUNCTION_FILENAME)
++all-local: $(ZSH_COMPLETION_FUNCTION_FILENAME)
+
+ $(ZSH_COMPLETION_FUNCTION_FILENAME): completion.pl
+ @CROSSCOMPILING_TRUE@ @echo "NOTICE: we can't generate zsh completion when cross-compiling!"
+@@ -573,9 +573,7 @@ $(FISH_COMPLETION_FUNCTION_FILENAME): co
+ install-data-local:
+ @CROSSCOMPILING_TRUE@ @echo "NOTICE: we can't install zsh completion when cross-compiling!"
+ @CROSSCOMPILING_FALSE@ $(MKDIR_P) $(DESTDIR)$(ZSH_FUNCTIONS_DIR)
+-@CROSSCOMPILING_FALSE@ $(MKDIR_P) $(DESTDIR)$(FISH_FUNCTIONS_DIR)
+ @CROSSCOMPILING_FALSE@ $(INSTALL_DATA) $(ZSH_COMPLETION_FUNCTION_FILENAME) $(DESTDIR)$(ZSH_FUNCTIONS_DIR)/$(ZSH_COMPLETION_FUNCTION_FILENAME)
+-@CROSSCOMPILING_FALSE@ $(INSTALL_DATA) $(FISH_COMPLETION_FUNCTION_FILENAME) $(DESTDIR)$(FISH_FUNCTIONS_DIR)/$(FISH_COMPLETION_FUNCTION_FILENAME)
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 37d797ece962..ebe131fd352c 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -443,5 +443,4 @@ man/man3/libcurl-tutorial.3.gz
man/man3/libcurl-url.3.gz
man/man3/libcurl.3.gz
share/aclocal/libcurl.m4
-share/fish/completions/curl.fish
share/zsh/site-functions/_curl