aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-24 16:57:38 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-24 16:57:38 +0800
commitfc0f70a87d23ce3610d371eb36a00081a80c8557 (patch)
tree9949a4c8c2f583e0d78be4f5349a986db3678287 /ftp
parent256850454288e7b5dac7b88e2cf7772db2c5ae54 (diff)
downloadfreebsd-ports-gnome-fc0f70a87d23ce3610d371eb36a00081a80c8557.tar.gz
freebsd-ports-gnome-fc0f70a87d23ce3610d371eb36a00081a80c8557.tar.zst
freebsd-ports-gnome-fc0f70a87d23ce3610d371eb36a00081a80c8557.zip
- Add SMB option
PR: 210472 Submitted by: Marcin Gryszkalis <mg@fork.pl>
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 73f287b0b55f..92bac0b3f28b 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -14,7 +14,7 @@ COMMENT?= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES HTTP2 IDN IPV6 LDAP LDAPS LIBSSH2 METALINK PROXY PSL RTMP TLS_SRP
+OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES HTTP2 IDN IPV6 LDAP LDAPS LIBSSH2 METALINK PROXY PSL RTMP SMB TLS_SRP
OPTIONS_RADIO= RESOLV SSL
OPTIONS_SINGLE= GSSAPI
OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER
@@ -29,6 +29,7 @@ LDAPS_IMPLIES= LDAP
LIBSSH2_DESC= SCP/SFTP support via libssh2
LIBSSH2_IMPLIES= OPENSSL
RESOLV_DESC= DNS resolving options
+SMB_DESC= SMB/CIFS support
THREADED_RESOLVER_DESC= Threaded DNS resolver
TLS_SRP_DESC= TLS-SRP (Secure Remote Password) support
@@ -133,6 +134,7 @@ PSL_LIB_DEPENDS= libpsl.so:dns/libpsl
RTMP_CONFIGURE_WITH= librtmp
RTMP_LIB_DEPENDS= librtmp.so:multimedia/librtmp
RTMP_USES= pkgconfig
+SMB_CONFIGURE_ENABLE= smb
THREADED_RESOLVER_CONFIGURE_ENABLE= threaded-resolver
TLS_SRP_CONFIGURE_ENABLE= tls-srp
WOLFSSL_CONFIGURE_WITH= cyassl