aboutsummaryrefslogtreecommitdiffstats
path: root/games/0ad/Makefile
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-09-15 02:34:21 +0800
committermadpilot <madpilot@FreeBSD.org>2012-09-15 02:34:21 +0800
commitb40c1ad7a5e967337a50d601a5f5a618a466bd0c (patch)
tree35976349e0053041b39ba874753c38e004a78ece /games/0ad/Makefile
parent02bf1df23df58fee8b7c62900c3c6771befb0093 (diff)
downloadfreebsd-ports-gnome-b40c1ad7a5e967337a50d601a5f5a618a466bd0c.tar.gz
freebsd-ports-gnome-b40c1ad7a5e967337a50d601a5f5a618a466bd0c.tar.zst
freebsd-ports-gnome-b40c1ad7a5e967337a50d601a5f5a618a466bd0c.zip
- Update to version 0.0.11 (alpha 11)
- Trim Makefile header Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'games/0ad/Makefile')
-rw-r--r--games/0ad/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 5faaa68e51aa..9f831e9efb20 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -1,17 +1,11 @@
-# New ports collection makefile for: 0ad
-# Date created: 13 Jan 2012
-# Whom: Guido Falsi <mad@madpilot.net>
-#
# $FreeBSD$
-#
PORTNAME= 0ad
-DISTVERSION= alpha.10
-PORTREVISION= 2
+PORTVERSION= 0.0.11
CATEGORIES= games
MASTER_SITES= SF/zero-ad/releases
-DISTFILES= ${PORTNAME}-${SVNREV}-alpha-unix-build.tar.xz \
- ${PORTNAME}-${SVNREV}-alpha-unix-data.tar.xz
+DISTFILES= ${PORTNAME}-${PORTVERSION}-alpha-unix-build.tar.xz \
+ ${PORTNAME}-${PORTVERSION}-alpha-unix-data.tar.xz
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Real-time strategy (RTS) game of ancient warfare
@@ -27,7 +21,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
curl:${PORTSDIR}/ftp/curl \
gamin-1:${PORTSDIR}/devel/gamin
-WRKSRC= ${WRKDIR}/${PORTNAME}-${SVNREV}-alpha
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-alpha
BUILD_WRKSRC= ${WRKSRC}/build/workspaces/gcc
MAKE_ARGS= config=release
USE_GMAKE= yes
@@ -37,7 +31,7 @@ USE_GNOME= libxml2 gtk20
USE_GL= gl
USE_OPENAL= al
USE_DOS2UNIX= yes
-DOS2UNIX_REGEX= .*\.[ch]p{0,2}
+DOS2UNIX_REGEX= .*\.([ch]p{0,2}|make)
MAKE_JOBS_SAFE= yes
USE_WX= 2.8
@@ -47,8 +41,6 @@ MAKE_ENV+= JOBS=${_MAKE_JOBS}
MANUAL_PACKAGE_BUILD= yes # huge
-SVNREV= r11863
-
PORTDATA= *
.include <bsd.port.pre.mk>