aboutsummaryrefslogtreecommitdiffstats
path: root/games/3dpong
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-10 10:34:46 +0800
committerswills <swills@FreeBSD.org>2012-09-10 10:34:46 +0800
commitac9985a23cb76fe93342a21b857d24f204508118 (patch)
tree0a301bebd0a845cd38f34fe9887b35383eff2799 /games/3dpong
parent7dfda538347614348d0761e04d8931a3fc6ab4fa (diff)
downloadfreebsd-ports-gnome-ac9985a23cb76fe93342a21b857d24f204508118.tar.gz
freebsd-ports-gnome-ac9985a23cb76fe93342a21b857d24f204508118.tar.zst
freebsd-ports-gnome-ac9985a23cb76fe93342a21b857d24f204508118.zip
- Add second MASTER_SITES entry
- Convert to OptionsNG - Use PLIST_FILES instead of pkg-plist - Give maintainership to submitter PR: ports/171261 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'games/3dpong')
-rw-r--r--games/3dpong/Makefile55
-rw-r--r--games/3dpong/distinfo2
-rw-r--r--games/3dpong/pkg-plist11
3 files changed, 44 insertions, 24 deletions
diff --git a/games/3dpong/Makefile b/games/3dpong/Makefile
index 6114e160aaa9..039693b98b44 100644
--- a/games/3dpong/Makefile
+++ b/games/3dpong/Makefile
@@ -7,12 +7,17 @@
PORTNAME= 3dpong
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ftp://ftp.billsgames.com/unix/x/3dpong/src/
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/3dpong/src/ \
+ ftp://ftp.billsgames.com/unix/x/3dpong/src/ \
+ http://www.newbreedsoftware.com/images/prodicons/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.gif:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= X Window 3D Pong game for 1 or 2 players with a ball and paddles
+MAINTAINER= nemysis@gmx.ch
+COMMENT= X Window 3D Pong game for 1 or 2 players
LICENSE= GPLv2
@@ -21,19 +26,43 @@ USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
XLIB="-L${LOCALBASE}/lib -lX11"
+MAN6= ${PORTNAME}.6
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.gif \
+ share/examples/${PORTNAME}/${PORTNAME}-handball.sh \
+ share/examples/${PORTNAME}/${PORTNAME}-vs-computer.sh
+PLIST_DIRS= share/examples/${PORTNAME}
+
+PORTDATA= *
+PORTDOCS= AUTHORS.txt CHANGES.txt README.txt TODO.txt
+
+.include <bsd.port.options.mk>
+
post-patch:
- @${REINPLACE_CMD} -e \
- 's|cat sounds/|cat ${DATADIR}/|g' ${WRKSRC}/src/3dpong.c
+ @${REINPLACE_CMD} -e 's|cat sounds/|cat ${DATADIR}/|g' ${WRKSRC}/src/3dpong.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/3dpong ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Data
+ ${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/sounds/*.au ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in AUTHORS.txt CHANGES.txt INSTALL.txt README.txt TODO.txt
- ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_MAN} ${WRKSRC}/src/${MAN6} ${MAN1PREFIX}/man/man6
+
+# Pixmaps
+ ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.gif ${PREFIX}/share/pixmaps/
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+. endfor
.endif
+# Examples
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+
.include <bsd.port.mk>
diff --git a/games/3dpong/distinfo b/games/3dpong/distinfo
index 0c5bf212a8f7..e566a43d0aad 100644
--- a/games/3dpong/distinfo
+++ b/games/3dpong/distinfo
@@ -1,2 +1,4 @@
SHA256 (3dpong-0.5.tar.gz) = b1557818319f482c1e0795192f013ecf998c9f1013033b542676d1bf743a6bc5
SIZE (3dpong-0.5.tar.gz) = 37004
+SHA256 (3dpong.gif) = 52524304fd79bb31740ac59a6ce249cc8461112adca0e4f3ab57ff4ab5623a1f
+SIZE (3dpong.gif) = 321
diff --git a/games/3dpong/pkg-plist b/games/3dpong/pkg-plist
deleted file mode 100644
index 3bfce1e13f7c..000000000000
--- a/games/3dpong/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/3dpong
-%%DATADIR%%/hit.au
-%%DATADIR%%/score.au
-%%DATADIR%%/wall.au
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%