aboutsummaryrefslogtreecommitdiffstats
path: root/games/alephone
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-08-22 06:30:18 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-08-22 06:30:18 +0800
commit6ba125b2fad407fb763e057fff537d7e7dc7e94d (patch)
treee0bb1c758727ab59ef6f521c3b249d6afa86676a /games/alephone
parent76b91999aeda8070d0251b737c73d1195dbc4fd4 (diff)
downloadfreebsd-ports-gnome-6ba125b2fad407fb763e057fff537d7e7dc7e94d.tar.gz
freebsd-ports-gnome-6ba125b2fad407fb763e057fff537d7e7dc7e94d.tar.zst
freebsd-ports-gnome-6ba125b2fad407fb763e057fff537d7e7dc7e94d.zip
- Update to 20080721
- Unbreak build - Take maintainership
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile22
-rw-r--r--games/alephone/distinfo6
-rw-r--r--games/alephone/files/patch-Source_Files-Misc-preferences.cpp13
-rw-r--r--games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp63
-rw-r--r--games/alephone/pkg-plist15
5 files changed, 38 insertions, 81 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 149845f9ae33..c8d9f21f7727 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,32 +6,34 @@
#
PORTNAME= alephone
-PORTVERSION= 20070525
-PORTREVISION= 2
+PORTVERSION= 20080721
CATEGORIES= games
MASTER_SITES= SF/marathon
DISTNAME= AlephOne-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= The open source version of Bungie's Marathon game
BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
-BROKEN= does not build with speex-1.2rc1
-
USE_BZIP2= yes
USE_GL= yes
USE_GNOME= gnometarget
-USE_LUA= 5.0
+USE_LUA= 5.1
USE_SDL= image net sdl sound
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CPPFLAGS= -I${LOCALBASE}/include -I${LUA_INCDIR}
-LDFLAGS= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LUA_INCDIR}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}"
DATADIR= ${PREFIX}/share/AlephOne
+MAN6= alephone.6
+
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -41,4 +43,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/alephone/distinfo b/games/alephone/distinfo
index 99c5a8c9a87e..a8626180cc92 100644
--- a/games/alephone/distinfo
+++ b/games/alephone/distinfo
@@ -1,3 +1,3 @@
-MD5 (AlephOne-20070525.tar.bz2) = 2e37050e62418e433dfc8f66010289e3
-SHA256 (AlephOne-20070525.tar.bz2) = 98f12f5c66b68d7af87db6c7f088ff3386abb9855dc46841f20f6871e80feca3
-SIZE (AlephOne-20070525.tar.bz2) = 6657074
+MD5 (AlephOne-20080721.tar.bz2) = f2ccc889e6b56cf32c603b9df0a3fa87
+SHA256 (AlephOne-20080721.tar.bz2) = 8a03b72c947e00606318b0c52d117f87352915b5f6feb926ba046a276b87b6eb
+SIZE (AlephOne-20080721.tar.bz2) = 3025203
diff --git a/games/alephone/files/patch-Source_Files-Misc-preferences.cpp b/games/alephone/files/patch-Source_Files-Misc-preferences.cpp
new file mode 100644
index 000000000000..22d0eb9d8325
--- /dev/null
+++ b/games/alephone/files/patch-Source_Files-Misc-preferences.cpp
@@ -0,0 +1,13 @@
+--- Source_Files/Misc/preferences.cpp.orig 2008-07-22 04:06:39.000000000 +0400
++++ Source_Files/Misc/preferences.cpp 2008-08-21 23:10:31.000000000 +0400
+@@ -175,10 +175,7 @@
+ static void default_environment_preferences(environment_preferences_data *preferences);
+ static bool validate_environment_preferences(environment_preferences_data *preferences);
+
+-#if 0
+ static inline float log2(int x) { return std::log((float) x) / std::log(2.0); };
+-static inline float exp2(int x) { return std::exp((float) x + std::log(2.0)); };
+-#endif
+
+ // Prototypes
+ static void player_dialog(void *arg);
diff --git a/games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp b/games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp
deleted file mode 100644
index 03fb1194513e..000000000000
--- a/games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp
+++ /dev/null
@@ -1,63 +0,0 @@
-diff -ruN Source_Files.orig/Network/network_microphone_sdl_dummy.cpp Source_Files/Network/network_microphone_sdl_dummy.cpp
---- Source_Files.orig/Network/network_microphone_sdl_dummy.cpp Wed Dec 31 19:00:00 1969
-+++ Source_Files/Network/network_microphone_sdl_dummy.cpp Thu May 31 21:30:37 2007
-@@ -0,0 +1,59 @@
-+/*
-+ * network_microphone_sdl_dummy.cpp
-+ * created for Marathon: Aleph One <http://source.bungie.org/>
-+
-+ Copyright (C) 2002 and beyond by Woody Zenfell, III
-+ and the "Aleph One" developers.
-+
-+ This program is free software; you can redistribute it and/or modify
-+ it under the terms of the GNU General Public License as published by
-+ the Free Software Foundation; either version 2 of the License, or
-+ (at your option) any later version.
-+
-+ This program is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ GNU General Public License for more details.
-+
-+ This license is contained in the file "COPYING",
-+ which is included with this source code; it is available online at
-+ http://www.gnu.org/licenses/gpl.html
-+
-+ * The code in this file is licensed to you under the GNU GPL. As the copyright holder,
-+ * however, I reserve the right to use this code as I see fit, without being bound by the
-+ * GPL's terms. This exemption is not intended to apply to modified versions of this file -
-+ * if I were to use a modified version, I would be a licensee of whomever modified it, and
-+ * thus must observe the GPL terms.
-+ *
-+ * Dummy implementation of SDL-style network microphone.
-+ * Does nothing except satisfy the linker (and admit to anyone interested it's a poseur).
-+ *
-+ * Created by woody March 9, 2002.
-+ */
-+
-+void
-+open_network_microphone() {
-+ // Nothing
-+}
-+
-+void
-+close_network_microphone() {
-+ // Nothing
-+}
-+
-+void
-+set_network_microphone_state(bool inActive) {
-+ // Nothing
-+ (void) (inActive);
-+}
-+
-+bool
-+is_network_microphone_implemented() {
-+ // No! You'll get nothing useful from us!
-+ return false;
-+}
-+
-+void
-+network_microphone_idle_proc() {
-+ // Nothing
-+}
diff --git a/games/alephone/pkg-plist b/games/alephone/pkg-plist
index 4fd54c2ff898..4babe801fd8e 100644
--- a/games/alephone/pkg-plist
+++ b/games/alephone/pkg-plist
@@ -3,9 +3,15 @@ bin/alephone
%%DATADIR%%/MML/Interface_Rects.mml
%%DATADIR%%/MML/Transparent_Liquids.mml
%%DATADIR%%/MML/Transparent_Sprites.mml
+%%DATADIR%%/Themes/Default/DejaVuLGCSansCondensed-Bold.ttf
+%%DATADIR%%/Themes/Default/DejaVuLGCSansCondensed-BoldOblique.ttf
+%%DATADIR%%/Themes/Default/bankgthd.ttf
%%DATADIR%%/Themes/Default/button_c.bmp
+%%DATADIR%%/Themes/Default/button_c_p.bmp
%%DATADIR%%/Themes/Default/button_l.bmp
+%%DATADIR%%/Themes/Default/button_l_p.bmp
%%DATADIR%%/Themes/Default/button_r.bmp
+%%DATADIR%%/Themes/Default/button_r_p.bmp
%%DATADIR%%/Themes/Default/frame_b.bmp
%%DATADIR%%/Themes/Default/frame_bl.bmp
%%DATADIR%%/Themes/Default/frame_br.bmp
@@ -27,16 +33,15 @@ bin/alephone
%%DATADIR%%/Themes/Default/slider_c.bmp
%%DATADIR%%/Themes/Default/slider_l.bmp
%%DATADIR%%/Themes/Default/slider_r.bmp
-%%DATADIR%%/Themes/Default/theme.mml
+%%DATADIR%%/Themes/Default/theme2.mml
%%DATADIR%%/Themes/Default/thumb_b.bmp
%%DATADIR%%/Themes/Default/thumb_bc.bmp
%%DATADIR%%/Themes/Default/thumb_c.bmp
%%DATADIR%%/Themes/Default/thumb_t.bmp
%%DATADIR%%/Themes/Default/thumb_tc.bmp
-%%PORTDOCS%%%%DOCSDIR%%/Cheat_Codes
-%%PORTDOCS%%%%DOCSDIR%%/MML.html
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%DATADIR%%/Themes/Default/tiny_button_c.bmp
+%%DATADIR%%/Themes/Default/tiny_button_l.bmp
+%%DATADIR%%/Themes/Default/tiny_button_r.bmp
@dirrm %%DATADIR%%/Themes/Default
@dirrm %%DATADIR%%/Themes
@dirrm %%DATADIR%%/MML