aboutsummaryrefslogtreecommitdiffstats
path: root/games/alienarena
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /games/alienarena
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'games/alienarena')
-rw-r--r--games/alienarena/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 30da704ebbad..c2cace7e6a29 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -28,7 +28,7 @@ CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
CONFIGURE_ARGS+=--with-xf86vm \
--with-xf86dga
-EXTRACT_AFTER_ARGS= | ${TAR} --exclude "data1" -xf -
+EXTRACT_AFTER_ARGS= --exclude "data1"
MAKE_ENV= WITH_DATADIR=yes WITH_LIBDIR=yes \
DATADIR="${DATADIR}" LIBDIR="${LIBDIR}"