aboutsummaryrefslogtreecommitdiffstats
path: root/games/allacrost
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-05 03:04:26 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-05 03:04:26 +0800
commit840797bd84eda45dd69170b2d2e5d44609cd6745 (patch)
tree161a0be7c2057f6e7f3a2329babb75ed6d7a8107 /games/allacrost
parent2503099879e9c134ae6605555fb03c7ae8008a0c (diff)
downloadfreebsd-ports-gnome-840797bd84eda45dd69170b2d2e5d44609cd6745.tar.gz
freebsd-ports-gnome-840797bd84eda45dd69170b2d2e5d44609cd6745.tar.zst
freebsd-ports-gnome-840797bd84eda45dd69170b2d2e5d44609cd6745.zip
Hero of Allacrost is a game inspired by the likes of SNES-era RPGs
such as Chrono Trigger and the Final Fantasy series. In Allacrost, the player explores rich environments, undertakes various quests and missions, solves dungeon puzzles, and fights strategic battles in an active time-based system. WWW: http://www.allacrost.org PR: ports/103962 Submitted by: Dmitry Marakasov <amdmi3 at mail.ru>
Diffstat (limited to 'games/allacrost')
-rw-r--r--games/allacrost/Makefile49
-rw-r--r--games/allacrost/distinfo3
-rw-r--r--games/allacrost/files/patch-src-engine-video-video.cpp29
-rw-r--r--games/allacrost/files/patch-src-main.cpp10
-rw-r--r--games/allacrost/pkg-descr7
-rw-r--r--games/allacrost/pkg-message16
-rw-r--r--games/allacrost/pkg-plist340
7 files changed, 454 insertions, 0 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
new file mode 100644
index 000000000000..f47f90bb4bee
--- /dev/null
+++ b/games/allacrost/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: allacrost
+# Date created: 03 Oct 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= allacrost
+PORTVERSION= 0.1.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= allacrost_demo_source_${PORTVERSION}
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A single player 2D role-playing game
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LUA= 5.0
+USE_SDL= sdl ttf mixer
+USE_GL= yes
+USE_GCC= 3.4+
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --datadir=${DATADIR}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -L${LUA_LIBDIR}" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${LUA_INCDIR}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|exit -1|exit 1|; /CXXFLAGS=/ d; \
+ s|-lSDL |`${SDL_CONFIG} --libs` |' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|DATADIR|"${DATADIR}"|' ${WRKSRC}/src/main.cpp
+
+post-install:
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/games/allacrost/distinfo b/games/allacrost/distinfo
new file mode 100644
index 000000000000..78f854082509
--- /dev/null
+++ b/games/allacrost/distinfo
@@ -0,0 +1,3 @@
+MD5 (allacrost_demo_source_0.1.0.tar.gz) = 1896eb2a6b369fc370b2043e49e9f7a7
+SHA256 (allacrost_demo_source_0.1.0.tar.gz) = 6528b7097db5ab254ad97b614fd73f479a43088877c845f9fa3054786515dc97
+SIZE (allacrost_demo_source_0.1.0.tar.gz) = 17367178
diff --git a/games/allacrost/files/patch-src-engine-video-video.cpp b/games/allacrost/files/patch-src-engine-video-video.cpp
new file mode 100644
index 000000000000..e3e05aec96ad
--- /dev/null
+++ b/games/allacrost/files/patch-src-engine-video-video.cpp
@@ -0,0 +1,29 @@
+--- src/engine/video/video.cpp.orig Wed Oct 4 02:42:52 2006
++++ src/engine/video/video.cpp Wed Oct 4 03:19:03 2006
+@@ -247,8 +247,6 @@
+
+ // make a temp directory and make sure it doesn't contain any files
+ // (in case the game crashed during a previous run, leaving stuff behind)
+- MakeDirectory("temp");
+- CleanDirectory("temp");
+
+ // enable text shadows
+ EnableTextShadow(true);
+@@ -438,8 +436,6 @@
+ delete iImage->second;
+ ++iImage;
+ }
+-
+- RemoveDirectory("temp");
+ }
+
+
+@@ -1393,7 +1389,7 @@
+ string GameVideo::_CreateTempFilename(const string &extension)
+ {
+ // figure out the temp filename to return
+- string filename = "temp/TEMP_";
++ string filename = "/tmp/allacrost_TEMP_";
+ filename += _nextTempFile;
+ filename += extension;
+
diff --git a/games/allacrost/files/patch-src-main.cpp b/games/allacrost/files/patch-src-main.cpp
new file mode 100644
index 000000000000..9b8704a1a47b
--- /dev/null
+++ b/games/allacrost/files/patch-src-main.cpp
@@ -0,0 +1,10 @@
+--- src/main.cpp.orig Mon Sep 11 00:31:22 2006
++++ src/main.cpp Wed Oct 4 03:11:59 2006
+@@ -84,6 +84,7 @@
+
+ // Every great game begins with a single function :)
+ int32 main(int32 argc, char *argv[]) {
++ chdir(DATADIR);
+ // When the program exits, first the QuitAllacrost() function, followed by SDL_Quit()
+ atexit(SDL_Quit);
+ atexit(QuitAllacrost);
diff --git a/games/allacrost/pkg-descr b/games/allacrost/pkg-descr
new file mode 100644
index 000000000000..f599da2c9ba1
--- /dev/null
+++ b/games/allacrost/pkg-descr
@@ -0,0 +1,7 @@
+Hero of Allacrost is a game inspired by the likes of SNES-era RPGs
+such as Chrono Trigger and the Final Fantasy series. In Allacrost,
+the player explores rich environments, undertakes various quests
+and missions, solves dungeon puzzles, and fights strategic battles
+in an active time-based system.
+
+WWW: http://www.allacrost.org
diff --git a/games/allacrost/pkg-message b/games/allacrost/pkg-message
new file mode 100644
index 000000000000..fc6445c906ee
--- /dev/null
+++ b/games/allacrost/pkg-message
@@ -0,0 +1,16 @@
+ATTENTION!
+
+This is a first demo release of Hero of Allacrost, so don't expect
+it to be much playable.
+
+From the website:
+"One thing we wish to mention right off the bat is: don't expect too
+much from this first release. This release demonstrates the basic
+components of map exploration, dialogue, battles, and character
+management, but not much more. We are still missing a lot of artwork
+and some important sections from the code that would have made this
+release much more interactive and fun to play. What you will
+experience is nothing but the foundation to which we will continue
+to build the game off of, so don't be mistaken into thinking to
+yourself "What, that's it?" when you play the demo for the first
+time."
diff --git a/games/allacrost/pkg-plist b/games/allacrost/pkg-plist
new file mode 100644
index 000000000000..6d54fa565bba
--- /dev/null
+++ b/games/allacrost/pkg-plist
@@ -0,0 +1,340 @@
+bin/allacrost
+%%DATADIR%%/dat/config/boot.lua
+%%DATADIR%%/dat/config/settings.lua
+%%DATADIR%%/dat/enemies/skeleton.lua
+%%DATADIR%%/dat/enemies/slime.lua
+%%DATADIR%%/dat/enemies/snake.lua
+%%DATADIR%%/dat/enemies/spider.lua
+%%DATADIR%%/dat/maps/desert_cave.lua
+%%DATADIR%%/dat/skills/sword_swipe.lua
+%%DATADIR%%/dat/tilesets/tiles_database.lua
+%%DATADIR%%/img/backdrops/battle/desert_cave.png
+%%DATADIR%%/img/backdrops/boot_screen00.jpg
+%%DATADIR%%/img/fonts/COPYING
+%%DATADIR%%/img/fonts/tarnhalo.ttf
+%%DATADIR%%/img/fonts/vtc_switchblade_romance.ttf
+%%DATADIR%%/img/icons/armor/karlate_breastplate.png
+%%DATADIR%%/img/icons/armor/karlate_greaves.png
+%%DATADIR%%/img/icons/armor/karlate_helmet.png
+%%DATADIR%%/img/icons/armor/karlate_shield.png
+%%DATADIR%%/img/icons/battle/ap_indicator_fr0.png
+%%DATADIR%%/img/icons/battle/ap_indicator_fr1.png
+%%DATADIR%%/img/icons/battle/ap_indicator_fr2.png
+%%DATADIR%%/img/icons/battle/ap_indicator_fr3.png
+%%DATADIR%%/img/icons/battle/attack.png
+%%DATADIR%%/img/icons/battle/character_selector.png
+%%DATADIR%%/img/icons/battle/defend.png
+%%DATADIR%%/img/icons/battle/item.png
+%%DATADIR%%/img/icons/battle/support.png
+%%DATADIR%%/img/icons/battle/swap_card.png
+%%DATADIR%%/img/icons/battle/swap_icon.png
+%%DATADIR%%/img/icons/items/health_potion.png
+%%DATADIR%%/img/icons/items/health_potion_large.png
+%%DATADIR%%/img/icons/weapons/karlate_sword.png
+%%DATADIR%%/img/logos/main_logo_background.png
+%%DATADIR%%/img/logos/main_logo_sword.png
+%%DATADIR%%/img/logos/main_logo_text.png
+%%DATADIR%%/img/logos/program_icon.bmp
+%%DATADIR%%/img/logos/program_icon.ico
+%%DATADIR%%/img/menus/battle_bottom_menu.png
+%%DATADIR%%/img/menus/black_sleet_b.png
+%%DATADIR%%/img/menus/black_sleet_bl.png
+%%DATADIR%%/img/menus/black_sleet_br.png
+%%DATADIR%%/img/menus/black_sleet_l.png
+%%DATADIR%%/img/menus/black_sleet_parch.png
+%%DATADIR%%/img/menus/black_sleet_quad.png
+%%DATADIR%%/img/menus/black_sleet_r.png
+%%DATADIR%%/img/menus/black_sleet_t.png
+%%DATADIR%%/img/menus/black_sleet_texture.png
+%%DATADIR%%/img/menus/black_sleet_tl.png
+%%DATADIR%%/img/menus/black_sleet_tr.png
+%%DATADIR%%/img/menus/black_sleet_tri_b.png
+%%DATADIR%%/img/menus/black_sleet_tri_l.png
+%%DATADIR%%/img/menus/black_sleet_tri_r.png
+%%DATADIR%%/img/menus/black_sleet_tri_t.png
+%%DATADIR%%/img/menus/cursor.png
+%%DATADIR%%/img/menus/dialogue_box.png
+%%DATADIR%%/img/menus/dialogue_nameplate.png
+%%DATADIR%%/img/menus/locations/desert_cave.png
+%%DATADIR%%/img/misc/torch_light_mask.png
+%%DATADIR%%/img/portraits/battle/claudius.png
+%%DATADIR%%/img/portraits/battle/claudius_hp00.png
+%%DATADIR%%/img/portraits/battle/claudius_hp25.png
+%%DATADIR%%/img/portraits/battle/claudius_hp50.png
+%%DATADIR%%/img/portraits/battle/claudius_hp75.png
+%%DATADIR%%/img/portraits/map/claudius.png
+%%DATADIR%%/img/portraits/map/claudius_small.png
+%%DATADIR%%/img/portraits/map/laila.png
+%%DATADIR%%/img/portraits/map/laila_small.png
+%%DATADIR%%/img/portraits/map/marcus.png
+%%DATADIR%%/img/portraits/map/marcus_small.png
+%%DATADIR%%/img/portraits/map/vanica.png
+%%DATADIR%%/img/portraits/map/vanica_small.png
+%%DATADIR%%/img/portraits/menu/claudius.png
+%%DATADIR%%/img/portraits/menu/claudius_large.png
+%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr0.png
+%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr1.png
+%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr2.png
+%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr3.png
+%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr4.png
+%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr5.png
+%%DATADIR%%/img/sprites/battle/enemies/green_slime.png
+%%DATADIR%%/img/sprites/battle/enemies/green_slime_hp00.png
+%%DATADIR%%/img/sprites/battle/enemies/green_slime_hp33.png
+%%DATADIR%%/img/sprites/battle/enemies/green_slime_hp66.png
+%%DATADIR%%/img/sprites/battle/enemies/skeleton.png
+%%DATADIR%%/img/sprites/battle/enemies/skeleton_hp00.png
+%%DATADIR%%/img/sprites/battle/enemies/skeleton_hp33.png
+%%DATADIR%%/img/sprites/battle/enemies/skeleton_hp66.png
+%%DATADIR%%/img/sprites/battle/enemies/snake.png
+%%DATADIR%%/img/sprites/battle/enemies/snake_hp00.png
+%%DATADIR%%/img/sprites/battle/enemies/snake_hp33.png
+%%DATADIR%%/img/sprites/battle/enemies/snake_hp66.png
+%%DATADIR%%/img/sprites/battle/enemies/spider.png
+%%DATADIR%%/img/sprites/battle/enemies/spider_hp00.png
+%%DATADIR%%/img/sprites/battle/enemies/spider_hp33.png
+%%DATADIR%%/img/sprites/battle/enemies/spider_hp66.png
+%%DATADIR%%/img/sprites/map/claudius_d0.png
+%%DATADIR%%/img/sprites/map/claudius_d1.png
+%%DATADIR%%/img/sprites/map/claudius_d2.png
+%%DATADIR%%/img/sprites/map/claudius_d3.png
+%%DATADIR%%/img/sprites/map/claudius_d4.png
+%%DATADIR%%/img/sprites/map/claudius_d5.png
+%%DATADIR%%/img/sprites/map/claudius_l0.png
+%%DATADIR%%/img/sprites/map/claudius_l1.png
+%%DATADIR%%/img/sprites/map/claudius_l2.png
+%%DATADIR%%/img/sprites/map/claudius_l3.png
+%%DATADIR%%/img/sprites/map/claudius_l4.png
+%%DATADIR%%/img/sprites/map/claudius_l5.png
+%%DATADIR%%/img/sprites/map/claudius_r0.png
+%%DATADIR%%/img/sprites/map/claudius_r1.png
+%%DATADIR%%/img/sprites/map/claudius_r2.png
+%%DATADIR%%/img/sprites/map/claudius_r3.png
+%%DATADIR%%/img/sprites/map/claudius_r4.png
+%%DATADIR%%/img/sprites/map/claudius_r5.png
+%%DATADIR%%/img/sprites/map/claudius_u0.png
+%%DATADIR%%/img/sprites/map/claudius_u1.png
+%%DATADIR%%/img/sprites/map/claudius_u2.png
+%%DATADIR%%/img/sprites/map/claudius_u3.png
+%%DATADIR%%/img/sprites/map/claudius_u4.png
+%%DATADIR%%/img/sprites/map/claudius_u5.png
+%%DATADIR%%/img/sprites/map/laila_d0.png
+%%DATADIR%%/img/sprites/map/laila_d1.png
+%%DATADIR%%/img/sprites/map/laila_d2.png
+%%DATADIR%%/img/sprites/map/laila_d3.png
+%%DATADIR%%/img/sprites/map/laila_d4.png
+%%DATADIR%%/img/sprites/map/laila_d5.png
+%%DATADIR%%/img/sprites/map/laila_l0.png
+%%DATADIR%%/img/sprites/map/laila_l1.png
+%%DATADIR%%/img/sprites/map/laila_l2.png
+%%DATADIR%%/img/sprites/map/laila_l3.png
+%%DATADIR%%/img/sprites/map/laila_l4.png
+%%DATADIR%%/img/sprites/map/laila_l5.png
+%%DATADIR%%/img/sprites/map/laila_r0.png
+%%DATADIR%%/img/sprites/map/laila_r1.png
+%%DATADIR%%/img/sprites/map/laila_r2.png
+%%DATADIR%%/img/sprites/map/laila_r3.png
+%%DATADIR%%/img/sprites/map/laila_r4.png
+%%DATADIR%%/img/sprites/map/laila_r5.png
+%%DATADIR%%/img/sprites/map/laila_u0.png
+%%DATADIR%%/img/sprites/map/laila_u1.png
+%%DATADIR%%/img/sprites/map/laila_u2.png
+%%DATADIR%%/img/sprites/map/laila_u3.png
+%%DATADIR%%/img/sprites/map/laila_u4.png
+%%DATADIR%%/img/sprites/map/laila_u5.png
+%%DATADIR%%/img/sprites/map/marcus_d0.png
+%%DATADIR%%/img/sprites/map/marcus_d1.png
+%%DATADIR%%/img/sprites/map/marcus_d2.png
+%%DATADIR%%/img/sprites/map/marcus_d3.png
+%%DATADIR%%/img/sprites/map/marcus_d4.png
+%%DATADIR%%/img/sprites/map/marcus_d5.png
+%%DATADIR%%/img/sprites/map/marcus_l0.png
+%%DATADIR%%/img/sprites/map/marcus_l1.png
+%%DATADIR%%/img/sprites/map/marcus_l2.png
+%%DATADIR%%/img/sprites/map/marcus_l3.png
+%%DATADIR%%/img/sprites/map/marcus_l4.png
+%%DATADIR%%/img/sprites/map/marcus_l5.png
+%%DATADIR%%/img/sprites/map/marcus_r0.png
+%%DATADIR%%/img/sprites/map/marcus_r1.png
+%%DATADIR%%/img/sprites/map/marcus_r2.png
+%%DATADIR%%/img/sprites/map/marcus_r3.png
+%%DATADIR%%/img/sprites/map/marcus_r4.png
+%%DATADIR%%/img/sprites/map/marcus_r5.png
+%%DATADIR%%/img/sprites/map/marcus_u0.png
+%%DATADIR%%/img/sprites/map/marcus_u1.png
+%%DATADIR%%/img/sprites/map/marcus_u2.png
+%%DATADIR%%/img/sprites/map/marcus_u3.png
+%%DATADIR%%/img/sprites/map/marcus_u4.png
+%%DATADIR%%/img/sprites/map/marcus_u5.png
+%%DATADIR%%/img/sprites/map/rags_woman_d0.png
+%%DATADIR%%/img/sprites/map/rags_woman_d1.png
+%%DATADIR%%/img/sprites/map/rags_woman_d2.png
+%%DATADIR%%/img/sprites/map/rags_woman_d3.png
+%%DATADIR%%/img/sprites/map/rags_woman_d4.png
+%%DATADIR%%/img/sprites/map/rags_woman_d5.png
+%%DATADIR%%/img/sprites/map/rags_woman_l0.png
+%%DATADIR%%/img/sprites/map/rags_woman_l1.png
+%%DATADIR%%/img/sprites/map/rags_woman_l2.png
+%%DATADIR%%/img/sprites/map/rags_woman_l3.png
+%%DATADIR%%/img/sprites/map/rags_woman_l4.png
+%%DATADIR%%/img/sprites/map/rags_woman_l5.png
+%%DATADIR%%/img/sprites/map/rags_woman_r0.png
+%%DATADIR%%/img/sprites/map/rags_woman_r1.png
+%%DATADIR%%/img/sprites/map/rags_woman_r2.png
+%%DATADIR%%/img/sprites/map/rags_woman_r3.png
+%%DATADIR%%/img/sprites/map/rags_woman_r4.png
+%%DATADIR%%/img/sprites/map/rags_woman_r5.png
+%%DATADIR%%/img/sprites/map/rags_woman_u0.png
+%%DATADIR%%/img/sprites/map/rags_woman_u1.png
+%%DATADIR%%/img/sprites/map/rags_woman_u2.png
+%%DATADIR%%/img/sprites/map/rags_woman_u3.png
+%%DATADIR%%/img/sprites/map/rags_woman_u4.png
+%%DATADIR%%/img/sprites/map/rags_woman_u5.png
+%%DATADIR%%/img/sprites/map/vanica_d0.png
+%%DATADIR%%/img/sprites/map/vanica_d1.png
+%%DATADIR%%/img/sprites/map/vanica_d2.png
+%%DATADIR%%/img/sprites/map/vanica_d3.png
+%%DATADIR%%/img/sprites/map/vanica_d4.png
+%%DATADIR%%/img/sprites/map/vanica_d5.png
+%%DATADIR%%/img/sprites/map/vanica_l0.png
+%%DATADIR%%/img/sprites/map/vanica_l1.png
+%%DATADIR%%/img/sprites/map/vanica_l2.png
+%%DATADIR%%/img/sprites/map/vanica_l3.png
+%%DATADIR%%/img/sprites/map/vanica_l4.png
+%%DATADIR%%/img/sprites/map/vanica_l5.png
+%%DATADIR%%/img/sprites/map/vanica_r0.png
+%%DATADIR%%/img/sprites/map/vanica_r1.png
+%%DATADIR%%/img/sprites/map/vanica_r2.png
+%%DATADIR%%/img/sprites/map/vanica_r3.png
+%%DATADIR%%/img/sprites/map/vanica_r4.png
+%%DATADIR%%/img/sprites/map/vanica_r5.png
+%%DATADIR%%/img/sprites/map/vanica_u0.png
+%%DATADIR%%/img/sprites/map/vanica_u1.png
+%%DATADIR%%/img/sprites/map/vanica_u2.png
+%%DATADIR%%/img/sprites/map/vanica_u3.png
+%%DATADIR%%/img/sprites/map/vanica_u4.png
+%%DATADIR%%/img/sprites/map/vanica_u5.png
+%%DATADIR%%/img/tiles/ll_diagonal_wall_left_floor.png
+%%DATADIR%%/img/tiles/ll_diagonal_wall_right_floor.png
+%%DATADIR%%/img/tiles/ll_floor1.png
+%%DATADIR%%/img/tiles/ll_floor2.png
+%%DATADIR%%/img/tiles/ll_floor3.png
+%%DATADIR%%/img/tiles/ll_floor_horizontal_sand_left.png
+%%DATADIR%%/img/tiles/ll_floor_horizontal_sand_right.png
+%%DATADIR%%/img/tiles/ll_floor_shadow_full.png
+%%DATADIR%%/img/tiles/ll_floor_shadow_left.png
+%%DATADIR%%/img/tiles/ll_floor_shadow_middle.png
+%%DATADIR%%/img/tiles/ll_floor_shadow_right.png
+%%DATADIR%%/img/tiles/ll_floor_vertical_sand_bottom.png
+%%DATADIR%%/img/tiles/ll_floor_vertical_sand_top.png
+%%DATADIR%%/img/tiles/ll_wall_torch.png
+%%DATADIR%%/img/tiles/ll_water.png
+%%DATADIR%%/img/tiles/ll_water_inner_corner_left.png
+%%DATADIR%%/img/tiles/ll_water_inner_corner_right.png
+%%DATADIR%%/img/tiles/ll_water_left_edge.png
+%%DATADIR%%/img/tiles/ll_water_lower_edge.png
+%%DATADIR%%/img/tiles/ll_water_lower_left_corner.png
+%%DATADIR%%/img/tiles/ll_water_lower_right_corner.png
+%%DATADIR%%/img/tiles/ll_water_right_edge.png
+%%DATADIR%%/img/tiles/ll_water_upper_edge.png
+%%DATADIR%%/img/tiles/ll_water_upper_left_corner.png
+%%DATADIR%%/img/tiles/ll_water_upper_right_corner.png
+%%DATADIR%%/img/tiles/ol_cavewall_bottom.png
+%%DATADIR%%/img/tiles/ol_cavewall_bottom_hole1.png
+%%DATADIR%%/img/tiles/ol_cavewall_bottom_hole2.png
+%%DATADIR%%/img/tiles/ol_cavewall_bottom_hole2_eyes.png
+%%DATADIR%%/img/tiles/ol_cavewall_top.png
+%%DATADIR%%/img/tiles/ol_cavewall_top_hole1.png
+%%DATADIR%%/img/tiles/ol_cavewall_top_hole2.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_left_bottom.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_left_bottom_hole.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_left_top.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_left_top_connector.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_left_top_hole.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_right_bottom.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_right_bottom_hole.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_right_top.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_right_top_connector.png
+%%DATADIR%%/img/tiles/ol_diagonal_wall_right_top_hole.png
+%%DATADIR%%/img/tiles/ol_rock_01.png
+%%DATADIR%%/img/tiles/ol_rock_02.png
+%%DATADIR%%/img/tiles/ol_rock_03.png
+%%DATADIR%%/img/tiles/ol_rock_04.png
+%%DATADIR%%/img/tiles/ol_rock_05.png
+%%DATADIR%%/img/tiles/ol_rock_06.png
+%%DATADIR%%/img/tiles/ol_stalagmite_bottom.png
+%%DATADIR%%/img/tiles/ol_stalagmite_top.png
+%%DATADIR%%/img/tiles/ol_wallborder2_left.png
+%%DATADIR%%/img/tiles/ol_wallborder2_right.png
+%%DATADIR%%/img/tiles/ol_wallborder_down.png
+%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_lower_left.png
+%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_lower_right.png
+%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_upper_left.png
+%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_upper_right.png
+%%DATADIR%%/img/tiles/ol_wallborder_left1.png
+%%DATADIR%%/img/tiles/ol_wallborder_left2.png
+%%DATADIR%%/img/tiles/ol_wallborder_lower_left.png
+%%DATADIR%%/img/tiles/ol_wallborder_lower_left_outside_corner.png
+%%DATADIR%%/img/tiles/ol_wallborder_lower_right.png
+%%DATADIR%%/img/tiles/ol_wallborder_lower_right_outside_corner.png
+%%DATADIR%%/img/tiles/ol_wallborder_right1.png
+%%DATADIR%%/img/tiles/ol_wallborder_right2.png
+%%DATADIR%%/img/tiles/ol_wallborder_upper_left.png
+%%DATADIR%%/img/tiles/ol_wallborder_upper_right.png
+%%DATADIR%%/img/tiles/ul_bridge_bottom_left.png
+%%DATADIR%%/img/tiles/ul_bridge_bottom_middle.png
+%%DATADIR%%/img/tiles/ul_bridge_bottom_right.png
+%%DATADIR%%/img/tiles/ul_bridge_top_left.png
+%%DATADIR%%/img/tiles/ul_bridge_top_middle.png
+%%DATADIR%%/img/tiles/ul_bridge_top_right.png
+%%DATADIR%%/img/tiles/ul_roof_darkness.png
+%%DATADIR%%/mus/Allacrost_Opening_Theme.ogg
+%%DATADIR%%/mus/Confrontation.ogg
+%%DATADIR%%/mus/Opening_Effect.ogg
+%%DATADIR%%/mus/Seeking_New_Worlds.ogg
+%%DATADIR%%/snd/battle_encounter_01.ogg
+%%DATADIR%%/snd/battle_encounter_02.ogg
+%%DATADIR%%/snd/battle_encounter_03.ogg
+%%DATADIR%%/snd/bump.wav
+%%DATADIR%%/snd/cancel.wav
+%%DATADIR%%/snd/confirm.wav
+%%DATADIR%%/snd/obtain.wav
+%%DATADIR%%/snd/potion_drink.wav
+%%DATADIR%%/snd/skeleton_attack.wav
+%%DATADIR%%/snd/slime_attack.wav
+%%DATADIR%%/snd/snake_attack.wav
+%%DATADIR%%/snd/spider_attack.wav
+%%DATADIR%%/snd/sword_swipe.wav
+%%DATADIR%%/snd/volume_test.wav
+@dirrm %%DATADIR%%/snd
+@dirrm %%DATADIR%%/mus
+@dirrm %%DATADIR%%/img/tiles
+@dirrm %%DATADIR%%/img/sprites/map
+@dirrm %%DATADIR%%/img/sprites/battle/enemies
+@dirrm %%DATADIR%%/img/sprites/battle/characters
+@dirrm %%DATADIR%%/img/sprites/battle
+@dirrm %%DATADIR%%/img/sprites
+@dirrm %%DATADIR%%/img/portraits/menu
+@dirrm %%DATADIR%%/img/portraits/map
+@dirrm %%DATADIR%%/img/portraits/battle
+@dirrm %%DATADIR%%/img/portraits
+@dirrm %%DATADIR%%/img/misc
+@dirrm %%DATADIR%%/img/menus/locations
+@dirrm %%DATADIR%%/img/menus
+@dirrm %%DATADIR%%/img/logos
+@dirrm %%DATADIR%%/img/icons/weapons
+@dirrm %%DATADIR%%/img/icons/items
+@dirrm %%DATADIR%%/img/icons/battle
+@dirrm %%DATADIR%%/img/icons/armor
+@dirrm %%DATADIR%%/img/icons
+@dirrm %%DATADIR%%/img/fonts
+@dirrm %%DATADIR%%/img/backdrops/battle
+@dirrm %%DATADIR%%/img/backdrops
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/dat/tilesets
+@dirrm %%DATADIR%%/dat/skills
+@dirrm %%DATADIR%%/dat/maps
+@dirrm %%DATADIR%%/dat/enemies
+@dirrm %%DATADIR%%/dat/config
+@dirrm %%DATADIR%%/dat
+@dirrm %%DATADIR%%