aboutsummaryrefslogtreecommitdiffstats
path: root/games/anki
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-06-10 15:27:48 +0800
committerrm <rm@FreeBSD.org>2012-06-10 15:27:48 +0800
commit55a34f3abcd7145fc234cad4afb114f94eeb28ca (patch)
treeced94faf1fd64013ed3723861bd7e392bfcec847 /games/anki
parentcd3ce73ae9bb28d0909dc021c04470884f79c910 (diff)
downloadfreebsd-ports-gnome-55a34f3abcd7145fc234cad4afb114f94eeb28ca.tar.gz
freebsd-ports-gnome-55a34f3abcd7145fc234cad4afb114f94eeb28ca.tar.zst
freebsd-ports-gnome-55a34f3abcd7145fc234cad4afb114f94eeb28ca.zip
- according to [1] py-anki had switched to SQLAlchemy 0.7
since version 1.2.9, so change the dependency While I'm here: - strict python version to 2.x only - eliminate unused dependencies - use PYTHON_PKGNAMEPREFIX in _DEPENDS - add missing tabs - bump PORTREVISION because of dependencies change [1] http://ankisrs.net/changes.html PR: 168555 Submitted by: Jan Beich <jbeich at tormail dot org>
Diffstat (limited to 'games/anki')
-rw-r--r--games/anki/Makefile4
-rw-r--r--games/anki/Makefile.inc32
-rw-r--r--games/anki/pkg-descr2
3 files changed, 17 insertions, 21 deletions
diff --git a/games/anki/Makefile b/games/anki/Makefile
index b2772248004b..f0deadd273a2 100644
--- a/games/anki/Makefile
+++ b/games/anki/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: anki
-# Date created: 9 August 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+# Date created: 9 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
# $FreeBSD$
#
diff --git a/games/anki/Makefile.inc b/games/anki/Makefile.inc
index d82e5f215616..7ee618ce70ab 100644
--- a/games/anki/Makefile.inc
+++ b/games/anki/Makefile.inc
@@ -2,27 +2,23 @@
PORTNAME= anki
PORTVERSION= 1.2.11
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE \
http://ankisrs.net/download/mirror/
EXTRACT_SUFX= .tgz
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_GETTEXT= yes
USE_PYDISTUTILS= easy_install
.if !defined(PKGNAMEPREFIX)
-BUILD_DEPENDS= ${PYNUMPY} \
- py*-qt4-core>=4.4:${PORTSDIR}/devel/py-qt4-core \
- py*-sip>=4.6:${PORTSDIR}/devel/py-sip \
- py*-matplotlib>=0.90.0:${PORTSDIR}/math/py-matplotlib \
- py*-qt4-gui>=4.4:${PORTSDIR}/x11-toolkits/py-qt4-gui
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=4.4:${PORTSDIR}/devel/py-qt4-core \
+ ${PYTHON_PKGNAMEPREFIX}qt4-gui>=4.4:${PORTSDIR}/x11-toolkits/py-qt4-gui
RUN_DEPENDS:= ${BUILD_DEPENDS} \
- py*-anki>=1.2.11:${PORTSDIR}/games/py-anki \
- py*-svg>=4.4:${PORTSDIR}/graphics/py-qt4-svg \
- py*-network>=4.4:${PORTSDIR}/net/py-qt4-network \
- py*-webkit>=4.4:${PORTSDIR}/www/py-qt4-webkit
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}sip>=4.6:${PORTSDIR}/devel/py-sip \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.0:${PORTSDIR}/math/py-matplotlib \
USE_QT4= corelib gui
PYDISTUTILS_PKGNAME= ankiqt
@@ -35,13 +31,13 @@ DESKTOP_ENTRIES= "${PORTNAME}" \
"Education;Languages;Qt;" \
false
.else
-BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
- py*-sqlalchemy06>=0:${PORTSDIR}/databases/py-sqlalchemy06 \
- py*-game>=0:${PORTSDIR}/devel/py-game \
- py*-simplejson>=0:${PORTSDIR}/devel/py-simplejson \
- py*-matplotlib>=0.90.0:${PORTSDIR}/math/py-matplotlib
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>0:${PORTSDIR}/devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:${PORTSDIR}/databases/py-sqlalchemy
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}game>0:${PORTSDIR}/devel/py-game \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.0:${PORTSDIR}/math/py-matplotlib
PLIST= ${PKGDIR}/pkg-plist.py-anki
WRKSRC= ${WRKDIR}/${DISTNAME}/lib${PORTNAME}
diff --git a/games/anki/pkg-descr b/games/anki/pkg-descr
index 609719d8755f..282ac13a54e1 100644
--- a/games/anki/pkg-descr
+++ b/games/anki/pkg-descr
@@ -10,4 +10,4 @@ features designed to make studying Japanese and English easier: integrated
dictionary lookups, missing kanji reports, and more. Sample decks are also
provided for Russian.
-WWW: http://ankisrs.net/
+WWW: http://ankisrs.net/