aboutsummaryrefslogtreecommitdiffstats
path: root/games/arx-libertatis
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-10-28 10:11:42 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-10-28 10:11:42 +0800
commit2134ad863219565454e1dea04ff91039be1ff202 (patch)
tree16a3ed2e89aaf36930bc55d92e60d69f3353cc83 /games/arx-libertatis
parent7d950c1d9de3fd0b47d76561496b610bd4206674 (diff)
downloadfreebsd-ports-gnome-2134ad863219565454e1dea04ff91039be1ff202.tar.gz
freebsd-ports-gnome-2134ad863219565454e1dea04ff91039be1ff202.tar.zst
freebsd-ports-gnome-2134ad863219565454e1dea04ff91039be1ff202.zip
- Add workaround for clang bug, seems like it's unlikely to be fixed before 10.1-RELEASE
Diffstat (limited to 'games/arx-libertatis')
-rw-r--r--games/arx-libertatis/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
index 926ca86d37b2..91073e1d2c29 100644
--- a/games/arx-libertatis/Makefile
+++ b/games/arx-libertatis/Makefile
@@ -41,6 +41,13 @@ CMAKE_ARGS+= -DBUILD_CRASHREPORTER=OFF
PLIST_SUB+= CRASHREPORTER="@comment "
.endif
+.if ${OSVERSION} >= 1000705
+# Workaround for clang 3.4 bug: it crashes when debug info is enabled
+# See http://llvm.org/bugs/show_bug.cgi?id=19031, http://llvm.org/bugs/show_bug.cgi?id=20893
+post-patch:
+ @${REINPLACE_CMD} -e '/add_cxxflag.*-g2/ d' ${WRKSRC}/CMakeLists.txt
+.endif
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}