aboutsummaryrefslogtreecommitdiffstats
path: root/games/asc/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
commit6e2b9def0c49c3e565a14f5987fd3e9f46d285c6 (patch)
treec23d8d7c62c20c0978b7a404b38eb7b9d5596d0f /games/asc/Makefile
parentfaa774bb672904227e681f88c16cfceef448ef6c (diff)
downloadfreebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.gz
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.zst
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Diffstat (limited to 'games/asc/Makefile')
-rw-r--r--games/asc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/asc/Makefile b/games/asc/Makefile
index ee7cad21895d..8953ba38fd05 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -35,7 +35,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
DATAFILE= main.con
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} \( -name "*.cpp" -or -name "*.h" \) | xargs \
${PERL} -pi -e 's|malloc\.h|stdlib.h|g'