aboutsummaryrefslogtreecommitdiffstats
path: root/games/assaultcube
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-10-12 10:24:14 +0800
committerdanilo <danilo@FreeBSD.org>2013-10-12 10:24:14 +0800
commit4511f889a992ad47d17ddf3379c422cb671c17a8 (patch)
tree5d2754fbcbdb680ebf20f8fc7aa83a974f7049dc /games/assaultcube
parent96d88a326ed887ca781bd62161043fe90b2d774b (diff)
downloadfreebsd-ports-gnome-4511f889a992ad47d17ddf3379c422cb671c17a8.tar.gz
freebsd-ports-gnome-4511f889a992ad47d17ddf3379c422cb671c17a8.tar.zst
freebsd-ports-gnome-4511f889a992ad47d17ddf3379c422cb671c17a8.zip
- Update from 1.1.0.4 to 1.2.0.0 [1]
- Add stage support [1] - Convert USE_GMAKE to USES - Convert LIB_DEPENDS to new syntax PR: ports/182889 Submitted by: Sender Ghost <lightside@gmx.com> (maintainer) [1] Approved by: wg/culot (mentors, implicit)
Diffstat (limited to 'games/assaultcube')
-rw-r--r--games/assaultcube/Makefile24
-rw-r--r--games/assaultcube/distinfo6
-rw-r--r--games/assaultcube/files/assaultcube_client.in25
-rw-r--r--games/assaultcube/files/assaultcube_master.in23
-rw-r--r--games/assaultcube/files/assaultcube_server.in23
-rw-r--r--games/assaultcube/files/patch-source_src_Makefile20
6 files changed, 26 insertions, 95 deletions
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index 7be5543a940e..1c895fe8c4b5 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= assaultcube
-PORTVERSION= 1.1.0.4
-PORTREVISION= 4
+PORTVERSION= 1.2.0.0
CATEGORIES= games
MASTER_SITES= SF/actiongame/AssaultCube%20Version%20${PORTVERSION}
-DISTFILES= AssaultCube_v${PORTVERSION}_source${EXTRACT_SUFX} \
- AssaultCube_v${PORTVERSION}${EXTRACT_SUFX}
+DISTNAME= AssaultCube_v${PORTVERSION}
MAINTAINER= lightside@gmx.com
COMMENT= Total conversion of the FPS game called Cube
@@ -26,10 +24,10 @@ LICENSE_PERMS_OTHER= dist-mirror pkg-mirror auto-accept
USE_BZIP2= yes
USE_OPENAL= al
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
ALL_TARGET= libenet
-WRKSRC= ${WRKDIR}/${PORTVERSION}
+WRKSRC= ${WRKDIR}/AssaultCube_v${PORTVERSION}
CONFIGURE_ARGS= --enable-shared=no --enable-static=yes
CONFIGURE_WRKSRC= ${WRKSRC}/source/enet
BUILD_WRKSRC= ${WRKSRC}/source/src
@@ -45,10 +43,10 @@ CLIENT_DESC= Build client
DEDICATED_DESC= Build dedicated server
MASTER_DESC= Build master server
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLIENT}
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USES+= gettext
USE_GL= yes
USE_SDL= image mixer sdl
@@ -75,16 +73,16 @@ ACUBE_BIN+= master
do-install:
.for f in ${ACUBE_BIN}
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}_${f} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/ac_${f} ${PREFIX}/libexec/${PORTNAME}_${f}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}_${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/ac_${f} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}_${f}
.endfor
.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR}
.endif
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
post-install:
diff --git a/games/assaultcube/distinfo b/games/assaultcube/distinfo
index e835b951a948..0c4bd6b64589 100644
--- a/games/assaultcube/distinfo
+++ b/games/assaultcube/distinfo
@@ -1,4 +1,2 @@
-SHA256 (AssaultCube_v1.1.0.4.tar.bz2) = fea2056aa7262617b96b06ea0b85422bcec54d88cd88689c2c73ade3bd0ba029
-SIZE (AssaultCube_v1.1.0.4.tar.bz2) = 47051151
-SHA256 (AssaultCube_v1.1.0.4_source.tar.bz2) = 045925610c54b2764a79286aeb1942df2cc5ce52b710c26b447eea69fa6b1129
-SIZE (AssaultCube_v1.1.0.4_source.tar.bz2) = 2560572
+SHA256 (AssaultCube_v1.2.0.0.tar.bz2) = 90b4a7278645d3297f3031b77f9ce3d9a059c2edd6b465fe4c9b0d7514b06a61
+SIZE (AssaultCube_v1.2.0.0.tar.bz2) = 52756452
diff --git a/games/assaultcube/files/assaultcube_client.in b/games/assaultcube/files/assaultcube_client.in
index a57f79969148..78cace30dcb0 100644
--- a/games/assaultcube/files/assaultcube_client.in
+++ b/games/assaultcube/files/assaultcube_client.in
@@ -1,25 +1,4 @@
#!/bin/sh
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.XXX, and create symlinks to the data files, but the configuration files
-# are copied, and write permission for the user is added to them.
-
-APPNAME="assaultcube"
-CUBE_OPTIONS="--home=${HOME}/.${APPNAME} --init"
-
-if [ -d ~/.$APPNAME ]
-then
- echo "Using existing ~/.$APPNAME directory."
-else
- echo "Creating ~/.$APPNAME directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.$APPNAME/{} \;
- find * -type f -name "*.cfg" \
- -exec cp %%DATADIR%%/{} ~/.$APPNAME/{} \; \
- -exec chmod u+w ~/.$APPNAME/{} \; 2>/dev/null
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.$APPNAME/{} \; 2>/dev/null
-fi
-
-cd ~/.$APPNAME || exit 1
-exec %%PREFIX%%/libexec/${APPNAME}_client ${CUBE_OPTIONS} "$@"
+CUBE_OPTIONS="--home=${HOME}/.assaultcube --init"
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/assaultcube_client ${CUBE_OPTIONS} "$@"
diff --git a/games/assaultcube/files/assaultcube_master.in b/games/assaultcube/files/assaultcube_master.in
index 58f81165a3be..9ba549d02243 100644
--- a/games/assaultcube/files/assaultcube_master.in
+++ b/games/assaultcube/files/assaultcube_master.in
@@ -1,25 +1,4 @@
#!/bin/sh
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.XXX, and create symlinks to the data files, but the configuration files
-# are copied, and write permission for the user is added to them.
-
-APPNAME="assaultcube"
CUBE_OPTIONS=
-
-if [ -d ~/.$APPNAME ]
-then
- echo "Using existing ~/.$APPNAME directory."
-else
- echo "Creating ~/.$APPNAME directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.$APPNAME/{} \;
- find * -type f -name "*.cfg" \
- -exec cp %%DATADIR%%/{} ~/.$APPNAME/{} \; \
- -exec chmod u+w ~/.$APPNAME/{} \; 2>/dev/null
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.$APPNAME/{} \; 2>/dev/null
-fi
-
-cd ~/.$APPNAME || exit 1
-exec %%PREFIX%%/libexec/${APPNAME}_master ${CUBE_OPTIONS} "$@"
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/assaultcube_master ${CUBE_OPTIONS} "$@"
diff --git a/games/assaultcube/files/assaultcube_server.in b/games/assaultcube/files/assaultcube_server.in
index 6138d372698f..56e1348907da 100644
--- a/games/assaultcube/files/assaultcube_server.in
+++ b/games/assaultcube/files/assaultcube_server.in
@@ -1,25 +1,4 @@
#!/bin/sh
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.XXX, and create symlinks to the data files, but the configuration files
-# are copied, and write permission for the user is added to them.
-
-APPNAME="assaultcube"
CUBE_OPTIONS=
-
-if [ -d ~/.$APPNAME ]
-then
- echo "Using existing ~/.$APPNAME directory."
-else
- echo "Creating ~/.$APPNAME directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.$APPNAME/{} \;
- find * -type f -name "*.cfg" \
- -exec cp %%DATADIR%%/{} ~/.$APPNAME/{} \; \
- -exec chmod u+w ~/.$APPNAME/{} \; 2>/dev/null
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.$APPNAME/{} \; 2>/dev/null
-fi
-
-cd ~/.$APPNAME || exit 1
-exec %%PREFIX%%/libexec/${APPNAME}_server ${CUBE_OPTIONS} "$@"
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/assaultcube_server ${CUBE_OPTIONS} "$@"
diff --git a/games/assaultcube/files/patch-source_src_Makefile b/games/assaultcube/files/patch-source_src_Makefile
index 1261a5b05cc8..b5899ff4e382 100644
--- a/games/assaultcube/files/patch-source_src_Makefile
+++ b/games/assaultcube/files/patch-source_src_Makefile
@@ -1,29 +1,27 @@
---- source/src/Makefile.orig 2010-11-15 00:46:24.000000000 +0600
-+++ source/src/Makefile 2010-11-30 07:29:06.000000000 +0600
-@@ -1,9 +1,8 @@
- //CXX=g++-gcc-4.2.3
+--- source/src/Makefile.orig 2013-10-09 23:35:27.000000000 +0400
++++ source/src/Makefile 2013-10-11 02:18:50.000000000 +0400
+@@ -1,8 +1,7 @@
-CXXFLAGS= -O3 -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char
PLATFORM= $(shell uname -s)
-PLATFORM_PREFIX=native
-+PLATFORM_PREFIX= FreeBSD
++PLATFORM_PREFIX=FreeBSD
INCLUDES= -I. -Ibot -I../enet/include
-@@ -24,9 +23,9 @@
+@@ -21,8 +20,8 @@
else
USRLIB=$(shell if [ -e /usr/lib64 ]; then echo "/usr/lib64"; else echo "/usr/lib"; fi)
override CXXFLAGS+= -rdynamic
-CLIENT_INCLUDES= $(INCLUDES) -I/usr/include `sdl-config --cflags` -idirafter ../include
-+CLIENT_INCLUDES= $(INCLUDES) `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include -idirafter ../include
- # -lSDL_ttf
--CLIENT_LIBS= -L../enet/.libs -lenet -L$(USRLIB) `sdl-config --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile
-+CLIENT_LIBS= -L../enet/.libs -lenet `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib -lSDL_image -lz -lGL -lopenal -lvorbisfile -lintl
+-CLIENT_LIBS= -L../enet/.libs -lenet -L$(USRLIB) -lX11 `sdl-config --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile -lcurl
++CLIENT_INCLUDES= $(INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags` -idirafter ../include
++CLIENT_LIBS= -L../enet/.libs -lenet -L${LOCALBASE}/lib -lX11 `${SDL_CONFIG} --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile -lcurl -lintl
endif
CLIENT_OBJS= \
-@@ -92,8 +91,8 @@
+@@ -86,8 +85,8 @@
SERVER_INCLUDES= -DSTANDALONE $(INCLUDES) -I../include
SERVER_LIBS= -L../lib -lzdll -lenet -llibintl -lws2_32 -lwinmm
else