aboutsummaryrefslogtreecommitdiffstats
path: root/games/asteroid
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-10 15:49:40 +0800
committermiwi <miwi@FreeBSD.org>2013-02-10 15:49:40 +0800
commit143c0f9663ee1349d35808076099c63269b18f5e (patch)
treea7b65bc35a9e1d9147803a64405ec87b88cf30fd /games/asteroid
parentc22f6de08c95282b50013736bde9aa6c2e42f9c3 (diff)
downloadfreebsd-ports-gnome-143c0f9663ee1349d35808076099c63269b18f5e.tar.gz
freebsd-ports-gnome-143c0f9663ee1349d35808076099c63269b18f5e.tar.zst
freebsd-ports-gnome-143c0f9663ee1349d35808076099c63269b18f5e.zip
Asteroid (just one!) is a modern version of the arcade classic Asteroids,
using OpenGL, GLUT, and optionally GTK and SDL_mixer. It features a variety of powerups, taunting aliens, 3D textured asteroids, face-melting sound effects, and infinite playability. Controls -------- Use the left and right arrows to turn the ship, x to accelerate, and z to shoot. Pressing p will pause the game, f toggles fullscreen mode, and m mutes and unmutes the audio. There's also a right-click menu if you forget anything. Gameplay -------- I'm not going to explain how to play Asteroids. I will mention that the wireframe octahedra that sometimes drift across the screen are powerups. To collect the powerups, run over them; or you can shoot them for bonus points (if you don't want the benefit of the powerup). You'll have to play the game to figure out the different powerup types. WWW: http://chaoslizard.sourceforge.net/asteroid/ PR: ports/171431 Submitted by: nemysis@gmx.ch
Diffstat (limited to 'games/asteroid')
-rw-r--r--games/asteroid/Makefile33
-rw-r--r--games/asteroid/distinfo2
-rw-r--r--games/asteroid/pkg-descr21
-rw-r--r--games/asteroid/pkg-plist8
4 files changed, 64 insertions, 0 deletions
diff --git a/games/asteroid/Makefile b/games/asteroid/Makefile
new file mode 100644
index 000000000000..c5112b495799
--- /dev/null
+++ b/games/asteroid/Makefile
@@ -0,0 +1,33 @@
+# Created by: nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= asteroid
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= SF/chaoslizard/Asteroid/v1.2%20%282012%20Apr.%2022%29/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Modern version of the arcade classic Asteroid
+
+LICENSE= GPLv3
+
+USE_GL= glut
+USE_SDL= mixer sdl
+USE_GNOME= gtk20
+USE_XORG= xmu
+INSTALLS_ICONS= yes
+USE_CMAKE= yes
+CMAKE_VERBOSE= yes
+
+PORTDATA= *
+PORTDOCS= AUTHORS NEWS README
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/asteroid/distinfo b/games/asteroid/distinfo
new file mode 100644
index 000000000000..90b1673c8774
--- /dev/null
+++ b/games/asteroid/distinfo
@@ -0,0 +1,2 @@
+SHA256 (asteroid-1.2.tar.gz) = e268985efd23e65ad0e96d93bcc711d48f9a58da419645eb20a24a6a0ceaabe1
+SIZE (asteroid-1.2.tar.gz) = 310346
diff --git a/games/asteroid/pkg-descr b/games/asteroid/pkg-descr
new file mode 100644
index 000000000000..1e2311f6e3e9
--- /dev/null
+++ b/games/asteroid/pkg-descr
@@ -0,0 +1,21 @@
+Asteroid (just one!) is a modern version of the arcade classic Asteroids,
+using OpenGL, GLUT, and optionally GTK and SDL_mixer. It features a variety
+of powerups, taunting aliens, 3D textured asteroids, face-melting sound effects,
+and infinite playability.
+
+Controls
+--------
+Use the left and right arrows to turn the ship, x to accelerate, and z to
+shoot. Pressing p will pause the game, f toggles fullscreen mode, and m mutes
+and unmutes the audio. There's also a right-click menu if you forget anything.
+
+Gameplay
+--------
+I'm not going to explain how to play Asteroids. I will mention that the
+wireframe octahedra that sometimes drift across the screen are powerups. To
+collect the powerups, run over them; or you can shoot them for bonus points
+(if you don't want the benefit of the powerup). You'll have to play the game
+to figure out the different powerup types.
+
+
+WWW: http://chaoslizard.sourceforge.net/asteroid/
diff --git a/games/asteroid/pkg-plist b/games/asteroid/pkg-plist
new file mode 100644
index 000000000000..8ed1202e1c1a
--- /dev/null
+++ b/games/asteroid/pkg-plist
@@ -0,0 +1,8 @@
+bin/asteroid
+share/applications/asteroid.desktop
+share/icons/hicolor/scalable/apps/asteroid.svg
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications