aboutsummaryrefslogtreecommitdiffstats
path: root/games/bitefusion
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-16 17:41:07 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-16 17:41:07 +0800
commitfbac5fbcb7ed96c143281ef6a446b2ce4cb0aeb0 (patch)
treeeed8a08cca0724567b9f47f85c7e80ff5a95f8c2 /games/bitefusion
parent5ee2e942cc0f5d6e98a911e14197a84a5e1208da (diff)
downloadfreebsd-ports-gnome-fbac5fbcb7ed96c143281ef6a446b2ce4cb0aeb0.tar.gz
freebsd-ports-gnome-fbac5fbcb7ed96c143281ef6a446b2ce4cb0aeb0.tar.zst
freebsd-ports-gnome-fbac5fbcb7ed96c143281ef6a446b2ce4cb0aeb0.zip
A snake game with 8 levels. Great if you need to shut off your brain
for a few minutes and occupy your hands in the meantime. Guaranteed no adrenaline rush! WWW: http://www.junoplay.com/ PR: ports/98965 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games/bitefusion')
-rw-r--r--games/bitefusion/Makefile36
-rw-r--r--games/bitefusion/distinfo3
-rw-r--r--games/bitefusion/pkg-descr5
3 files changed, 44 insertions, 0 deletions
diff --git a/games/bitefusion/Makefile b/games/bitefusion/Makefile
new file mode 100644
index 000000000000..3f70bdf7c845
--- /dev/null
+++ b/games/bitefusion/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: bitefusion
+# Date created: 14 Jun 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bitefusion
+PORTVERSION= 1.0.0
+CATEGORIES= games
+MASTER_SITES= http://www.junoplay.com/files/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A snake game with 8 levels
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GCC= 3.4+
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
+ LDFLAGS="`${SDL_CONFIG} --libs`"
+
+PLIST_FILES= bin/bitefusion
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/*.c
+ @${REINPLACE_CMD} -e 's|-linux-gnu|-portbld-freebsd|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.in
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|stdint.h|sys/inttypes.h|' ${WRKSRC}/image.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/bitefusion/distinfo b/games/bitefusion/distinfo
new file mode 100644
index 000000000000..9159dd7e90d6
--- /dev/null
+++ b/games/bitefusion/distinfo
@@ -0,0 +1,3 @@
+MD5 (bitefusion-1.0.0.tar.gz) = ddbbab99db5b26623842a202f6a18fa0
+SHA256 (bitefusion-1.0.0.tar.gz) = 6dd60f43bf7f0ce8d47a5854dac079ff9ba1b6f763210a91fb1d0641241f8399
+SIZE (bitefusion-1.0.0.tar.gz) = 279538
diff --git a/games/bitefusion/pkg-descr b/games/bitefusion/pkg-descr
new file mode 100644
index 000000000000..45da3af5c9b1
--- /dev/null
+++ b/games/bitefusion/pkg-descr
@@ -0,0 +1,5 @@
+A snake game with 8 levels. Great if you need to shut off your brain
+for a few minutes and occupy your hands in the meantime. Guaranteed
+no adrenaline rush!
+
+WWW: http://www.junoplay.com/