aboutsummaryrefslogtreecommitdiffstats
path: root/games/bygfoot/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-07 02:47:37 +0800
committerpav <pav@FreeBSD.org>2004-07-07 02:47:37 +0800
commitf9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe (patch)
tree6b1ee2ab2d432562ebef1e8334d1fb27c61ab254 /games/bygfoot/Makefile
parent659e31d52a0a963e4ef5e5b71e1feabecdbe867b (diff)
downloadfreebsd-ports-gnome-f9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe.tar.gz
freebsd-ports-gnome-f9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe.tar.zst
freebsd-ports-gnome-f9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe.zip
Add bygfoot, a football (a.k.a. soccer) management game. Bygfoot allows you to
manage a team by training the players, buying and selling them, contracting loans, maintaining the stadium, etc.
Diffstat (limited to 'games/bygfoot/Makefile')
-rw-r--r--games/bygfoot/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
new file mode 100644
index 000000000000..39e875b7876f
--- /dev/null
+++ b/games/bygfoot/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: bygfoot
+# Date created: 6th July 2004
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bygfoot
+PORTVERSION= 1.4.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Football (soccer) management game
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gtk20 gnometarget
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|;;|;|' ${WRKSRC}/src/windows.c
+
+.include <bsd.port.mk>