aboutsummaryrefslogtreecommitdiffstats
path: root/games/chessx
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-03-30 00:16:18 +0800
committerjgh <jgh@FreeBSD.org>2013-03-30 00:16:18 +0800
commit6ae0249c387334ecbd1337098047fd4bca026400 (patch)
tree0dcb643ef07b426341d6ac9947b1992e8d37e8ef /games/chessx
parent9dafe3f62e804965f8192bb3b8b20d124da03579 (diff)
downloadfreebsd-ports-gnome-6ae0249c387334ecbd1337098047fd4bca026400.tar.gz
freebsd-ports-gnome-6ae0249c387334ecbd1337098047fd4bca026400.tar.zst
freebsd-ports-gnome-6ae0249c387334ecbd1337098047fd4bca026400.zip
add new port: games/chessx
ChessX is an open source chess database based on Qt4. With ChessX you can operate on your collection of chess games in many ways: browse, edit, add, organize, analyze, etc. Additionally ChessX can interface with chess engines via UCI and Winboard protocol. WWW: http://chessx.sourceforge.net/ PR: 177338 Submitted by: yamagi@yamagi.org
Diffstat (limited to 'games/chessx')
-rw-r--r--games/chessx/Makefile48
-rw-r--r--games/chessx/distinfo2
-rw-r--r--games/chessx/files/patch-src_database_enginelist.cpp16
-rw-r--r--games/chessx/pkg-descr6
4 files changed, 72 insertions, 0 deletions
diff --git a/games/chessx/Makefile b/games/chessx/Makefile
new file mode 100644
index 000000000000..135177152ce7
--- /dev/null
+++ b/games/chessx/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= chessx
+PORTVERSION= 0.9.6
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
+
+MAINTAINER= yamagi@yamagi.org
+COMMENT= Qt4 chess database application
+
+LICENSE= GPLv2 # (or later)
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_QT4= corelib gui svg xml network moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAVE= yes
+
+OPTIONS_DEFINE= STOCKFISH CRAFTY
+STOCKFISH_DESC= Build with Stockfish Chess Engine
+CRAFTY_DESC= Build with Crafty Chess Application
+OPTIONS_DEFAULT=STOCKFISH CRAFTY
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSTOCKFISH}
+RUN_DEPENDS+= stockfish:${PORTSDIR}/games/stockfish
+.endif
+
+.if ${PORT_OPTIONS:MCRAFTY}
+RUN_DEPENDS+= crafty:${PORTSDIR}/games/crafty
+.endif
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+DESKTOP_ENTRIES="ChessX" "" "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "Game;BoardGame;" true
+
+do-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
+
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} release/${PORTNAME} ${PREFIX}/bin)
+ (cd ${WRKSRC}/data/images && ${INSTALL_DATA} chessx.png \
+ ${PREFIX}/share/pixmaps/${PORTNAME}.png)
+
+.include <bsd.port.mk>
diff --git a/games/chessx/distinfo b/games/chessx/distinfo
new file mode 100644
index 000000000000..9b34af8cc28a
--- /dev/null
+++ b/games/chessx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (chessx-0-9-6.tar.gz) = 37ec638736b0e20fbdfb5db374bf971d76d81fe267ace3bde8b4e5c2d2e9c601
+SIZE (chessx-0-9-6.tar.gz) = 3213601
diff --git a/games/chessx/files/patch-src_database_enginelist.cpp b/games/chessx/files/patch-src_database_enginelist.cpp
new file mode 100644
index 000000000000..abf37a0ff688
--- /dev/null
+++ b/games/chessx/files/patch-src_database_enginelist.cpp
@@ -0,0 +1,16 @@
+--- src/database/enginelist.cpp_orig 2013-03-24 11:48:27.000000000 +0100
++++ src/database/enginelist.cpp 2013-03-24 11:48:59.000000000 +0100
+@@ -50,7 +50,12 @@
+ QString path1 = path + "/engines-linux/uci";
+ QString path2 = path + "/engines-linux/winboard";
+ #endif
+-
++
++#ifdef Q_OS_FREEBSD
++ QString path1 = path + "/engines-freebsd/uci";
++ QString path2 = path + "/engines-freebsd/winboard";
++#endif
++
+ restoreEmptyFromPath(path1, EngineData::UCI);
+ restoreEmptyFromPath(path2, EngineData::WinBoard);
+ }
diff --git a/games/chessx/pkg-descr b/games/chessx/pkg-descr
new file mode 100644
index 000000000000..54e295484c12
--- /dev/null
+++ b/games/chessx/pkg-descr
@@ -0,0 +1,6 @@
+ChessX is an open source chess database based on Qt4. With ChessX you
+can operate on your collection of chess games in many ways: browse,
+edit, add, organize, analyze, etc. Additionally ChessX can interface
+with chess engines via UCI and Winboard protocol.
+
+WWW: http://chessx.sourceforge.net/