aboutsummaryrefslogtreecommitdiffstats
path: root/games/chroma
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-08 04:27:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-08 04:27:29 +0800
commitf383441b64eb856f9f44e5c066a4c188a070a4b1 (patch)
tree3e217a259d6bb891bd3f72291dec93ec3b6c52f2 /games/chroma
parentab984ff58e9b698d3043c4ca5942019fe3cd3516 (diff)
downloadfreebsd-ports-gnome-f383441b64eb856f9f44e5c066a4c188a070a4b1.tar.gz
freebsd-ports-gnome-f383441b64eb856f9f44e5c066a4c188a070a4b1.tar.zst
freebsd-ports-gnome-f383441b64eb856f9f44e5c066a4c188a070a4b1.zip
- Use new OPTIONS features
Diffstat (limited to 'games/chroma')
-rw-r--r--games/chroma/Makefile24
1 files changed, 7 insertions, 17 deletions
diff --git a/games/chroma/Makefile b/games/chroma/Makefile
index 453c7e1a0de8..0b60d4185910 100644
--- a/games/chroma/Makefile
+++ b/games/chroma/Makefile
@@ -18,38 +18,28 @@ CONFIGURE_ENV= LIBS="-lintl"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= README
+PORTDOCS= *
PORTDATA= *
OPTIONS_DEFINE= DOCS
OPTIONS_MULTI= INTERFACES
-OPTIONS_MULTI_INTERFACES= SDL CURSES
+OPTIONS_MULTI_INTERFACES=SDL CURSES
OPTIONS_DEFAULT=SDL CURSES
SDL_DESC= Enable SDL interface
CURSES_DESC= Enable curses interface
-OPTIONS_SUB= yes
-CURSES_USES= ncurses
+OPTIONS_SUB= yes
+CURSES_USES= ncurses
CURSES_CONFIGURE_ENABLE=curses
+CURSES_PLIST_FILES= bin/${PORTNAME}-curses
SDL_CONFIGURE_ENABLE= sdl
SDL_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+SDL_USE= SDL=sdl,image
+SDL_PLIST_FILES= bin/${PORTNAME}
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL+= sdl image
-PLIST_FILES+= bin/${PORTNAME}
-.endif
-
-.if ${PORT_OPTIONS:MCURSES}
-PLIST_FILES+= bin/${PORTNAME}-curses
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
-.endif
.include <bsd.port.mk>