aboutsummaryrefslogtreecommitdiffstats
path: root/games/cleanq3
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-26 07:00:50 +0800
committermarino <marino@FreeBSD.org>2015-03-26 07:00:50 +0800
commit0c8bec8d1565cd01e8fc1017de057d1986719d12 (patch)
tree2f9cd8c0a819b520aa1b353994707173199cca50 /games/cleanq3
parent5db5908d4795f6a79fd122fbe80953bd1e2104c2 (diff)
downloadfreebsd-ports-gnome-0c8bec8d1565cd01e8fc1017de057d1986719d12.tar.gz
freebsd-ports-gnome-0c8bec8d1565cd01e8fc1017de057d1986719d12.tar.zst
freebsd-ports-gnome-0c8bec8d1565cd01e8fc1017de057d1986719d12.zip
games category: Remove $PTHREAD_LIBS
approved by: PTHREAD blanket
Diffstat (limited to 'games/cleanq3')
-rw-r--r--games/cleanq3/Makefile2
-rw-r--r--games/cleanq3/files/patch-code-unix-Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/games/cleanq3/Makefile b/games/cleanq3/Makefile
index 17b64b1e8cec..b3d0331eae90 100644
--- a/games/cleanq3/Makefile
+++ b/games/cleanq3/Makefile
@@ -66,7 +66,7 @@ PLIST_SUB+= CLIENT="@comment "
.endif
.if ${PORT_OPTIONS:MSMP_CLIENT}
-MAKE_ENV+= SMP=YES PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV+= SMP=YES
PLIST_SUB+= SMP_CLIENT=""
Q3BIN+= cleanq3-smp
.else
diff --git a/games/cleanq3/files/patch-code-unix-Makefile b/games/cleanq3/files/patch-code-unix-Makefile
index ca8955dff06a..e0065e05fec8 100644
--- a/games/cleanq3/files/patch-code-unix-Makefile
+++ b/games/cleanq3/files/patch-code-unix-Makefile
@@ -87,7 +87,7 @@
RANLIB=ranlib
-THREAD_LDFLAGS=-lpthread
-+THREAD_LDFLAGS=$(PTHREAD_LIBS)
++THREAD_LDFLAGS=-lpthread
# don't need -ldl (FreeBSD)
-LDFLAGS=-lm
+LDFLAGS+=-lm