aboutsummaryrefslogtreecommitdiffstats
path: root/games/crashtest/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-11-14 23:10:20 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-11-14 23:10:20 +0800
commite271d43e2bb42c8c70fee2e8d288f5e2fb8e3b6d (patch)
tree593e29166b5f5b31c8248f6ee821de0bddf8e460 /games/crashtest/Makefile
parent0f46cd2ae83de11827cf31e8429f88625fd42fb2 (diff)
downloadfreebsd-ports-gnome-e271d43e2bb42c8c70fee2e8d288f5e2fb8e3b6d.tar.gz
freebsd-ports-gnome-e271d43e2bb42c8c70fee2e8d288f5e2fb8e3b6d.tar.zst
freebsd-ports-gnome-e271d43e2bb42c8c70fee2e8d288f5e2fb8e3b6d.zip
- Add games/crashtest
Crashtest simulates car crashes. This is an educational tool that can be used to acquire much insight into this complex process. The user can learn about the relation between speed, reaction-time and stopping distance. Also, many physical properties can be studied. WWW: http://www.stolk.org/crashtest/
Diffstat (limited to 'games/crashtest/Makefile')
-rw-r--r--games/crashtest/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/games/crashtest/Makefile b/games/crashtest/Makefile
new file mode 100644
index 000000000000..df1aae3a41bf
--- /dev/null
+++ b/games/crashtest/Makefile
@@ -0,0 +1,47 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= crashtest
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= http://www.stolk.org/crashtest/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Educational crash simulator
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:devel/ode \
+ ${LOCALBASE}/lib/libplibul.a:x11-toolkits/plib
+LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
+
+USE_GL= gl glu
+
+BUILD_WRKSRC= ${WRKSRC}/src-crashtest
+
+PORTDOCS= *
+PORTDATA= *
+PLIST_FILES= bin/${PORTNAME}
+
+DESKTOP_ENTRIES="${PORTNAME}" \
+ "" \
+ "" \
+ "${PORTNAME}" \
+ "Game;Simulation;Physics;" \
+ ""
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/src-crashtest/crashtest.cxx
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}/models
+ ${INSTALL_DATA} ${WRKSRC}/models-crashtest/*.3ds ${STAGEDIR}${DATADIR}/models
+ ${INSTALL_DATA} ${WRKSRC}/models-crashtest/*.ac ${STAGEDIR}${DATADIR}/models
+ ${INSTALL_DATA} ${WRKSRC}/models-crashtest/*.bmp ${STAGEDIR}${DATADIR}/models
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>