aboutsummaryrefslogtreecommitdiffstats
path: root/games/crossfire-server
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1996-11-04 03:19:20 +0800
committerandreas <andreas@FreeBSD.org>1996-11-04 03:19:20 +0800
commit6ca8efe9aecce95957368e304c3c20510151bfd2 (patch)
tree7248fa30e539b0210a572e241d8c13793a1ff082 /games/crossfire-server
parentf3106d17174d72f883884468959ae001abf8a7ba (diff)
downloadfreebsd-ports-gnome-6ca8efe9aecce95957368e304c3c20510151bfd2.tar.gz
freebsd-ports-gnome-6ca8efe9aecce95957368e304c3c20510151bfd2.tar.zst
freebsd-ports-gnome-6ca8efe9aecce95957368e304c3c20510151bfd2.zip
Added two patches from crossfire mailinglist.
1) get experience points if you use skills 2) don't crash if player logs in with 2 skills enabled 3) cleaned up PLIST (removed 2 player characters of mine which aren't part of the distribution)
Diffstat (limited to 'games/crossfire-server')
-rw-r--r--games/crossfire-server/files/patch-ak31
-rw-r--r--games/crossfire-server/pkg-plist2
2 files changed, 31 insertions, 2 deletions
diff --git a/games/crossfire-server/files/patch-ak b/games/crossfire-server/files/patch-ak
new file mode 100644
index 000000000000..6b90de63dca3
--- /dev/null
+++ b/games/crossfire-server/files/patch-ak
@@ -0,0 +1,31 @@
+Date: Sun, 3 Nov 96 08:03:51 EST
+From: "Brian Thomas" <thomas@astro.psu.edu>
+Message-Id: <9611031303.AA04680@zaphod.astro.psu.edu>
+Subject: CF: skill status upon login
+
+ It is possible right now for a player to log
+ back into a game and have 2 skills readied
+ (applied!). This can confuse the code, and
+ cause problems for a while. This patch
+ fixes that.
+
+ -b.t.
+
+*** server/skill_util.c.orig Tue Oct 29 05:57:46 1996
+--- server/skill_util.c Sun Nov 3 07:57:20 1996
+***************
+*** 877,886 ****
+--- 880,891 ----
+ return 0;
+ }
+ }
+ /* Ok, create linked list and link the associated skills to exp objects */
+ for(i=0;i<sk_index;i++) {
++ /* for startup, lets unapply all skills */
++ if(QUERY_FLAG(sk_ob[i],FLAG_APPLIED)) CLEAR_FLAG(sk_ob[i],FLAG_APPLIED);
+ #ifdef LINKED_SKILL_LIST
+ objectlink *obl;
+ obl = (objectlink *) malloc(sizeof(objectlink));
+ obl->ob=sk_ob[i];
+ obl->id=sk_ob[i]->stats.sp;
+
diff --git a/games/crossfire-server/pkg-plist b/games/crossfire-server/pkg-plist
index 6149f401f880..ced48ab5e88a 100644
--- a/games/crossfire-server/pkg-plist
+++ b/games/crossfire-server/pkg-plist
@@ -1494,8 +1494,6 @@ crossfire/lib/maps/world/world_e1
crossfire/lib/maps/world/world_e2
crossfire/lib/messages
crossfire/lib/motd
-crossfire/lib/players/andreas.pl
-crossfire/lib/players/crusher.pl
crossfire/lib/races
crossfire/lib/skill_params
crossfire/lib/sounds