aboutsummaryrefslogtreecommitdiffstats
path: root/games/doom-data
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-12 16:06:32 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-12 16:06:32 +0800
commit9752f9ac9754718fcf1046e29c071474a69e749e (patch)
tree36fe9bc878683842de3c4779e9a7645be41dba81 /games/doom-data
parent459303bbf89ffb7d06079da088a4cc1b4961fb93 (diff)
downloadfreebsd-ports-gnome-9752f9ac9754718fcf1046e29c071474a69e749e.tar.gz
freebsd-ports-gnome-9752f9ac9754718fcf1046e29c071474a69e749e.tar.zst
freebsd-ports-gnome-9752f9ac9754718fcf1046e29c071474a69e749e.zip
If port is setting PKGNAMEPREFIX=${FOOPKGNAMEPREFIX}, but .include's this
file before <bsd.port.options.mk>, options handling gets broken because options will be loaded from OPTIONSFILE which is based on UNIQUENAME and thus PKGNAMEPREFIX, which is empty at that point. Prevent this: ensure that FOOPKGNAMEPREFIX is defined in advance for ports that use it to set their PKGNAMEPREFIX and having OPTIONS.
Diffstat (limited to 'games/doom-data')
-rw-r--r--games/doom-data/Makefile.include4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/doom-data/Makefile.include b/games/doom-data/Makefile.include
index 6c262202ab38..e85c68b10d05 100644
--- a/games/doom-data/Makefile.include
+++ b/games/doom-data/Makefile.include
@@ -3,6 +3,10 @@
DMPKGNAMEPREFIX?= doom-
DMDIR?= ${LOCALBASE}/share/doom
+.if ${PKGNAMEPREFIX} == ${DMPKGNAMEPREFIX} && defined(OPTIONSMKINCLUDED)
+. error include before <bsd.port.options.mk> if using DMPKGNAMEPREFIX
+.endif
+
MAKE_ENV+= DMDIR="${DMDIR}"
PLIST_SUB+= DMDIR="${DMDIR:S/${LOCALBASE}\///}"
SUB_LIST+= DMDIR="${DMDIR}"