aboutsummaryrefslogtreecommitdiffstats
path: root/games/easysok/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-12-06 02:31:13 +0800
committerkrion <krion@FreeBSD.org>2004-12-06 02:31:13 +0800
commitccb79dc7bc4e709295059078dcd208439fcdb0a0 (patch)
tree3fbc4541cd0bfb70c3e75a032b178ab6199436be /games/easysok/Makefile
parent0428f0fb2e02224943a4b3e9b2e8cb657e9f3df8 (diff)
downloadfreebsd-ports-gnome-ccb79dc7bc4e709295059078dcd208439fcdb0a0.tar.gz
freebsd-ports-gnome-ccb79dc7bc4e709295059078dcd208439fcdb0a0.tar.zst
freebsd-ports-gnome-ccb79dc7bc4e709295059078dcd208439fcdb0a0.zip
Fix build on amd64/ia64
PR: ports/74729 Submitted by: Ports Fury
Diffstat (limited to 'games/easysok/Makefile')
-rw-r--r--games/easysok/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/easysok/Makefile b/games/easysok/Makefile
index ee7fb514c8bd..a7533c8797d8 100644
--- a/games/easysok/Makefile
+++ b/games/easysok/Makefile
@@ -19,6 +19,12 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g ; \
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -26,4 +32,4 @@ post-patch:
's|-lkdeprint|$$(LIB_KDEPRINT) $$(LIBPTHREAD)|g' \
${WRKSRC}/src/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>