aboutsummaryrefslogtreecommitdiffstats
path: root/games/enigma/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-23 13:13:03 +0800
committeredwin <edwin@FreeBSD.org>2003-02-23 13:13:03 +0800
commitdd46144a82c0261e229377c7487081c788fe50e9 (patch)
treea654e78ad266d3e9772c193ef615eac1f8789d09 /games/enigma/Makefile
parent8e90aacb09d85a47ff2fb6526ee94d74784a2c67 (diff)
downloadfreebsd-ports-gnome-dd46144a82c0261e229377c7487081c788fe50e9.tar.gz
freebsd-ports-gnome-dd46144a82c0261e229377c7487081c788fe50e9.tar.zst
freebsd-ports-gnome-dd46144a82c0261e229377c7487081c788fe50e9.zip
Maintainer update to version 0.70, with lots of new levels!
Diffstat (limited to 'games/enigma/Makefile')
-rw-r--r--games/enigma/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 6a0f6c35b6c5..0c7e2bad80b6 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= enigma
-PORTVERSION= 0.60
+PORTVERSION= 0.70
CATEGORIES= games
MASTER_SITES= http://savannah.nongnu.org/download/enigma/
MAINTAINER= edwin@mavetju.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
-BUILD_DEPENDS= ${LOCALBASE}/bin/sdl11-config:${PORTSDIR}/devel/sdl12 \
+BUILD_DEPENDS= sdl11-config:${PORTSDIR}/devel/sdl12 \
lua:${PORTSDIR}/lang/lua
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_image.10:${PORTSDIR}/graphics/sdl_image
@@ -21,12 +21,16 @@ LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_REINPLACE= yes
+USE_GMAKE= yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ARGS= --target=""
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
MAN6= enigma.6
post-install:
- ${CAT} pkg-message
+ @${CAT} pkg-message
.include <bsd.port.mk>