aboutsummaryrefslogtreecommitdiffstats
path: root/games/enigma
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /games/enigma
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'games/enigma')
-rw-r--r--games/enigma/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index bfdc8f45b5eb..12978c98adee 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -26,8 +26,8 @@ USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-cxxlua \
--with-libintl-prefix="${LOCALBASE}"
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}" \
- CPPFLAGS="-I${LOCALBASE}/include -I${LUA_INCDIR}"
+CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR}
+LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}